Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Virtio lässt sich als Rootdevice beim Booten nicht einhängen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
boospy
Apprentice
Apprentice


Joined: 07 Feb 2010
Posts: 299
Location: Austria

PostPosted: Mon Jan 03, 2011 6:45 pm    Post subject: Virtio lässt sich als Rootdevice beim Booten nicht einhängen Reply with quote

Hallo Leute

Habe ein virtuelles Gentoo auf KVM laufen. Virtion ist im Kernel, und es funktioniert bei Festplatten auch wenn man eine Zusätzliche im laufendem Betrieb ranhängt. Nur wenn ich die Rootfestplatte als Virtio deklariere, bootet zwar der Kernel, aber nur bis zum Einhängen von "/". Fehlermeldung:

Code:
Blockdevice /dev/vda1 is not a valid root device...
Could not find the root block device in.
Please specify another value or. press ENTER for the same.


Was muss sein damit das Teil richtig gemountet wird? VDA1 stimmt, sonst würde ja der Kernel nicht booten. Und das steht auch in der FSTAB.

lg
boospy
Back to top
View user's profile Send private message
Beforegod
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 1493
Location: Frankfurt/Main

PostPosted: Fri Jan 07, 2011 9:11 am    Post subject: Reply with quote

Interessant wäre die Bezeichnung innerhalb der VM.
Es scheint als findert er dort /dev/vda1 nicht. Hast Du es mal mit Labels oder uuid probiert (/dev/root innerhalb der VM). Evt. kann er damit was anfangen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum