Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Install-zwang: consolekit, policykit, device-mapper
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Tue Jan 04, 2011 6:55 pm    Post subject: [solved] Install-zwang: consolekit, policykit, device-mapper Reply with quote

Hallo,

ich hab mal wieder ein Update gemacht. Und da erscheint auf einmal:
Code:
emerge -puND world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] sys-fs/lvm2-2.02.74  USE="lvm1 readline static (-clvm) (-cman) (-selinux)"
[ebuild  N    ] dev-libs/libatasmart-0.17
[ebuild   R   ] sys-block/parted-2.3  USE="device-mapper*"
[ebuild  N    ] sys-auth/polkit-0.99-r1  USE="doc examples gtk nls -debug (-introspection) -pam"
[ebuild  N    ] gnome-extra/polkit-gnome-0.99  USE="doc examples (-introspection)"
[ebuild  N    ] sys-auth/consolekit-0.4.3  USE="doc policykit -debug -pam -test"
[ebuild  N    ] sys-auth/polkit-qt-0.96.1  USE="examples -debug"
[ebuild   R   ] gnome-base/gconf-2.32.0-r1  USE="policykit*"
[ebuild  N    ] sys-fs/udisks-1.0.2  USE="bash-completion doc nls -debug -remote-access"
[ebuild     U ] media-sound/clementine-0.6-r2 [0.5.3] USE="dbus%* lastfm%* udev%* -ayatana%" LINGUAS="-be% -br% -cy% -eo% -et% -eu% -he% -hi% -ja%"
[ebuild   R   ] kde-base/kdelibs-4.5.4  USE="policykit*"
[ebuild  N    ] sys-auth/polkit-kde-0.95.1-r1  USE="(-aqua) -debug (-kdeenablefinal)" LINGUAS="pt_BR -da -en_GB -et -gl -lt -nl -pt -sk -sv -uk -zh_TW"


Nun ja, ich konnte bisher ganz gut ohne Consolekit, Policykit und Device-Mapper leben. Deaktivier ich das Zeug in den Use-Flags, bekomm ich folgendes:
Code:
emerge -puND world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=sys-auth/consolekit-0.4[policykit]".
!!! One of the following packages is required to complete your request:
- sys-auth/consolekit-0.4.3 (Change USE: +policykit)
(dependency required by "sys-auth/polkit-0.99-r1" [ebuild])
(dependency required by "sys-fs/udisks-1.0.2" [ebuild])
(dependency required by "media-sound/clementine-0.6-r2" [ebuild])
(dependency required by "@selected")
(dependency required by "@world" [argument])


Ich hab weder lvm noch verschlüsselte Partitionen im Einsatz. Und Desktop-Manager ist bei mir e16. Ein Session-Handling brauch ich nicht. Damit entfällt der Sinn für Consolekit. Wie krieg ich diesen Rattenschwanz wieder los?


Last edited by musv on Tue Jan 04, 2011 9:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Tue Jan 04, 2011 7:04 pm    Post subject: Reply with quote

kommt durch clementine-0.6-r2. Das hat als abhängigkeit udisk wenn die use-flags dbus und udev aktiv sind.
Quote:
dbus? ( udev? ( sys-fs/udisks ) )

und sys-fs/udisk-1.0.2 hat als feste Abhängigkeit sys-auth/polkit.
Und olkit hat als feste Abhängigkeit consolekit:
Quote:
>=sys-auth/consolekit-0.4[policykit]


Edith: Aber das steht auch fast alles in der Meldung von portage ;)
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Tue Jan 04, 2011 9:15 pm    Post subject: Reply with quote

hattest recht.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum