Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Probleme mit Fritz!Wlan N (AR9170 Chip) Wlan Verbindung
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Zaiko
n00b
n00b


Joined: 21 Oct 2010
Posts: 21

PostPosted: Fri Jan 07, 2011 1:36 pm    Post subject: Probleme mit Fritz!Wlan N (AR9170 Chip) Wlan Verbindung Reply with quote

Hallo,
meine Wlan-Verbindung ist sehr instabil. Manchmal besteht sie direkt nach dem starten von KDE, manchmal wiederrum nicht. Wenn sie dann besteht, ist die Geschw. sehr langsam. Manchmal kommt es auch vor, dass sie ohne jeglichen Grund abbricht, und wlan0 von ifconfig verschwindet.
Das Gerät lässt sich dann auch nicht mehr starten
Code:
ifconfig wlan0 up > SIOCSIFFLAGS: Connection timed out

Hier hilft jetzt nur ein restart der Module oder des Systems. Dmesg liefert folgendes aus:
Code:
[   41.207013] ar9170 cmd: 00 00 00 00                                      ....
[   41.207016] Pid: 2801, comm: ifconfig Tainted: P            2.6.36-gentoo-r5 #17
[   41.207017] Call Trace:
[   41.207021]  [<ffffffff813b2f43>] ? print_hex_dump_bytes+0x33/0x40
[   41.207025]  [<ffffffffa0e0abf9>] ar9170_usb_exec_cmd+0x1f9/0x250 [ar9170usb]
[   41.207029]  [<ffffffffa0e0e727>] ar9170_set_beacon_timers+0x87/0xd0 [ar9170usb]
[   41.207033]  [<ffffffffa0e0c38c>] ar9170_op_remove_interface+0x3c/0x80 [ar9170usb]
[   41.207039]  [<ffffffffa0ddff11>] ieee80211_stop+0x1b1/0x520 [mac80211]
[   41.207043]  [<ffffffff8159d5b3>] ? dev_deactivate+0x1c3/0x1e0
[   41.207045]  [<ffffffff815869d8>] __dev_close+0x48/0x80
[   41.207048]  [<ffffffff81585b61>] __dev_change_flags+0xa1/0x180
[   41.207051]  [<ffffffff81586858>] dev_change_flags+0x28/0x70
[   41.207053]  [<ffffffff8160de3c>] devinet_ioctl+0x5fc/0x6b0
[   41.207057]  [<ffffffff8160f6fc>] inet_ioctl+0x8c/0xa0
[   41.207059]  [<ffffffff81574172>] T.1026+0x22/0x60
[   41.207062]  [<ffffffff8157420f>] sock_ioctl+0x5f/0x2b0
[   41.207065]  [<ffffffff8113153f>] do_vfs_ioctl+0x9f/0x540
[   41.207067]  [<ffffffff81131a2f>] sys_ioctl+0x4f/0x80
[   41.207071]  [<ffffffff8100299b>] system_call_fastpath+0x16/0x1b
[   42.207008] usb 7-5: no command feedback received (-110).
[   42.207011] ar9170 cmd: 10 01 00 00 10 36 1c 00 00 00 00 00 14 36 1c 00  .....6.......6..
[   42.207013] ar9170 cmd: 00 00 00 00                                      ....
[   42.207016] Pid: 2801, comm: ifconfig Tainted: P            2.6.36-gentoo-r5 #17
[   42.207017] Call Trace:
[   42.207021]  [<ffffffff813b2f43>] ? print_hex_dump_bytes+0x33/0x40
[   42.207025]  [<ffffffffa0e0abf9>] ar9170_usb_exec_cmd+0x1f9/0x250 [ar9170usb]
[   42.207029]  [<ffffffffa0e0ef3b>] ar9170_set_operating_mode+0xab/0x2f0 [ar9170usb]
[   42.207033]  [<ffffffffa0e0c3b9>] ar9170_op_remove_interface+0x69/0x80 [ar9170usb]
[   42.207039]  [<ffffffffa0ddff11>] ieee80211_stop+0x1b1/0x520 [mac80211]
[   42.207042]  [<ffffffff8159d5b3>] ? dev_deactivate+0x1c3/0x1e0
[   42.207045]  [<ffffffff815869d8>] __dev_close+0x48/0x80
[   42.207047]  [<ffffffff81585b61>] __dev_change_flags+0xa1/0x180
[   42.207050]  [<ffffffff81586858>] dev_change_flags+0x28/0x70
[   42.207053]  [<ffffffff8160de3c>] devinet_ioctl+0x5fc/0x6b0
[   42.207056]  [<ffffffff8160f6fc>] inet_ioctl+0x8c/0xa0s
[   42.207058]  [<ffffffff81574172>] T.1026+0x22/0x60
[   42.207061]  [<ffffffff8157420f>] sock_ioctl+0x5f/0x2b0
[   42.207064]  [<ffffffff8113153f>] do_vfs_ioctl+0x9f/0x540
[   42.207066]  [<ffffffff81131a2f>] sys_ioctl+0x4f/0x80
[   42.207070]  [<ffffffff8100299b>] system_call_fastpath+0x16/0x1b
[   43.207008] phy0: writing reg 0x1d0104 (val 0x0) failed
[   44.207015] phy0: writing reg 0x1c3d30 (val 0x0) failed


Besteht das Problem in der Zeit nicht, so sieht das bei dmesg so aus:
Code:
[ 2145.204030] usb 7-5: USB setup failed (-110).
[ 2508.660025] usbcore: deregistering interface driver ar9170usb
[ 2519.091702] cfg80211: Calling CRDA to update world regulatory domain
[ 2519.232014] usb 7-5: reset high speed USB device using ehci_hcd and address 3
[ 2520.365075] usbcore: registered new interface driver ar9170usb
[ 2520.593735] ath: EEPROM regdomain: 0x8114
[ 2520.593738] ath: EEPROM indicates we should expect a country code
[ 2520.593740] ath: doing EEPROM country->regdmn map search
[ 2520.593741] ath: country maps to regdmn code: 0x37
[ 2520.593743] ath: Country alpha2 being used: DE
[ 2520.593745] ath: Regpair used: 0x37
[ 2520.593839] phy0: Selected rate control algorithm 'minstrel_ht'
[ 2520.594418] cfg80211: Calling CRDA for country: DE
[ 2520.595262] Registered led device: ar9170-phy0::tx
[ 2520.595284] Registered led device: ar9170-phy0::assoc
[ 2520.595287] usb 7-5: Atheros AR9170 is registered as 'phy0'


Ich benutzt WICD als Netzwerkmanager. Bei der installation von Fritz!Wlan habe ich diese Firmware unter /lib/firmware kopiert: http://linuxwireless.org/en/users/Drivers/ar9170. Ich habe den 2.6.36-gentoo-r5 Kernel.

Woran liegt es, dass es so instabil läuft? Braucht ihr noch mehr Informationen?

Gruß
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum