Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sehr lange Startzeit von Win2K in Virtualbox
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Murmeltier
n00b
n00b


Joined: 14 May 2008
Posts: 32

PostPosted: Sun Jan 16, 2011 10:08 am    Post subject: Sehr lange Startzeit von Win2K in Virtualbox Reply with quote

Hallo zusammen,
habe hier zur Zeit Virtualbox 3.2.12 laufen (weil die Module von 3.1.8 nicht mit Kernel 2.6.36 kompilieren...).
Meine existierende VM mit Win 2000 startet nun extrem langsam (sobald der grafische Startbildschirm erscheint).
Andere VMs (z.B. eine mit Gentoo) starten normal. Das VBox Logfile sagt nicht viel, es dokumentiert nur die lange Pause von fast 45 Minuten!
Wenn's dann endlich so weit ist, verhält es sich normal, d.h. W2K ist normal benutzbar.

00:00:08.288 Guest Log: BIOS: Boot from CD-ROM failed
00:00:08.296 Guest Log: BIOS: Booting from Hard Disk...
00:00:09.473 Guest Log: BIOS: int13_harddisk: function 15, unmapped device for ELDL=83
00:00:17.176 PIT: mode=2 count=0x2ead (11949) - 99.85 Hz (ch=0)
00:00:17.710 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=b1792000 w=640 h=480 bpp=0 cbLine=0x140
00:43:19.939 PIIX3 ATA: LUN#0: IDLE IMMEDIATE, CmdIf=0xc4 (-1 usec ago)
00:43:19.939 PIIX3 ATA: LUN#0: aborting current command
00:43:35.141 PIIX3 ATA: Ctl#0: RESET, DevSel=0 AIOIf=1 CmdIf0=0xe1 (-1 usec ago) CmdIf1=0xc4 (-1 usec ago)

Habe versucht, W2K frisch in einer neuen VM zu installieren, selbes Problem, nach dem Reboot und Wechsel auf den Startbildschirm hängt es scheinbar.
Mit älteren Versionen von VBox war dies nicht so, allerdings kann ich nicht gut zurück wegen der Kernelversion.
Kennt jemand dieses Problem?
Danke...

Virtualbox-bin 3.2.12-r68302
Linux Obelix 2.6.36-gentoo-r5 #2 Sat Jan 8 12:20:30 CET 2011 i686 Intel(R) Pentium(R) 4 CPU 1.70GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Sun Jan 16, 2011 2:48 pm    Post subject: Reply with quote

W2K... schon VBox 4 probiert (läuft hier unter Win und Lin stabil.)

Außer so ein seltsames "IRQL_DRIVER_LESS_OR_EQUAL" BSOD unter WinXP mit aktiviertem 3D (bzw eig. installierten VBox 3D Erweiterung im Guest)
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Murmeltier
n00b
n00b


Joined: 14 May 2008
Posts: 32

PostPosted: Mon Jan 17, 2011 5:07 pm    Post subject: Reply with quote

Danke, 4.0 ist zwar nicht schneller bei diesem speziellen Problem, aber ich lasse es nun installiert, wenn es schonmal da ist.
Werde mich wohl damit abfinden müssen. Wenn die VM endlich mal aufgestartet ist, werde ich sie bei Nichtgebrauch einfach "einfrieren". Dann geht das Aufstarten nachher in vernünftiger Zeit. Kompromiss halt...
Danke, mfg
Murmel
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1423
Location: germany

PostPosted: Tue Jan 18, 2011 8:50 am    Post subject: Re: Sehr lange Startzeit von Win2K in Virtualbox Reply with quote

Murmeltier wrote:
Meine existierende VM mit Win 2000 startet nun extrem langsam (sobald der grafische Startbildschirm erscheint).
Andere VMs (z.B. eine mit Gentoo) starten normal. Das VBox Logfile sagt nicht viel, es dokumentiert nur die lange Pause von fast 45 Minuten!
Wenn's dann endlich so weit ist, verhält es sich normal, d.h. W2K ist normal benutzbar.

Hallo Murmeltier. Ich habe meine Win2k Testinstallation leider schon länger nicht mehr gebootet, aber sobald ich wieder zu Hause an meiner VBox-Testmaschine bin, hole ich das gleich mal nach. Allerdings kann ich mich erinnern, daß ich mit keiner 3.2.x Version solch ein Verhalten beobachten konnte. Das Win2k bootete immer sauber und ohne Verzögerung durch. Mein einziges Problem mit meinem Win2k-Gastsystem sind immer zu 100% ausgelastete CPUs. Das beeinflußt zwar die Performance nur minimal, aber es nervt schon wenn die Host-CPUs trotz ondemand gouvernor immer auf ihrer Maximalfrequenz laufen.

Max Steel wrote:
Außer so ein seltsames "IRQL_DRIVER_LESS_OR_EQUAL" BSOD unter WinXP mit aktiviertem 3D (bzw eig. installierten VBox 3D Erweiterung im Guest)

Siehe driver_irql_not_lesss_or_equal after 4.0.0 upgrade. Scheint ein Problem zu sein, das nur auf AMD-Systemen auftritt. Mein XP-Gastsystem auf einem Intel-Notebook hat dieses Problem nicht. Leider weiß ich nicht, ob das Problem den VBox-Entwicklern bekannt ist, und kann daher nicht versprechen, daß das Problem mit virtualbox-4.0.2 behoben sein wird.
_________________
The manual said "Requires Windows10 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
Murmeltier
n00b
n00b


Joined: 14 May 2008
Posts: 32

PostPosted: Tue Jan 18, 2011 10:27 am    Post subject: Sehr lange Startzeit von Win2K in Virtualbox Reply with quote

Danke an alle, ich habe zumindest inzwischen herausgefunden, wie man das Problem entschärfen kann:
Offensichtlich bootet W2K so extrem langsam, wenn VBox nicht die volle CPU-Last vom Host bekommen kann.

Szenario 1:
KDE 4.4.5, es läuft zwar wenig Grundlast (Sys-Monitor...), aber VirtualBox zieht maximal ca. 65-70% CPU Last, der Rest geht vor allem an X
--> W2K braucht 30-40 MINUTEN bis diese ganze "Klötzchen" auf dem Startschirm durch sind und die Anmeldung kommt (danach ist das Tempo ok)

Szenario 2:
Nur X und twm gestartet (Ohne kde session), VirtualBox zieht sich ca. 85-90% CPU, Rest ist für X
--> W2K bootet in 30 Sekunden zum Anmeldeprompt durch (!!!)

Gut, der PC ist alt, aber so einen Effekt hatte ich nicht erwartet.
In Szenario 1 hätte ich vielleicht mit der knapp doppelten Startzeit gerechnet, aber nicht mit dem 60-fachen :-/

Danke und Gruss
Murmel
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1423
Location: germany

PostPosted: Wed Jan 19, 2011 6:28 pm    Post subject: Reply with quote

Hallo Murmeltier. Ja, die starke CPU-Auslastung könnte der Grund sein. Ich habe gestern auch nochmal meine Win2k-VM getestet und konnte das von dir beschriebene Verhalten weder unter virtualbox-3.2.12 noch unter virtualbox-4.0.2 nachvollziehen. Allerdings habe ich der VM auch zwei CPUs zugewiesen und habe AMD-V aktiviert. Das hilft zwar nicht die 100%ige Auslastung der zugewiesenen CPUs zu reduzieren, aber möglicherweise ist das der Grund, daß die Auslastung die VM nicht zu langsam werden läßt.
_________________
The manual said "Requires Windows10 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
schmutzfinger
Veteran
Veteran


Joined: 26 Oct 2003
Posts: 1287
Location: Dresden/Germany

PostPosted: Wed Jan 19, 2011 8:51 pm    Post subject: Reply with quote

Das sieht mir nach kaputten Gerätentreibern im Gast oder kaputter Geräteemulation in VirtualBox aus. Es ist auf jeden Fall empfehlenswert die vbox-Gerätetreibertreiber im Gast zu installieren.
Ausserdem kannst du die Geräte mal variieren. Also erstmal alle unnötigen Geräte wie Netzwerkkarten, Festplatten(-controller), USB etc. aus der VM rausnehmen. Und dann Stück für Stück wieder "anschliessen". Bei Geräten wie Grafikkarte, Netzwerkkarte, Festplatten-Controller kannst du bei vbox auch zwischen mehreren Modellen wählen.
Ausserdem solltest du mal mit den Einstellungen AMD-SVM/Intel-VT, Nested Paging und der Anzahl der virtuellen CPUs spielen. Du solltest vbox so genau wie möglich sagen, welches Gastsystem du verwendest. Das dürfte besonders hilfreich sein wenn du keine Hardware-Unterstützung für Virtualisierung verwendest.
Back to top
View user's profile Send private message
Murmeltier
n00b
n00b


Joined: 14 May 2008
Posts: 32

PostPosted: Thu Jan 20, 2011 10:12 am    Post subject: Reply with quote

Danke, die VBox-Gasterweiterungen sind schon installiert und ich habe auch schon mit diversen Geräten gespielt (Ohne Netzwerk, usw.).
Es ändert nichts grundsätzliches, wahrscheinlich hat die alte CPU nicht genug Reserven (es ist ein Pentium IV, nix mit VT, mehrere CPUs ;-)) und es kommen sicher auch andere Dinge ungünstig zusammen.
Weil die VM im Betrieb schnell genug ist, friere ich sie einfach ein bis zum nächsten Gebrauch (was nur selten ist) und spare den Bootvorgang.
Damit kann ich leben, bis mal ein neuer PC Einzug hält.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum