Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]VirtualBox 4.0.0 + extpack - remote access auth
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Mon Jan 17, 2011 4:45 am    Post subject: [Solved]VirtualBox 4.0.0 + extpack - remote access auth Reply with quote

I have VirtualBox 4.0.0 installed on my amd64 Gentoo system.
Code:
app-emulation/virtualbox-4.0.0-r1
app-emulation/virtualbox-additions-4.0.0
app-emulation/virtualbox-extpack-oracle-4.0.0
app-emulation/virtualbox-modules-4.0.0

I have configured a Windows XP Pro VM to have remote desktop server port of 3390, for testing purposes

I can only convince remote access to my VM by using the NULL Authentication Method.

I have tried External, providing a gentoo user/password in the 'rdesktop' command line
Code:
rdesktop -u gentoouser -p gentoopassword hostmachine.ip.address:3390


I have tried Guest, providing a user/password that is used to login to the guest Windows XP Pro.
Code:
rdesktop -u windowsUser -p windowsPassword hostmachine.ip.address:3390


I would prefer External to work.

Any suggestions as to what is going on?
_________________
...Lyall


Last edited by lyallp on Mon Jan 17, 2011 10:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
Etrnls
n00b
n00b


Joined: 20 Dec 2008
Posts: 8

PostPosted: Mon Jan 17, 2011 2:58 pm    Post subject: Reply with quote

Some problem and I did this to make it work

Code:

cd /usr/lib/virtualbox
ln -s VBoxAuth.so VRDPAuth.so


Because VB complains about not able to find VRDPAuth.so and the online document of VB says that VBoxAuth.so is in charge of this work...
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Mon Jan 17, 2011 10:13 pm    Post subject: Reply with quote

You are Awesome!
I did not check that the shared library actually existed - I assumed and made an A** of me.

Raised bug 351949 in bugzilla.
_________________
...Lyall
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum