Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE startet nach Update nicht mehr
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Mon Jan 31, 2011 7:00 pm    Post subject: KDE startet nach Update nicht mehr Reply with quote

Hallo Zusammen,

leider startet KDE nach einem Update nicht mehr. :(

Ich bekomme folgende Fehlermeldung:
Code:
kdeinit4: Aborting. $DISPLAY is not set


Im Syslog ist leider nichts zu finden, aber in der "kdm.log" steht:

Code:
********************************************************************************
Note that your system uses syslog. All of kdm's internally generated messages
(i.e., not from libraries and external programs/scripts it uses) go to the
daemon.* syslog facility; check your syslog configuration to find out to which
file(s) it is logged. PAM logs messages related to authentication to authpriv.*.
********************************************************************************

/usr/lib/kde4/libexec/kdm_greet: symbol lookup error: /usr/lib/qt4/libQtGui.so.4: undefined symbol: _ZN23QCoreApplicationPrivate19checkReceiverThreadEP7QObject


Hat Jemand eine Idee woran das liegen könnte, oder besser noch, wie man das Problem behebt?
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4416

PostPosted: Mon Jan 31, 2011 7:08 pm    Post subject: Reply with quote

Das Problem hat ncihst mit kde zu tun.
So einen Fehler bekommt man meist dann, wenn unterschiedliche inkompatible Versionen von libQtGui und libQtCore installiert sind. Flattert da bei dir sowas rum? Setz mal ein find nach libQtCore und libQtGui in den üblichen Dirs ab (/usr/lib,/usr/local/lib, ...)
Wenn nicht dann versuch mal eine Neuinstallation von qt-core und qt-gui.
BTW.: Welche Versiionen der ganzen x11-libs/qt-* hast du installiert?
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Mon Jan 31, 2011 7:22 pm    Post subject: Reply with quote

franzf wrote:
[...] Welche Versiionen der ganzen x11-libs/qt-* hast du installiert?


Code:
g2 ~ # qlist -ICv x11-libs/qt-
x11-libs/qt-core-4.7.1-r1
x11-libs/qt-dbus-4.7.1
x11-libs/qt-declarative-4.7.1-r2
x11-libs/qt-gui-4.7.1-r1
x11-libs/qt-opengl-4.7.1
x11-libs/qt-qt3support-4.7.1
x11-libs/qt-script-4.7.1-r1
x11-libs/qt-sql-4.7.1-r1
x11-libs/qt-svg-4.7.1
x11-libs/qt-test-4.7.1
x11-libs/qt-webkit-4.7.1-r1
x11-libs/qt-xmlpatterns-4.7.1
g2 ~ #


Code:
g2 ~ # updatedb
g2 ~ # locate libQtCore
/usr/lib/qt4/libQtCore.prl
/usr/lib/qt4/libQtCore.so
/usr/lib/qt4/libQtCore.so.4
/usr/lib/qt4/libQtCore.so.4.7
/usr/lib/qt4/libQtCore.so.4.7.1
/usr/local/src/lightscribe/opt/lightscribeApplications/common/Qt/libQtCore.so.4
g2 ~ # locate libQtGui
/usr/lib/qt4/libQtGui.prl
/usr/lib/qt4/libQtGui.so
/usr/lib/qt4/libQtGui.so.4
/usr/lib/qt4/libQtGui.so.4.7
/usr/lib/qt4/libQtGui.so.4.7.1
/usr/local/src/lightscribe/opt/lightscribeApplications/common/Qt/libQtGui.so.4
g2 ~ #
Back to top
View user's profile Send private message
bas89
Apprentice
Apprentice


Joined: 02 Mar 2010
Posts: 243
Location: Germany ;)

PostPosted: Tue Feb 01, 2011 5:11 pm    Post subject: Reply with quote

Quote:
/usr/lib/kde4/libexec/kdm_greet: symbol lookup error: /usr/lib/qt4/libQtGui.so.4: undefined symbol: _ZN23QCoreApplicationPrivate19checkReceiverThreadEP7QObject

revdep-rebuild laufen lassen?
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Tue Feb 01, 2011 5:18 pm    Post subject: Reply with quote

[ERLEDIGT]

THX @ franzf

Nach dem remerge von qt-core und qt-gui ging es dann wieder. ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum