Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wicd and kernel-2.6.37 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
bjlockie
Veteran
Veteran


Joined: 18 Oct 2002
Posts: 1186
Location: Canada

PostPosted: Wed Jan 19, 2011 6:02 pm    Post subject: wicd and kernel-2.6.37 [SOLVED] Reply with quote

I updated my kernel and broke wicd.
I'd post on the wicd help forum but it doesn't allow new registrations.
Wicd says "not connected" but the log implies it worked.
ifconfig doesn't show it got an IP.

/var/log/wicd/wicd.log
2011/01/19 12:55:52 :: Putting interface up...
2011/01/19 12:55:54 :: Generating psk...
2011/01/19 12:55:54 :: Attempting to authenticate...
2011/01/19 12:55:56 :: Running DHCP with hostname Gentoo-desktop
2011/01/19 12:55:56 :: dhcpcd[6668]: sending commands to master dhcpcd process
2011/01/19 12:55:56 ::
2011/01/19 12:55:56 ::
2011/01/19 12:55:56 :: DHCP connection successful
2011/01/19 12:55:56 :: not verifying
2011/01/19 12:55:56 :: Connecting thread exiting.
2011/01/19 12:55:56 :: Sending connection attempt result Success
_________________
AMD FX6100 CPU, 16 GiB RAM, OCZ Vertex 3 SSD
ASRock 970 Extreme3 motherboard with S/PDIF audio
Galaxy-NVidia GeForce 8800GT video card, Cyber Power CP550HG USB UPS


Last edited by bjlockie on Mon Jan 24, 2011 4:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5720

PostPosted: Wed Jan 19, 2011 6:12 pm    Post subject: Reply with quote

Does vanilla wpa_supplicant work?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Wed Jan 19, 2011 6:15 pm    Post subject: Reply with quote

Hmm, I've got no issues so far... sure there was no other update possibly breaking it?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
bjlockie
Veteran
Veteran


Joined: 18 Oct 2002
Posts: 1186
Location: Canada

PostPosted: Thu Jan 20, 2011 7:03 am    Post subject: Reply with quote

genstorm wrote:
Hmm, I've got no issues so far... sure there was no other update possibly breaking it?


I think it is the ath9k kernel driver.
I booted an older kernel on the same machine and it works fine.

How does wicd do scanning?

I've been doing:
$ sudo iwlist wlan1 scan
but I noticed wicd can scan even when there is no wlan1 in ifconfig.
_________________
AMD FX6100 CPU, 16 GiB RAM, OCZ Vertex 3 SSD
ASRock 970 Extreme3 motherboard with S/PDIF audio
Galaxy-NVidia GeForce 8800GT video card, Cyber Power CP550HG USB UPS
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum