Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem installoing panda manually
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
LaFolle
n00b
n00b


Joined: 07 Jul 2010
Posts: 34
Location: Aryadesa

PostPosted: Fri Jan 28, 2011 6:07 am    Post subject: Problem installoing panda manually Reply with quote

I am installiing panda3d manually as i cannot see it in portage. I am using ppremake to install as opposed to make. dtool has been built and the error occured while making in .../panda/ directory. ppremake went fine without errors. Error that came on make is:
Code:
Jaguareins panda # make
cd ./src/pandabase && make all
make[1]: Entering directory `/opt/panda3d-1.6.2/panda/src/pandabase'
g++ -ftemplate-depth-30  -c -o Opt3-Linux/pandabase_pandabase.o -I. -I/opt/panda3d-1.6.2/panda -I/usr/local/panda/include    -g -O2 -fPIC pandabase.cxx
g++ -shared  -o Opt3-Linux/libpandabase.so Opt3-Linux/pandabase_pandabase.o  -L/usr/local/panda/lib -L/usr/local/panda/lib -linterrogatedb -ldconfig -ldtoolutil -ldtoolbase -lprc
make[1]: Leaving directory `/opt/panda3d-1.6.2/panda/src/pandabase'
cd ./src/express && make all
make[1]: Entering directory `/opt/panda3d-1.6.2/panda/src/express'
g++ -ftemplate-depth-30  -c -o Opt3-Linux/express_express_composite1.o -I. -I/opt/panda3d-1.6.2/panda -I../pandabase -I/usr/local/panda/include    -g -O2 -fPIC express_composite1.cxx
g++ -ftemplate-depth-30  -c -o Opt3-Linux/express_express_composite2.o -I. -I/opt/panda3d-1.6.2/panda -I../pandabase -I/usr/local/panda/include    -g -O2 -fPIC express_composite2.cxx
g++ -shared  -o Opt3-Linux/libexpress.so Opt3-Linux/express_express_composite1.o Opt3-Linux/express_express_composite2.o -L../pandabase/Opt3-Linux -L/usr/local/panda/lib -L/usr/local/panda/lib -lpandabase -linterrogatedb -ldconfig -ldtoolutil -ldtoolbase -lprc -lz -lssl -lcrypto
make[1]: Leaving directory `/opt/panda3d-1.6.2/panda/src/express'
cd ./src/downloader && make all
make[1]: Entering directory `/opt/panda3d-1.6.2/panda/src/downloader'
g++ -ftemplate-depth-30  -c -o Opt3-Linux/downloader_downloader_composite1.o -I. -I/opt/panda3d-1.6.2/panda -I../express -I../pandabase -I/usr/local/panda/include    -g -O2 -fPIC downloader_composite1.cxx
g++ -ftemplate-depth-30  -c -o Opt3-Linux/downloader_downloader_composite2.o -I. -I/opt/panda3d-1.6.2/panda -I../express -I../pandabase -I/usr/local/panda/include    -g -O2 -fPIC downloader_composite2.cxx
In file included from downloader_composite2.cxx:3:
httpChannel.cxx: In member function 'bool HTTPChannel::run_ssl_handshake()':
 -------->>>  httpChannel.cxx:1575: error: invalid conversion from 'const SSL_CIPHER*' to 'SSL_CIPHER*'
In file included from downloader_composite2.cxx:13:
multiplexStreamBuf.cxx: In member function 'void MultiplexStreamBuf::Output::write_string(const std::string&)':
multiplexStreamBuf.cxx:75: warning: ignoring return value of 'size_t fwrite(const void*, size_t, size_t, FILE*)', declared with attribute warn_unused_result
make[1]: *** [Opt3-Linux/downloader_downloader_composite2.o] Error 1
make[1]: Leaving directory `/opt/panda3d-1.6.2/panda/src/downloader'
make: *** [downloader] Error 2


Panda version is panda-1.6.2.
OpenSSL is 1.0.0c

Thanks
Back to top
View user's profile Send private message
vnd
n00b
n00b


Joined: 28 Jan 2011
Posts: 19

PostPosted: Fri Jan 28, 2011 8:28 pm    Post subject: Reply with quote

Code:
 -------->>>  httpChannel.cxx:1575: error: invalid conversion from 'const SSL_CIPHER*' to 'SSL_CIPHER*'

It looks like this program has been prepared for older version of gcc. You could try gcc v. 4.2 (or lower) or patch these source files by hand - you have to add casting from `const SSL_CIPHER*` to `SSL_CIPHER*` but looking at the size of the sources I think there would be quite a lot of patches needed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum