Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Paket durch irgendein Paket geblockt - wie herausfinden?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Jan 28, 2011 12:48 pm    Post subject: Paket durch irgendein Paket geblockt - wie herausfinden? Reply with quote

Hi,

ich habe KDE4.6 unmasked.
Nun bekomme ich bei einem
emerge --jobs 2 --update --deep @system @world -av --tree --newuse --keep-going

Code:
These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild     U ] kde-misc/yakuake-2.9.7 [2.9.6] USE="(-aqua) (-kdeenablefinal)" LINGUAS="de en_GB -ca -cs -da -el -es -et -fr -ga -gl -hr% -it -ja -ko -nb% -nds -nl -nn -pl -pt -pt_BR -ro -ru -sk% -sv -th -tr -uk -wa -zh_CN (-hne%)" 302 kB                                                                                                                       

Total: 1 package (1 upgrade), Size of downloads: 302 kB

!!! One or more updates have been skipped due to a dependency conflict:

sys-auth/polkit:0

  (sys-auth/polkit-0.99-r1, ebuild scheduled for merge) conflicts with
    <sys-auth/polkit-0.99 required by (gnome-extra/polkit-gnome-0.96-r1, ebuild scheduled for merge)


!!! The following installed packages are masked:
- dev-libs/libattica-0.2.0 (masked by: package.mask)
/var/lib/layman/kde/profiles/package.mask:
# Autogenerated by regenerate-files, DO NOT EDIT.
# You can use this file to mask/unmask KDE SC 4.6 release.
# Edit Documentation/package.unmask/.kde-4.6/ files instead.
# Polkit and other deps



polkit-gnome ist nicht installiert.
Wer will das nun aber installieren?

--tree ist angegeben, sodass es doch eigentlich angezeigt werden müsste?

Danke
Tobi

EDIT:

lösche ich das betreffende Paket, erhalte ich diese Aussage:
Code:
Calculating dependencies... done!
[ebuild     U ] kde-misc/yakuake-2.9.7 [2.9.6] USE="(-aqua) (-kdeenablefinal)" LINGUAS="de en_GB -ca -cs -da -el -es -et -fr -ga -gl -hr% -it -ja -ko -nb% -nds -nl -nn -pl -pt -pt_BR -ro -ru -sk% -sv -th -tr -uk -wa -zh_CN (-hne%)" 302 kB                                                                                                                       
[nomerge      ] net-misc/wicd-1.7.0  USE="X gtk libnotify ncurses nls pm-utils (-ioctl)"
[nomerge      ]  dev-python/notify-python-0.1.1-r1
[nomerge      ]   x11-libs/libnotify-0.4.5
[nomerge      ]    x11-misc/notification-daemon-0.4.0-r1  USE="-debug -gstreamer"
[nomerge      ]     gnome-base/gconf-2.28.1  USE="ldap policykit -debug -doc"
[ebuild  N    ]      sys-auth/polkit-0.99  USE="nls pam -debug -doc -examples (-introspection)" 0 kB


hilft mir auch nicht viel, da ich zumindest wicd benötige.
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 483
Location: münchen.de

PostPosted: Fri Jan 28, 2011 1:13 pm    Post subject: Reply with quote

Laut diesem Thread sollte gnome-extra/polkit-gnome-0.99 nicht mehr von <sys-auth/polkit-0.99 abhängen.
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Jan 28, 2011 1:21 pm    Post subject: Reply with quote

Danke, das hilft.
Mir ging es aber viel mehr um die Frage, wie man das Programm hätte herausfinden können, ohne sys-auth/polkit zu deinstallieren...
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 483
Location: münchen.de

PostPosted: Fri Jan 28, 2011 1:26 pm    Post subject: Reply with quote

Code:

equery d sys-auth/polkit
equery d gnome-extra/polkit-gnome


Das hilft aber iirc nur für bereits installierte Pakete, oder?
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Fri Jan 28, 2011 1:37 pm    Post subject: Reply with quote

das problem ist heir "gnome-base/gconf"
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Fri Jan 28, 2011 4:18 pm    Post subject: Reply with quote

forrestfunk81 wrote:
Code:

equery d sys-auth/polkit
equery d gnome-extra/polkit-gnome


Das hilft aber iirc nur für bereits installierte Pakete, oder?

Für Pakete die noch nicht installiert sind gibt es bei equery auch die Option "-a" (im Zugsamenhang mit depends)
man equery wrote:
depends (d) [OPTIONS] PKG
List all packages that depend on PKG.
......

-a, --all-packages
Include dependencies that are not installed. This can take a while.
(Auszug)
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Fri Jan 28, 2011 4:40 pm    Post subject: Reply with quote

stable gnome und kde-4.6 gehen eh nicht miteinander. Großer Blocker hier war sys-power/upower. gnome will <0.9.6, kde will aktuelle unstable (weiß nicht mehr genau welches Paket das war :( )
upower hat dann entsprechende Anforderungen an polkit:
<upower-0.9.6 -> <polkit-0.9.7
>upower-0.9.6 -> >=polkit-0.9.7
gnome-session lässt sich mit >upower-0.9.5 auch gar nicht bauen.
Also entweder <kde-4.6 oder gnome nach unstable ziehen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum