Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
default xorg keymap ohne KDE settings einrichten - fixed
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2036
Location: Heidelberg - Germany

PostPosted: Mon Jan 31, 2011 4:05 pm    Post subject: default xorg keymap ohne KDE settings einrichten - fixed Reply with quote

Hallo,

"Früher" hatte ich in den KDE setting keine keymap angegeben und trotzdem war die korrekte keymap incl € symbol und \ ~ etc. vorhanden. Mit xorg 1.9 krieg ich das nicht mehr hin obwohl ich folgende Abschitte in der xorg.conf habe:

Code:

Section "InputClass"
   Identifier "keyboard-all"
   Driver "evdev"
   Option "XkbLayout" "de"
   #Option "XkbVariant" "qwertz,nodeadkeys"
   Option "XkbOptions" "grp:alt_shift_toggle,grp:switch,compose:rwin,terminate:ctrl_alt_bksp"

   MatchIsKeyboard "on"
EndSection

Section "InputClass"
   Identifier "mouse-all"
   Driver "evdev"

   MatchIsPointer "on"
EndSection


Ich möchte in meinen Einstellung von KDE unabhängig bleiben. Wie kann man das machen?

Grüße
Erdie


Last edited by Erdie on Wed Feb 02, 2011 5:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3698
Location: Hamburg

PostPosted: Mon Jan 31, 2011 4:17 pm    Post subject: Reply with quote

Code:
tfoerste@n22 ~ $ cat /usr/share/X11/xorg.conf.d/20-keyboard.conf
Section "InputClass"
        Identifier "keyboard-all"
        Driver "evdev"
        Option "XkbLayout" "de(nodeadkeys)"
EndSection
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3674
Location: Germany

PostPosted: Mon Jan 31, 2011 4:17 pm    Post subject: Reply with quote

Hallo

Du kannst deine passende keymap auch global mit in der xorg.conf setzen, zb
Code:
Option   "XkbModel" "deine passende_keymap"
und bei bedarf evtl. auch
Option   "XkbLayout" "de"
Option   "XkbVariant" "nodeadkeys"


Eine Liste der verfügbarer Keymaps findet sich unter /usr/share/X11/xkb/rules/base.lst
Back to top
View user's profile Send private message
disi
Veteran
Veteran


Joined: 28 Nov 2003
Posts: 1354
Location: Out There ...

PostPosted: Mon Jan 31, 2011 4:25 pm    Post subject: Reply with quote

In der .xinitrc in deinem home folder ein einfaches
Code:
setxkbmap gb


Oder welches Layout du hast.
_________________
Gentoo on Uptime Project - Larry is a cow
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Jan 31, 2011 5:10 pm    Post subject: Reply with quote

Das was toralf da gecattet hat, sollte mMn. aber in /etc/X11/xorg.conf.d/ stehen.
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2036
Location: Heidelberg - Germany

PostPosted: Mon Jan 31, 2011 9:21 pm    Post subject: Reply with quote

Danke :)

nur, die Keymap habe ich ja, also alle Umlaute z und y richtig und so, nur alle Tasten, die man mit Alt Gr erreicht wie z. B. ~ fehlen. Welcher Paramter ist dafür verantwortlich?

Grüße
Erdie
Back to top
View user's profile Send private message
mastacloak
Apprentice
Apprentice


Joined: 01 Aug 2004
Posts: 174
Location: Berlin / Germany

PostPosted: Tue Feb 01, 2011 9:01 pm    Post subject: Reply with quote

Gehe ich richtig in der Annahme, dass Du nach
http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.8-upgrade-guide.xml
Deine xorg.conf angepasst hast? Insbesondere hast Du
Code:
Option "XkbOptions" "grp:alt_shift_toggle,grp:switch,compose:rwin,terminate:ctrl_alt_bksp"

eins zu eins übernommen, obwohl darunter explizit gewarnt wird
Quote:
Note: XkbOptions shown in the example file are not to be copied directly to your configs. One of really suprising results for you will be non-working AltGr if you do so.

(allerdings grün und nicht rot hinterlegt, was vielleicht angebracht wäre)
Ich habe z.B. nur
Code:
Option "XkbOptions" "terminate:ctrl_alt_bksp"

damit der X-Server per Ctrl-Alt-Backspace beendet werden kann.

Gruß
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Wed Feb 02, 2011 10:26 am    Post subject: Reply with quote

Code:
cat /etc/X11/xorg.conf.d/10-evdev.conf
#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
        Identifier "keyboard-all"
        MatchIsKeyboard "on"
        Driver "evdev"
        Option "XkbLayout" "de"
EndSection

Section "InputClass"
        Identifier "mouse-all"
        MatchIsPointer "on"
        Driver "evdev"
EndSection


Die Datei mit dem Inhalt anlegen und alles was Eingabe betrifft aus der Xorg.conf raus schmeißen. Dann ging das bis jetzt auf allen Rechnern die ich umgestellt hab. Außer Strg + Alt + Backspace um den X zu killen klappt alles.

Sebastian
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Feb 02, 2011 10:41 am    Post subject: Reply with quote

@Hollowman:
Er braucht XkbLayout = "de(nodeadkeys)", wie bereits von torals gesagt. Sonst kommt man an die AltGr-Binds nur, indem man die Taste zweimal drückt.
Und der Strg+Alt+Backspace macht wieder das was man davon kennt mit
Code:
Option "XkbOptions" "terminate:ctrl_alt_bksp"
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2036
Location: Heidelberg - Germany

PostPosted: Wed Feb 02, 2011 1:51 pm    Post subject: Reply with quote

mastacloak wrote:
Gehe ich richtig in der Annahme, .... Insbesondere hast Du
Code:
Option "XkbOptions" "grp:alt_shift_toggle,grp:switch,compose:rwin,terminate:ctrl_alt_bksp"

eins zu eins übernommen,
Gruß


:oops: Ja, das habe ich, da ich die Warnung übersehen hatte. Wie peinlich. Jetzt geht es, welch ein Wunder ..

sorry und Grüße
Erdie
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum