Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Keine Displaybeleuchtung nach Standby (IBM X60s)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
zeitsofa
n00b
n00b


Joined: 08 Feb 2011
Posts: 9

PostPosted: Tue Feb 08, 2011 3:39 pm    Post subject: [gelöst] Keine Displaybeleuchtung nach Standby (IBM X60s) Reply with quote

Hi zusammen,

ich habe nach dem Aufwachen aus dem Standby keine Displaybeleuchtung mehr.
Einzige hilfe aktuell ist das ich durch Wechseln auf ein anderes TTY die Beleuchtung wieder zum Leben erwecken kann.

Probiert habe ich auch schon die boot option acpi=s3_bios aber das half leider auch nichts.
Meine bisherige Google-Suche war auch nicht sonderlich viel versprechend.

Im ThinkWink gibt es zwar etwas dazu aber bis jetzt noch ohne Erfolg. Vielleicht fällt einem von euch ja etwas passendes ein wie ich das Problem beheben kann.

beste Grüße an alle


Last edited by zeitsofa on Fri Feb 11, 2011 12:46 am; edited 1 time in total
Back to top
View user's profile Send private message
manuels
Advocate
Advocate


Joined: 22 Nov 2003
Posts: 2146
Location: Europe

PostPosted: Tue Feb 08, 2011 4:39 pm    Post subject: Reply with quote

Klappt denn
Code:
echo 4 > /proc/acpi/ibm/cmos
?
_________________
Build your own live cd with catalyst 2.0!
Back to top
View user's profile Send private message
zeitsofa
n00b
n00b


Joined: 08 Feb 2011
Posts: 9

PostPosted: Tue Feb 08, 2011 5:48 pm    Post subject: Reply with quote

Hi,

echo 4 > /proc/acpi/ibm/cmos
bash: /proc/acpi/ibm/cmos: Datei oder Verzeichnis nicht gefunden

geht leider nicht
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3691
Location: Hamburg

PostPosted: Tue Feb 08, 2011 6:30 pm    Post subject: Reply with quote

zeitsofa wrote:
Hi,

echo 4 > /proc/acpi/ibm/cmos
bash: /proc/acpi/ibm/cmos: Datei oder Verzeichnis nicht gefunden

geht leider nicht
http://ibm-acpi.sourceforge.net/README und kernel option CONFIG_THINKPAD_ACPI=m
Back to top
View user's profile Send private message
zeitsofa
n00b
n00b


Joined: 08 Feb 2011
Posts: 9

PostPosted: Tue Feb 08, 2011 7:26 pm    Post subject: Reply with quote

Hier ist der passende Teil aus meiner aktuellen Kernelconfig

$ zgrep THINK /proc/config.gz

CONFIG_THINKPAD_ACPI=m
CONFIG_THINKPAD_ACPI_ALSA_SUPPORT=y
# CONFIG_THINKPAD_ACPI_DEBUGFACILITIES is not set
# CONFIG_THINKPAD_ACPI_DEBUG is not set
# CONFIG_THINKPAD_ACPI_UNSAFE_LEDS is not set
CONFIG_THINKPAD_ACPI_VIDEO=y
CONFIG_THINKPAD_ACPI_HOTKEY_POLL=y

$ modprobe thinkpad_acpi
FATAL: Error inserting thinkpad_acpi (/lib/modules/2.6.36-gentoo-r5/kernel/drivers/platform/x86/thinkpad_acpi.ko): No such device

$ ls -la /lib/modules/2.6.36-gentoo-r5/kernel/drivers/platform/x86/thinkpad_acpi.ko
-rw-r--r-- 1 root root 102103 6. Feb 15:38 /lib/modules/2.6.36-gentoo-r5/kernel/drivers/platform/x86/thinkpad_acpi.ko

Ich werd mal versuchen das Teil fest in den kernel zu bauen testweise. Oder gibts noch nen besseren Ansatzpunkt?
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3691
Location: Hamburg

PostPosted: Wed Feb 09, 2011 8:32 am    Post subject: Reply with quote

Für mein T400 funktioniert diese Koifg ganz gut : http://paste.pocoo.org/show/334847/
Back to top
View user's profile Send private message
zeitsofa
n00b
n00b


Joined: 08 Feb 2011
Posts: 9

PostPosted: Thu Feb 10, 2011 1:44 pm    Post subject: Reply with quote

So nach ein bisschen Kernel Versionen testen und rumprobieren habe ich in der dmesg-Ausgabe folgendes gefunden:

Code:

thinkpad_acpi: http://ibm-acpi.sf.net/
thinkpad_acpi: ThinkPad BIOS 7BET46WW (1.06 ), EC 7BHT31WW-1.04
thinkpad_acpi: Lenovo ThinkPad X60s, model 170456G
thinkpad_acpi: WARNING: Outdated ThinkPad BIOS/EC firmware
thinkpad_acpi: WARNING: This firmware may be missing critical bug fixes and/or important features
thinkpad_acpi: detected a 8-level brightness capable ThinkPad
thinkpad_acpi: ACPI backlight control delay disabled


nach dem Besuchen der Lenovo Page habe ich mir nun "7BETD7WW" besorgt und werde das in einer ruhigen Minute mal einspielen. Ich hoffe mal das es damit funktioniert. Sieht zumindest vielversprechend aus.

viele grüße

zeitsofa
Back to top
View user's profile Send private message
zeitsofa
n00b
n00b


Joined: 08 Feb 2011
Posts: 9

PostPosted: Fri Feb 11, 2011 12:45 am    Post subject: Reply with quote

Nach erfolgreichem BIOS Update funktioniert nun auch die Hintergrundbeleuchtung nach dem Standby

Vielen Lieben dank für eure Unterstützung

Viele Grüße
zeitsofa
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum