Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sata Kontroller Reset
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Wed Feb 23, 2011 12:54 pm    Post subject: Sata Kontroller Reset Reply with quote

Hallo Leute,

auf einem meiner Rechner bekomme ich ich oft den Fehler (Treiber: sata_sil):
Code:
ata3: SATA max UDMA/133 cmd 0x9e0 ctl 0xbe0 bmdma 0xc400 irq 22

Code:
klogd: ata3.00: configured for UDMA/133
klogd: ata3: EH complete

Angeschlossen ist:
Code:
ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata3.00: ATA-7: SAMSUNG SP2004C, VM100-33, max UDMA7
ata3.00: 390721968 sectors, multi 1: LBA48 NCQ (depth 0/32)

Bisher hat es mich nicht gestört, doch ab und zu stürtzt dann mein X11 ab. Einfach Bildschirm schwarz und neue Anmeldemaske:
Code:
kdm[8395]: X server for display :0 terminated unexpectedly

immer ca 10 Sekunden nach solch einem Reset. Keine weiteren Fehlermeldungen. Gehäuft, wenn ich per vnc auf den Server gehe. Nicht in Anzahl, sondern da schmiert dann X11 ab, wenn ich lokal dran sitzte läuft X11 weiter und ich bekomme das nicht wirklich mit.

Im Netz finde ich nur die Hinweise, dass evtl. das Kabel kaputt sein könnte oder der Kontroler. Hat jemand eine Idee, wie das besser eingrenzen könnte? Warum der ständig deses "reset" kommt? ATA_VERBOSE_ERROR ist im Kernel schon gesetzt, doch offensichtlich reicht das nicht ganz.

Das Mainboard hat einen NVidia-Sata-Kontroller:
Code:
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3) (prog-if 85 [Master SecO PriO])
        Subsystem: ASUSTeK Computer Inc. K8N4-E or A8N-E Mainboard
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0 (750ns min, 250ns max)
        Interrupt: pin A routed to IRQ 22
        Region 0: I/O ports at 09e0 [size=8]
        Region 1: I/O ports at 0be0 [size=4]
        Region 2: I/O ports at 0960 [size=8]
        Region 3: I/O ports at 0b60 [size=4]
        Region 4: I/O ports at c400 [size=16]
        Region 5: Memory at c6401000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Kernel driver in use: sata_nv


Und einen Silicon Image Raid-Controller:
Code:
05:0a.0 RAID bus controller: Silicon Image, Inc. SiI 3114 [SATALink/SATARaid] Serial ATA Controller (rev 02)
        Subsystem: ASUSTeK Computer Inc. Device 8167
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR+ INTx-
        Latency: 32, Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 19
        Region 0: I/O ports at 8400 [size=8]
        Region 1: I/O ports at 8800 [size=4]
        Region 2: I/O ports at 8c00 [size=8]
        Region 3: I/O ports at 9000 [size=4]
        Region 4: I/O ports at 9400 [size=16]
        Region 5: Memory at c5808000 (32-bit, non-prefetchable) [size=1K]
        [virtual] Expansion ROM at c4000000 [disabled] [size=512K]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=2 PME-
        Kernel driver in use: sata_sil
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Wed Feb 23, 2011 2:05 pm    Post subject: Reply with quote

Ein wenig habe ich es eingegrenzt. Es scheint nicht unbedingt ein Hardwareproblem zu sein. Die Festplatte war immer an ata7 angeschlossen. Dann habe ich nur den Kernel von 2.6.34-12 auf 2.6.36-r5 ausgewechselt und schon hängt die Platte auf ata3 und macht diese Probleme. Mal sehen, ob ich es weiter eingrenzen kann. Evtl. Kernelkonfig.

Wenn jemand irgend einen hilfreichen Tipp hat, her damit. :?
Back to top
View user's profile Send private message
schachti
Advocate
Advocate


Joined: 28 Jul 2003
Posts: 3765
Location: Gifhorn, Germany

PostPosted: Sat Feb 26, 2011 4:52 pm    Post subject: Reply with quote

Probier mal, die Linkgeschwindigkeit auf 1,5 Gbps runterzusetzen, manchmal hilft das...
_________________
Never argue with an idiot. He brings you down to his level, then beats you with experience.

How-To: Daten verschlüsselt auf DVD speichern.
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Tue Aug 23, 2011 11:02 am    Post subject: Reply with quote

Hat zwar lange gedauert, doch endlich gefunden. Der Leidensdruck war auf einmal so groß, weil es immer zu ungewolltem Ausloggen kam, nur wenn ich mal das 3. oder 4. Fenster von FireFox geöffnet habe:
Code:
touch /etc/pm/power.d/harddrive

ist die Lösung. :D [1]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum