Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] xorg-server-1.9 and mesa-9999
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
zolxd
Tux's lil' helper
Tux's lil' helper


Joined: 14 Feb 2003
Posts: 92

PostPosted: Tue Mar 01, 2011 3:43 am    Post subject: [SOLVED] xorg-server-1.9 and mesa-9999 Reply with quote

emerge world fails with
Code:
!!! All ebuilds that could satisfy "x11-libs/libX11[xcb?]" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/libX11-9999 (masked by: package.mask, ~amd64 keyword)
/var/lib/layman/x11/profiles/package.mask:
# Don't let people install these accidentally

- x11-libs/libX11-1.3.6 (masked by: package.mask, ~amd64 keyword)
/usr/portage/profiles/package.mask:
# Tomáš Chvátal <scarabeus@gentoo.org> (15 Feb 2011)
# Dropping support for 1.7 xorg-server series.
# Please upgrade to xorg-server-1.9.
# These ebuilds will be removed in 30 days.

- x11-libs/libX11-1.3.4 (masked by: package.mask)

(dependency required by "media-libs/mesa-9999" [ebuild])
(dependency required by "mesa" [argument])


So I checked http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.9-upgrade-guide.xml.

I now have
xorg-server-1.9.4, xorg-x11-7.4-r1, libX11-1.4.1

And from svn x11-overlay
libdrm-9999, xf86-video-ati-9999, mesa-9999

How can I update my system from here? Should I unmask something? or force some -9999 to a specific lower version?
_________________
core i7 + ati 5400 on GA-P55


Last edited by zolxd on Wed Mar 02, 2011 6:33 am; edited 3 times in total
Back to top
View user's profile Send private message
tryn
Guru
Guru


Joined: 21 Dec 2002
Posts: 319
Location: 39.885° N. -88.913° W.

PostPosted: Tue Mar 01, 2011 4:01 am    Post subject: Reply with quote

So do you have x11-libs/libX11-1.3.4 or -1.3.6 ? If so they are hard masked now. You might need to upgrade to one of the stable versions 1.4.0 or 1.4.1 If that is what is giving you the problem.
Back to top
View user's profile Send private message
zolxd
Tux's lil' helper
Tux's lil' helper


Joined: 14 Feb 2003
Posts: 92

PostPosted: Tue Mar 01, 2011 5:22 am    Post subject: Reply with quote

I have libX11-1.4.1 (I've edited my previous post to include this info.)

It hadn't occurred to me that mesa was requesting an older version rather than a more recent one.
Perhaps I need a non-svn version for compatibility now, but I don't know whether any will work properly, since I only used svn because I initially had trouble without it.

I wonder too, whether all three of libdrm, xf86-video-ati, and mesa would have to be changed together.
_________________
core i7 + ati 5400 on GA-P55
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Tue Mar 01, 2011 9:49 am    Post subject: Reply with quote

Moved from Desktop Environments to Unsupported Software, overlay ebuilds are not officially supported.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
zolxd
Tux's lil' helper
Tux's lil' helper


Joined: 14 Feb 2003
Posts: 92

PostPosted: Wed Mar 02, 2011 2:23 am    Post subject: Reply with quote

tomk wrote:
Moved from Desktop Environments to Unsupported Software, overlay ebuilds are not officially supported.
Sorry. I completely forgot the distinction.

But that was actually helpful. I had also forgotten that layman (as with any overlay) doesn't sync with emerge, so
Code:
layman -S
changing the problem to "needs EAPI 4." EAPI 4 in turn requires portage 2.2, which is still testing only, so
Code:
ACCEPT_KEYWORDS="**" emerge -av =sys-apps/portage-2.2.0_alpha25

I am suitably nervous about trying an unstable portage, but emerge world is now proceeding normally.

I won't mark this SOLVED until I know I can reboot and no other problems arise...
_________________
core i7 + ati 5400 on GA-P55
Back to top
View user's profile Send private message
zolxd
Tux's lil' helper
Tux's lil' helper


Joined: 14 Feb 2003
Posts: 92

PostPosted: Wed Mar 02, 2011 6:33 am    Post subject: Reply with quote

Ok, apart from a couple of non-essential programs I couldn't upgrade, everything appears fine.

However, I did have to re-emerge xf86-video-ati after everything else to fix ABI conflict so X would start.
_________________
core i7 + ati 5400 on GA-P55
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum