Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Segmentation Fault
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Liquido
n00b
n00b


Joined: 06 Jan 2006
Posts: 39
Location: Schweiz

PostPosted: Wed Mar 02, 2011 9:51 am    Post subject: [solved] Segmentation Fault Reply with quote

Hallo,

ich hatte schon des öfteren ein segmentation fault beim emerge von packeten unter gnome. Bei Chromium knall es, bei Wireshark und auch beim letzten world update vor ein paar Tagen.

Fahre ich xdm herunter und machen es direkt von der console läuft emerge sauber durch.

Hatten ihr das auch schon? An was könnte es liegen?

Gruss und Danke für sachdienliche Hinweise.


Last edited by Liquido on Wed Mar 02, 2011 1:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Wed Mar 02, 2011 10:26 am    Post subject: Reply with quote

Ich lehne mich jetzt mal weit aus dem Fenster (bin mir nicht genau sicher, ob in dem fall wirklich "segmentation fault" kommt oder was anderes): Ist dein Speicher voll? hast du swap eingerichtet?
Back to top
View user's profile Send private message
Liquido
n00b
n00b


Joined: 06 Jan 2006
Posts: 39
Location: Schweiz

PostPosted: Wed Mar 02, 2011 10:41 am    Post subject: Reply with quote

Der Gedanke ist gut, aber cat /proc/swaps zeigt mir das /dev/sda2 aktive ist. Also gehe ich mal davon aus das swap aktive ist.

Top zeigt mir Swap auch an, 2Gb an wovon 104k used sind.
Back to top
View user's profile Send private message
Liquido
n00b
n00b


Joined: 06 Jan 2006
Posts: 39
Location: Schweiz

PostPosted: Wed Mar 02, 2011 11:00 am    Post subject: Reply with quote

ok chromium scheint sich so auch nicht kompilieren zu lassen...ging zwar einiges länger, aber nun hab ich wieder ein Segmentation fault bekommen.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Mar 02, 2011 11:18 am    Post subject: Reply with quote

Mein erster Gedanke: Du hast einen fehlerhaften RAM...
Kannst du überprüfen, ob es immer die selbe Stelle ist, an der es Abbricht?
Back to top
View user's profile Send private message
Liquido
n00b
n00b


Joined: 06 Jan 2006
Posts: 39
Location: Schweiz

PostPosted: Wed Mar 02, 2011 1:34 pm    Post subject: Reply with quote

Problem gelöst :-)

Ich hab CFLAGS geändert :D

von CFLAGS="-O2 -march=i686 -pipe"

auf CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"


Und siehe da, ich konnte chromium unter gnome kompilieren.
Back to top
View user's profile Send private message
mrsteven
Veteran
Veteran


Joined: 04 Jul 2003
Posts: 1938

PostPosted: Thu Mar 03, 2011 12:07 pm    Post subject: Reply with quote

Liquido wrote:
Problem gelöst :-)

Ich hab CFLAGS geändert :D

von CFLAGS="-O2 -march=i686 -pipe"

auf CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"


Und siehe da, ich konnte chromium unter gnome kompilieren.


Das ergibt keinen Sinn. Der Fehler tritt vermutlich bald wieder auf. Schau lieber mal nach deinem RAM und der Kühlung. Wenn da irgendwas hinüber ist, erlebt man teilweise die seltsamsten Effekte.
_________________
Unix philosophy: "Do one thing and do it well."
systemd: "Do everything and do it wrong."
Back to top
View user's profile Send private message
Liquido
n00b
n00b


Joined: 06 Jan 2006
Posts: 39
Location: Schweiz

PostPosted: Mon Mar 07, 2011 9:00 pm    Post subject: Reply with quote

Stimmt...einmal hatte ich es noch, aber das lag vermutlich am clamd den muss ich je nach grösse vorher beenden.

Aber seither hatte ich kein segmentation fault mehr.
Back to top
View user's profile Send private message
mattes
Apprentice
Apprentice


Joined: 23 Jul 2008
Posts: 255
Location: München, Bavaria, Germany

PostPosted: Fri Mar 11, 2011 10:00 pm    Post subject: Reply with quote

Wenn du einen Segfault beim Compilieren hast, heißt das, dass gcc den auslöst. Solange du den nicht neu compilierst, haben die CFLAGS keine Auswirkung.
Back to top
View user's profile Send private message
doedel
Guru
Guru


Joined: 05 Feb 2006
Posts: 579
Location: Denmark

PostPosted: Sat Mar 12, 2011 3:52 pm    Post subject: Reply with quote

Quote:
Wenn du einen Segfault beim Compilieren hast, heißt das, dass gcc den auslöst.

Und wenn eines von den vielen hunderten kleinen Test-Binaries die bei den vielen ./configures anufgerufen werden, das auslöst? Entpacken? Der linker? Ein Assembler der aufgerufen wird?
Immer erstmal Fehlermeldung, dann sieht man was wirklich los is, vorallem liefs mit den anderen Flags.
_________________
1 ha == 1 Hekto-Ar == 1 Hektar
Back to top
View user's profile Send private message
Mr. Anderson
l33t
l33t


Joined: 22 Apr 2004
Posts: 761

PostPosted: Sat Mar 12, 2011 4:09 pm    Post subject: Reply with quote

Vielleicht auch ein voller ccache?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum