Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
compiz-9999
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Loko123
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2011
Posts: 91

PostPosted: Fri Jun 03, 2011 8:43 pm    Post subject: Reply with quote

hedmo wrote:
does someone know something about this




************************************************************

WARNING:
"FindCompiz.cmake" file not found in cmake module directories.
It should be installed to allow building of external compiz packages.
Call "sudo make findcompiz_install" to install it.

************************************************************

-- <<< Gentoo configuration >>>
Build type Gentoo
Install path /usr
Compiler flags:
C -march=amdfam10 -O2 -pipe -fomit-frame-pointer -Wall -Wall
C++ -march=amdfam10 -O2 -pipe -fomit-frame-pointer -Wall -Wall
Linker flags:
Executable -Wl,-O1 -Wl,--as-needed
Module -Wl,-O1 -Wl,--as-needed
Shared -Wl,-O1 -Wl,--as-needed

-- Configuring incomplete, errors occurred!
* ERROR: x11-wm/compiz-9999 failed (configure phase):
* cmake failed


hedmo,

Which version of GCC are you using? Give this command a shot: - MAKEOPTS="-j1" emerge -v =x11-wm/compiz-9999

P.S. That is actually the problem, that the live builds aren't compatible with git anymore. We need some patches / improvements - An update. :) I hope, that the desktop-effects devs are going to read through this thread!

Loko123
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 943
Location: halmstad

PostPosted: Sat Jun 04, 2011 12:11 am    Post subject: Reply with quote

Loko123

i was not hoping you ask for my gcc :oops:

mybox ~ # gcc-config -l
[1] x86_64-pc-linux-gnu-4.5.2
[2] x86_64-pc-linux-gnu-4.7.0-alpha20110528 *
mybox ~ #

"-j1" i know so it got to be my gcc :( i will give some more try and post back

by the way compiz-0.9.2 compile fine but that old one crach and cython-0.13 is gone
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Sun Jun 05, 2011 11:00 pm    Post subject: Reply with quote

Loko123 wrote:
...
Compiz-9999 doesn't compile with gtk-use flag enabled (This bug has been reported almost 2 month ago - https://bugs.gentoo.org/show_bug.cgi?id=357831) - So I'll have to compile it with kde use-flag. :) Let's hope that it works like a charm. I'll be back in ~20 minutes. :>

P.S. I hope, that any Developer / Community member is going to adopt the live ebuilds of compiz and fix the issue with gtk. :) Compiz is still a great WM! :-)

Loko123

Actually, compiz-0.9.4 compiles fine with gtk-use flag enabled. So I think, Compiz-9999 will compile fine with gtk-use flag enabled, if you use the gnome overlay for gtk related packages.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum