Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Blocket?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
chrisv93
n00b
n00b


Joined: 15 Sep 2010
Posts: 25

PostPosted: Thu Mar 03, 2011 2:27 pm    Post subject: Blocket? Reply with quote

Hey, wenn ich postfix installieren will kommt das :(siehe unten)
Aber ich weiß wie man sachen demaskiert aber hier hab ich echt keine ahnung


localhost chris # emerge -av postfix
--- Invalid atom in /etc/portage/package.keywords: x11-libs/libXext-1.1.2

* IMPORTANT: 6 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] mail-mta/postfix-2.7.2 USE="ipv6 mysql pam ssl -cdb -dovecot-sasl -hardened -ldap -mbox -nis -postgres -sasl (-selinux) -vda" 3,342 kB
[blocks B ] mail-mta/ssmtp ("virtual/mta" is blocking mail-mta/postfix-2.7.2)
[blocks B ] mail-mta/ssmtp ("virtual/mta" is blocking mail-mta/ssmtp-2.62-r7)

Total: 1 package (1 new), Size of downloads: 3,342 kB
Conflict: 2 blocks (2 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(mail-mta/ssmtp-2.62-r7, installed) pulled in by
mail-mta/ssmtp required by (app-crypt/gnupg-2.0.16-r1, installed)
mail-mta/ssmtp required by (sys-process/vixie-cron-4.1-r10, installed)

(mail-mta/postfix-2.7.2, ebuild scheduled for merge) pulled in by
postfix


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- x11-libs/libXext-1.1.2 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tomáš Chvátal <scarabeus@gentoo.org> (15 Feb 2011)
# Dropping support for 1.7 xorg-server series.
# Please upgrade to xorg-server-1.9.
# These ebuilds will be removed in 30 days.

- x11-base/xorg-drivers-1.7 (masked by: package.mask)
- x11-libs/libXft-2.1.14 (masked by: package.mask)
- x11-libs/libfontenc-1.0.5 (masked by: package.mask)
- x11-libs/libSM-1.1.1 (masked by: package.mask)
- x11-libs/libXdmcp-1.0.3 (masked by: package.mask)
- x11-libs/libXmu-1.0.5 (masked by: package.mask)
- x11-libs/libX11-1.3.4 (masked by: package.mask)
- dev-lang/perl-5.8.8-r8 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Torsten Veller <tove@gentoo.org> (06 Jan 2011)
# Next step to remove old perl and libperl versions.
# Versions prior 5.12 are masked and will be removed when 5.14 is available.
# If you are a sparc-fbsd user and your only keyworded perl version was masked,
# test perl-5.12.2 and reply to bug 288028
# For other complaints go to bug 350785

- x11-libs/libXi-1.3.1 (masked by: package.mask)
- x11-base/xorg-server-1.7.7-r1 (masked by: package.mask)
- sys-devel/libperl-5.8.8-r2 (masked by: package.mask)
- x11-apps/xinit-1.2.0-r3 (masked by: package.mask)
- x11-libs/libxcb-1.6 (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


* IMPORTANT: 6 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Thu Mar 03, 2011 3:39 pm    Post subject: Reply with quote

Hehe, ich denke du solltest in deinem System mal ein wenig aufräumen....! ;)

Zu deiner eigentlichen Anfrage:
chrisv93 wrote:
Code:
* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(mail-mta/ssmtp-2.62-r7, installed) pulled in by
mail-mta/ssmtp required by (app-crypt/gnupg-2.0.16-r1, installed)
mail-mta/ssmtp required by (sys-process/vixie-cron-4.1-r10, installed)

(mail-mta/postfix-2.7.2, ebuild scheduled for merge) pulled in by
postfix

I.d.R. kann bzw sollte es nur einen Mail Transfer Agent (MTA) im System geben. Wenn du nun einen anderen installieren möchtest wirst du den schon installierten erst deinstallieren müssen.
Siehe hierzu zb auch http://de.wikipedia.org/wiki/Mail_Transfer_Agent

PS: Nutze für Shell Ausgaben doch bitte die Code Tags hier im Forum, die Ausgaben sind dann doch wesentlich besser lesbar.
Back to top
View user's profile Send private message
chrisv93
n00b
n00b


Joined: 15 Sep 2010
Posts: 25

PostPosted: Thu Mar 03, 2011 3:55 pm    Post subject: Reply with quote

Das wars danke :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum