Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Kde 3.5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Sun Mar 13, 2011 2:16 am    Post subject: [SOLVED] Kde 3.5 Reply with quote

I'm still using KDE 3.5
When I tried to upgrade "world" today I got:
Code:
!!! All ebuilds that could satisfy ">=kde-base/kdelibs-4.4[aqua=]" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kdelibs-4.6.1 (masked by: package.mask, ~amd64 keyword)
- kde-base/kdelibs-4.6.0-r1 (masked by: package.mask, ~amd64 keyword)
- kde-base/kdelibs-4.5.5 (masked by: package.mask, ~amd64 keyword)
- kde-base/kdelibs-4.4.5-r2 (masked by: package.mask)
- kde-base/kdelibs-4.4.5-r1 (masked by: package.mask, ~amd64 keyword)
- kde-base/kdelibs-4.4.5 (masked by: package.mask)

(dependency required by "sys-auth/polkit-kde-0.95.1-r1" [ebuild])
(dependency required by "polkit-kde" [argument])

All KDE 4 are masked.
Is the blockage because polkit-kde-0.95.1 require min. kdelibs-4.4

"eix polkit-kde" is not showing any package being installed on my system or being available.
_________________
#Thelma


Last edited by Joseph_sys on Sun Mar 13, 2011 2:46 am; edited 1 time in total
Back to top
View user's profile Send private message
pingufunkybeat
l33t
l33t


Joined: 01 Dec 2004
Posts: 610

PostPosted: Sun Mar 13, 2011 2:23 am    Post subject: Reply with quote

Are you using the kde USE flag?

Try updating with USE="-kde" and seeing if it is resolved (use emerge -pv)

If it works, try to find out what is pulling in polkit-kde. Probably policy kit has USE=kde set and pulls in polkit-kde
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Sun Mar 13, 2011 2:45 am    Post subject: Reply with quote

pingufunkybeat wrote:
Are you using the kde USE flag?

Try updating with USE="-kde" and seeing if it is resolved (use emerge -pv)

If it works, try to find out what is pulling in polkit-kde. Probably policy kit has USE=kde set and pulls in polkit-kde


Indeed "-kde" flag solved the problem.
Though since I'm using still KDE-3.5 I was under impression I need to have in make.conf USE=kde
_________________
#Thelma
Back to top
View user's profile Send private message
pingufunkybeat
l33t
l33t


Joined: 01 Dec 2004
Posts: 610

PostPosted: Sun Mar 13, 2011 7:54 pm    Post subject: Reply with quote

Since kde 3.5 is removed from portage, I imagine that all new packages will interpret the "kde" flag to mean KDE4.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7108
Location: Austria

PostPosted: Sun Mar 13, 2011 8:15 pm    Post subject: Reply with quote

Yes they are. ;)

In case of the kde-sunset overlay, if there are any packages with kde flags, they hopefully already renamed them to kde3 or equiv...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum