Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Benutzerlogin = freeze !?!
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
m0021
n00b
n00b


Joined: 08 Jan 2010
Posts: 55
Location: Sonneberg, Germany

PostPosted: Wed Mar 16, 2011 2:39 pm    Post subject: Benutzerlogin = freeze !?! Reply with quote

Hi,

hab ein kleines bis größeres Problem mit gentoo auf meinem Laptop. Und zwar wenn ich mich als Benutzer anmelde, friert der Bildschirm ein. Mit Einfrieren meine ich das der Desktop an dem Punkt, an dem er die gnome-panels und mein cairo-dock zeigen sollte stehen bleibt (inklusive Mauszeiger). Wenn ich dann ca 2-10 minuten warte, läd er diese auch. Das Problem ist das sich dieses Verhalten wiederholt (beim starten von Programmen, arbeiten im Terminal). Das kurriose ist, das eine Consolenanmeldung bzw eine grafische Anmeldung als root problemlos (ohne Einfrieren) verläuft.

Meine bisherige Vorgehensweise bezüglich der Fehlersuche:
- Überhitzung geprüft --> CPU auf durchschnittlich 60-70°C
- Xorg, gdm und andere Log-Dateien angeschaut --> keine Errormeldungen bzw. andere Auffälligkeiten
- emerge -avuDN world && emerge --depclean -av && lafilefixer --justfixit && revdep-rebuild durchgeführt --> keine Broken Libraries und auch keine Besserung
- dann hab ich noch sämtliche Packete neu gebaut die Unterschiedlich zur grafischen Anmeldung von root sind (cairo-dock, compiz)
- Arbeitsspeicher geprüft (Durchlauf von memtest86+) --> auch keine Fehler
- SMART Health Status meiner SSD geprüft --> SMART sagt sie ist ok

Mein System:
- gnome-2.32 mit cairo-dock 2.2.0.4 und compiz-fusion 0.8.6 (das Problem trat nicht nach einem Update, oder nach installieren von Entwicklungsversionen dieser Packete auf)
- xorg-server 1.9.4 mit nvidia-drivers 260.19.36


Über Vorschläge was ich noch überprüfen kann würde ich mich freuen


Mit freundlichem Gruß,
m0021
Back to top
View user's profile Send private message
manuels
Advocate
Advocate


Joined: 22 Nov 2003
Posts: 2146
Location: Europe

PostPosted: Wed Mar 16, 2011 3:23 pm    Post subject: Reply with quote

Schau mal nach ob localhost in deiner /etc/hosts definiert ist.
Ich meine mich mal an einen entsprechenden KDE-Bug zu erinnern. Vielleicht ist dein Problem ähnlich.
_________________
Build your own live cd with catalyst 2.0!
Back to top
View user's profile Send private message
m0021
n00b
n00b


Joined: 08 Jan 2010
Posts: 55
Location: Sonneberg, Germany

PostPosted: Wed Mar 16, 2011 5:39 pm    Post subject: Reply with quote

eintrag ist vorhanden und schaut folgendermaßen aus:

127.0.0.1 localhost
127.0.0.1 hostname
::1 localhost
::1 hostname

Fehler bleibt bestehen
Back to top
View user's profile Send private message
Beforegod
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 1493
Location: Frankfurt/Main

PostPosted: Thu Mar 17, 2011 10:27 am    Post subject: Reply with quote

Würde mal folgende Schritte probieren:

- X mit TWM starten und sehen ob sich das Verhalten wieder auftritt
- Evt. mal GraKa Treiber wechseln (VESA) und sehen ob Besserung auftritt
- Während des startens der Gnome-Panles mal auf die Konsole wechseln und prüfen ob Prozesse hängen oder sonstige Fehlermeldungen auftauchen
Back to top
View user's profile Send private message
m0021
n00b
n00b


Joined: 08 Jan 2010
Posts: 55
Location: Sonneberg, Germany

PostPosted: Fri Mar 18, 2011 8:37 am    Post subject: Reply with quote

- X mit twm startet als Benutzer ohne probleme
- wechseln auf vesa brachte auch keine Besserung
- wenn ich während des startens (wenn der rechner hängt), alt+strg+f1 drücke, dann dauert es ne ganze Weile. Wenn er dann aber in der Konsole ist, dann kann ich flüssig arbeiten (kein Einfrieren)
Back to top
View user's profile Send private message
Beforegod
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 1493
Location: Frankfurt/Main

PostPosted: Fri Mar 25, 2011 2:46 pm    Post subject: Reply with quote

Ok, wechsel dann mal mit init 3 auf die Konsole (damit XDM,GDM beendet wird).

Danach als user folgendes Eingeben:

Code:
echo exec gnome-session >> ~/.xinitrc

danach

Code:
startx


und sehen ob es wieder zum Einfrieren kommt
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum