Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Issues with firefox 4.0 RC1
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
supernovae
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2004
Posts: 82

PostPosted: Fri Mar 18, 2011 9:39 pm    Post subject: Issues with firefox 4.0 RC1 Reply with quote

Code:
emerge -av =www-client/firefox-4.0_rc1

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "=www-client/firefox-4.0_rc1" have been masked.
!!! One of the following masked packages is required to complete your request:
- www-client/firefox-4.0_rc1::mozilla (masked by: invalid: DEPEND: USE flag 'libnotify' referenced in conditional 'libnotify=' in atom '~net-libs/xulrunner-2.0_rc1[wifi=,libnotify=,system-sqlite=,webm=]' is not in IUSE, invalid: RDEPEND: USE flag 'libnotify' referenced in conditional 'libnotify=' in atom '~net-libs/xulrunner-2.0_rc1[wifi=,libnotify=,system-sqlite=,webm=]' is not in IUSE)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I can't seem to get around this error, any ideas? Was happily running the beta versions up to b13, but then b13 also broke with this error.

Cheers,
Novae.
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2600

PostPosted: Fri Mar 18, 2011 9:54 pm    Post subject: Reply with quote

Try it with USE="-libnotify"
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
supernovae
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2004
Posts: 82

PostPosted: Sat Mar 19, 2011 1:01 am    Post subject: Reply with quote

penguin swordmaster wrote:
Try it with USE="-libnotify"


USE="-libnotify" emerge -av =www-client/firefox-4.0_rc1

returns the same message :(
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4329
Location: Dallas area

PostPosted: Sat Mar 19, 2011 1:21 am    Post subject: Reply with quote

Have you already emerged xulrunner that comes with the new version of firefox and if so is it using the libnotify flag
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
supernovae
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2004
Posts: 82

PostPosted: Sat Mar 19, 2011 1:30 am    Post subject: Reply with quote

Anon-E-moose wrote:
Have you already emerged xulrunner that comes with the new version of firefox and if so is it using the libnotify flag


Code:

[ebuild   R   #] net-libs/xulrunner-2.0_rc1  USE="crashreporter custom-optimization dbus ipc startup-notification -gnome" MULTILIB_ABI="amd64 -x86" 0 kB [1]


So, no it doesn't use the libnotify flag.
Back to top
View user's profile Send private message
Etal
Veteran
Veteran


Joined: 15 Jul 2005
Posts: 1696

PostPosted: Sat Mar 19, 2011 3:18 am    Post subject: Reply with quote

What overlay are you getting the xulrunner ebuild from? It does not look like the ones from the mozilla overlay...
_________________
“And even in authoritarian countries, information networks are helping people discover new facts and making governments more accountable.”– Hillary Clinton, Jan. 21, 2010
Back to top
View user's profile Send private message
supernovae
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2004
Posts: 82

PostPosted: Sat Mar 19, 2011 3:20 am    Post subject: Reply with quote

Etal wrote:
What overlay are you getting the xulrunner ebuild from? It does not look like the ones from the mozilla overlay...


That's coming from the mozilla overlay. But to be sure i'll remove the overlay and refetch it to be sure.

Update: I removed the mozilla overlay and re-added it with layman, no change. :(
Back to top
View user's profile Send private message
Etal
Veteran
Veteran


Joined: 15 Jul 2005
Posts: 1696

PostPosted: Sat Mar 19, 2011 3:23 am    Post subject: Reply with quote

Hmm, for me it looks like this:

Code:
$ emerge -pv xulrunner

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   #] net-libs/xulrunner-2.0_rc1  USE="alsa crashreporter custom-optimization dbus ipc libnotify startup-notification webm wifi -debug -system-sqlite" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB


Could you try "emerge -pv xulrunner::mozilla"?
_________________
“And even in authoritarian countries, information networks are helping people discover new facts and making governments more accountable.”– Hillary Clinton, Jan. 21, 2010
Back to top
View user's profile Send private message
supernovae
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2004
Posts: 82

PostPosted: Sat Mar 19, 2011 3:25 am    Post subject: Reply with quote

Etal wrote:
Hmm, for me it looks like this:

Code:
$ emerge -pv xulrunner

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   #] net-libs/xulrunner-2.0_rc1  USE="alsa crashreporter custom-optimization dbus ipc libnotify startup-notification webm wifi -debug -system-sqlite" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB


Could you try "emerge -pv xulrunner::mozilla"?


Code:
emerge -pv xulrunner::mozilla

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   #] net-libs/xulrunner-2.0_rc1  USE="crashreporter custom-optimization dbus ipc startup-notification -gnome" MULTILIB_ABI="amd64 -x86" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/mozilla
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2600

PostPosted: Sat Mar 19, 2011 3:30 am    Post subject: Reply with quote

Have you run layman -S recently? your layman might be out of date.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
supernovae
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2004
Posts: 82

PostPosted: Sat Mar 19, 2011 3:32 am    Post subject: Reply with quote

penguin swordmaster wrote:
Have you run layman -S recently? your layman might be out of date.


Don't think this would be it as i just removed and re-added the overlay.
Back to top
View user's profile Send private message
Etal
Veteran
Veteran


Joined: 15 Jul 2005
Posts: 1696

PostPosted: Sat Mar 19, 2011 3:40 am    Post subject: Reply with quote

What seems like, and it's really odd, is that the Portage-tree mozconfig-3.eclass is somehow taking precedence over the mozilla-overlay one...

Here are the flags defined in the eclass from the mozilla overlay (the ones you seem to be missing):
IUSE="+alsa +dbus debug libnotify startup-notification system-sqlite +webm wifi"

And this is from the portage tree (the ones you have):
IUSE="gnome dbus startup-notification"

Are you doing something weird in the make.conf with regards to overlays? :?

Maybe try deleting /usr/portage/eclass/mozconfig-3.eclass and see if that helps?
(It will be restored next time you sync)
_________________
“And even in authoritarian countries, information networks are helping people discover new facts and making governments more accountable.”– Hillary Clinton, Jan. 21, 2010
Back to top
View user's profile Send private message
supernovae
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2004
Posts: 82

PostPosted: Sat Mar 19, 2011 4:16 am    Post subject: Reply with quote

Etal wrote:
What seems like, and it's really odd, is that the Portage-tree mozconfig-3.eclass is somehow taking precedence over the mozilla-overlay one...

Here are the flags defined in the eclass from the mozilla overlay (the ones you seem to be missing):
IUSE="+alsa +dbus debug libnotify startup-notification system-sqlite +webm wifi"

And this is from the portage tree (the ones you have):
IUSE="gnome dbus startup-notification"

Are you doing something weird in the make.conf with regards to overlays? :?

Maybe try deleting /usr/portage/eclass/mozconfig-3.eclass and see if that helps?
(It will be restored next time you sync)


Yep, removing the mozconfig-3.eclass allowed it to install rc1, and also build xulrunner with correct use flags. Thanks for the help. I think it might be an issue with multilib but i'll have to look into it further. :)
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4329
Location: Dallas area

PostPosted: Sat Mar 19, 2011 10:47 am    Post subject: Reply with quote

I'm running multilib without any problems.

I just added the mozilla overlay and did an "emerge -pv firefox" and it returned this
Code:
[ebuild     U #] net-libs/xulrunner-2.0_rc1 [2.0_beta6_pre] USE="alsa crashreporter%* dbus ipc startup-notification webm -custom-optimization -debug -libnotify -system-sqlite -wifi (-cups%*) (-gnome%)" 64,529 kB [2=>1]
[ebuild     U #] www-client/firefox-4.0_rc1 [4.0_beta6_pre] USE="alsa dbus ipc startup-notification webm -bindist -custom-optimization -debug% -libnotify -system-sqlite -wifi (-cups%*) (-gnome%)" LINGUAS="-af% -ak% -ar% -ast% -be% -bg% -bn% -bn_BD% -bn_IN% -br% -bs% -ca% -cs% -cy% -da% -de% -el% -en% -en_ZA% -eo% -es% -es_ES% -et% -eu% -fa% -fi% -fr% -fy% -fy_NL% -ga% -ga_IE% -gd% -gl% -gu% -gu_IN% -he% -hi% -hi_IN% -hr% -hu% -hy% -hy_AM% -id% -is% -it% -ja% -kk% -kn% -ko% -ku% -lg% -lt% -lv% -mai% -mk% -ml% -mr% -nb% -nb_NO% -nl% -nn% -nn_NO% -nso% -or% -pa% -pa_IN% -pl% -pt% -pt_PT% -rm% -ro% -ru% -si% -sk% -sl% -son% -sq% -sr% -sv% -sv_SE% -ta% -ta_LK% -te% -th% -tr% -uk% -zu%" 5 kB [2=>1]


the libnotify shows up in both ff and xul

It could be something you have set or not set in make.conf or layman.cfg


Anyway glad you got it working.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
supernovae
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2004
Posts: 82

PostPosted: Sat Mar 19, 2011 1:12 pm    Post subject: Reply with quote

Anon-E-moose wrote:
I'm running multilib without any problems.

I just added the mozilla overlay and did an "emerge -pv firefox" and it returned this
Code:
[ebuild     U #] net-libs/xulrunner-2.0_rc1 [2.0_beta6_pre] USE="alsa crashreporter%* dbus ipc startup-notification webm -custom-optimization -debug -libnotify -system-sqlite -wifi (-cups%*) (-gnome%)" 64,529 kB [2=>1]
[ebuild     U #] www-client/firefox-4.0_rc1 [4.0_beta6_pre] USE="alsa dbus ipc startup-notification webm -bindist -custom-optimization -debug% -libnotify -system-sqlite -wifi (-cups%*) (-gnome%)" LINGUAS="-af% -ak% -ar% -ast% -be% -bg% -bn% -bn_BD% -bn_IN% -br% -bs% -ca% -cs% -cy% -da% -de% -el% -en% -en_ZA% -eo% -es% -es_ES% -et% -eu% -fa% -fi% -fr% -fy% -fy_NL% -ga% -ga_IE% -gd% -gl% -gu% -gu_IN% -he% -hi% -hi_IN% -hr% -hu% -hy% -hy_AM% -id% -is% -it% -ja% -kk% -kn% -ko% -ku% -lg% -lt% -lv% -mai% -mk% -ml% -mr% -nb% -nb_NO% -nl% -nn% -nn_NO% -nso% -or% -pa% -pa_IN% -pl% -pt% -pt_PT% -rm% -ro% -ru% -si% -sk% -sl% -son% -sq% -sr% -sv% -sv_SE% -ta% -ta_LK% -te% -th% -tr% -uk% -zu%" 5 kB [2=>1]


the libnotify shows up in both ff and xul

It could be something you have set or not set in make.conf or layman.cfg


Anyway glad you got it working.


Are you using multilib from the emul-linux* libraries or full multilib(all packages build amd64 and x86 libraries from their ebuilds) from the multilib overlay?
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4329
Location: Dallas area

PostPosted: Sat Mar 19, 2011 1:22 pm    Post subject: Reply with quote

I use the emul libs, as the multilib overlay is experimental at this point
and there are very few apps that I run that use the 32 bit libs,
right now just wine, cnijfilter and grub.

But I doubt that the multilib overlay would cause problems with
the firefox beta unless you were trying to compile it for 32 bits on a 64 bit system.


Post your /etc/make.conf and /etc/layman/layman.cfg files
and "emerge --info"
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
supernovae
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2004
Posts: 82

PostPosted: Sat Mar 19, 2011 1:31 pm    Post subject: Reply with quote

Code:
#cat /etc/make.conf
CHOST="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
LDFLAGS="-Wl,--as-needed"
MAKEOPTS="-j8"
FEATURES="ccache parallel-fetch"
GENTOO_MIRRORS="ftp://mirror.aarnet.edu.au/pub/gentoo/"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
LINGUAS="en"
USE="3dnow X a52 aac acpi alsa ati bash-completion bootsplash cairo cdr cleartype css \
cups dbus dvb dvd dvdr encode emerald gallium fbcondecor ffmpeg flac firefox fontconfig \
 gnutls gstreamer gnome-keyring gtk gzip imap lame multilib_abi_x86 lirc lm_sensors lzo madwifi fuse  \
-hal matroska mmap mms mmx mp3 mp4 mpeg msn mtp nsplugin ntfs -nvidia offensive \
ogm opengl openal policykit quicktime rar smp sse sse2 spell samba syslog s3tc theora thunar \
threads unicode udev v4l v4l2 vcd wifi win32codecs x264 xcomposite xinerama xrandr xv xscreensaver xfce xvid zlib \
-accessibility -bluetooth -doc -emacs -ipv6 -ldap -kde -pulseaudio -qt4 -xemacs"

ACCEPT_KEYWORDS="~amd64"
VIDEO_CARDS="radeon r600"
ALSA_CARDS="hda-intel"
INPUT_DEVICES="evdev"
LIRC_DEVICES="sb0540"
ACCEPT_LICENSE="*"
PORTAGE_ELOG_CLASSES="log warn error info"
PORTAGE_ELOG_SYSTEM="echo:log,error,warn,info  save:log,error,warn,info syslog:log,error,warn,info"
USE_PYTHON="2.6"
MULTILIB_BINARIES=sys-devel/libtool
PORTDIR_OVERLAY=/usr/local/portage
source /var/lib/layman/make.conf


Code:
#cat /etc/layman/layman.cfg
[MAIN]

#-----------------------------------------------------------
# Defines the directory where overlays should be installed

storage   : /var/lib/layman

#-----------------------------------------------------------
# Remote overlay lists will be stored here
# layman will append _md5(url).xml to each filename

cache     : %(storage)s/cache

#-----------------------------------------------------------
# The list of locally installed overlays

local_list: %(storage)s/overlays.xml

#-----------------------------------------------------------
# Path to the make.conf file that should be modified by
# layman

make_conf : %(storage)s/make.conf

#-----------------------------------------------------------
# URLs of the remote lists of overlays (one per line) or
# local overlay definitions
#
#overlays  : http://www.gentoo.org/proj/en/overlays/repositories.xml
#            http://dev.gentoo.org/~wrobel/layman/global-overlays.xml
#            http://mydomain.org/my-layman-list.xml
#            file:///var/lib/layman/my-list.xml

overlays  : http://www.gentoo.org/proj/en/overlays/repositories.xml

#-----------------------------------------------------------
# Proxy support
# If unset, layman will use the http_proxy environment variable.
#
#proxy  : http://[user:pass@]www.my-proxy.org:3128

#-----------------------------------------------------------
# Strict checking of overlay definitions
#
# The nocheck option is a bit confusing, for historical reasons.
# Hopefully this description eases the double negation trouble:
#
# nocheck : yes
# - Accepts completene overlay entries without warnings
# - Lists overlays of type foo (say Git) even with no foo installed
#
# nocheck : no
# - Checks overlay entries for missing description or contact
#     information and issue warnings as needed
# - Hides overlays of type foo (say Git) if foo not not installed
#
nocheck  : yes

#-----------------------------------------------------------
# Umask settings
#
# layman should usually work with a umask of 0022. You should
# only change this setting if you are absolutely certain that
# you know what you are doing.
#
#umask  : 0022

#-----------------------------------------------------------
# Command overrides
#
# You can have commands point to either a binary at a different
# location, e.g.
#
#   /home/you/local/bin/git
#
# or just the command, e.g.
#
#   git
#
# to use PATH-based resolution of the binary to call.
#
#bzr_command        : /usr/bin/bzr
#cvs_command        : /usr/bin/cvs
#darcs_command      : /usr/bin/darcs
#git_command        : /usr/bin/git
#mercurial_command  : /usr/bin/hg
#rsync_command      : /usr/bin/rsync
#svn_command        : /usr/bin/svn
#tar_command        : /bin/tar


Code:
#emerge --info
Portage 2.2.0_alpha27-r1 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.13-r2, 2.6.38-gentoo x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.0.2
Timestamp of tree: Sat, 19 Mar 2011 12:45:01 +0000
ccache version 3.1.4 [enabled]
app-shells/bash:     4.2_p8
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/ccache:     3.1.4
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.38 (sys-kernel/linux-headers)
Repositories: gentoo sunrise x11 multilib ohnobinki_overlay mozilla my_local_overlay
Installed sets:
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.2/ext-active/ /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.2/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.2/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://mirror.aarnet.edu.au/pub/gentoo/"
LANG="en_AU.UTF-8"
LDFLAGS="-Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/x11 /var/lib/layman/multilib /var/lib/layman/ohnobinki /var/lib/layman/mozilla /usr/local/portage"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 ati bash-completion berkdb bootsplash branding bzip2 cairo cdr cleartype cli consolekit cracklib crypt css cups cxx dbus dri dts dvb dvd dvdr emboss emerald encode exif fam fbcondecor ffmpeg firefox flac fontconfig fortran fuse gallium gdbm gdu gif gnome-keyring gnutls gpm gstreamer gtk gzip iconv imap jpeg lame lcms libnotify lirc lm_sensors lzo mad madwifi matroska mikmod mmap mms mmx mng modules mp3 mp4 mpeg msn mtp mudflap multilib ncurses nls nptl nptlonly nsplugin ntfs offensive ogg ogm openal opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support quicktime rar readline s3tc samba sdl session smp spell sse sse2 ssl startup-notification svg sysfs syslog tcpd theora threads thunar tiff truetype udev unicode usb v4l v4l2 vcd vorbis wifi x264 xcb xcomposite xfce xinerama xml xorg xrandr xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" LIRC_DEVICES="sb0540" MULTILIB_ABIS="amd64 x86" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" multilib_abi="x86"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


This system is using the experimental multilib as i required 32bit mesa libraries for 3D acceleration in WINE, although almost the whole system has been recompiled to support both ABI's bar a handful of buggy packages.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4329
Location: Dallas area

PostPosted: Sat Mar 19, 2011 2:12 pm    Post subject: Reply with quote

Not a lot of difference between my files/emerge info and yours.

It's possible that one of the overlays was interfering with the override of the eclass.

Other than that don't know.


Edit to add: I added each of the overlays, in the same order that you did and ff still didn't show any problems with libnotify.
The problem lies elsewhere.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2251
Location: Germany

PostPosted: Tue Mar 22, 2011 7:09 pm    Post subject: Reply with quote

Today for Windows and Linux, Firefox 4.0 are official available... are there some major bugs/issues to solve or dependencies.. before it is in the official portage?

Ohhhh sorry, did a re-sync and :) Its there! YES!
Back to top
View user's profile Send private message
hvengel
Guru
Guru


Joined: 19 Sep 2004
Posts: 515

PostPosted: Tue Mar 22, 2011 7:17 pm    Post subject: Reply with quote

I synced this morning and 4.0 is in portage. Has anyone unmasked it and given it a try?
Back to top
View user's profile Send private message
jkomar
Apprentice
Apprentice


Joined: 24 Sep 2004
Posts: 192
Location: Calgary, Canada

PostPosted: Tue Mar 22, 2011 7:27 pm    Post subject: Reply with quote

Installed and using it right now. It's working great.

Jason
_________________
www.jbox.ca
www.flashinthepan.ca
stormfront Portage/Paludis overlay
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8122
Location: ~Brussels - Belgique

PostPosted: Tue Mar 22, 2011 7:37 pm    Post subject: Reply with quote

Posting from FF4, on a netbook 8)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2251
Location: Germany

PostPosted: Tue Mar 22, 2011 8:05 pm    Post subject: Reply with quote

Got it, and it works. But i hasn't check out webgl. Thought there will be a useflag, but it don't fount it. Will check it later.

Just few issues i have with some Plugins, like my Proxy-Switcher in the bottom won't display. Seems that there is no space for this any more?

Thank you (to all who have working on this) for that work!
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 533
Location: Venice FL

PostPosted: Tue Mar 22, 2011 8:12 pm    Post subject: Reply with quote

I installed FF4 to see what all the hoopla was about, yep it's faster, but gecko-mediaplayer no longer will build and FF4 crashes on some pages, for example http://trailers.apple.com/trailers/wb/suckerpunch/

In light of the crash, I thought there was some irony to the link.

At least it's not crashed on anything important yet...

George
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4329
Location: Dallas area

PostPosted: Tue Mar 22, 2011 10:26 pm    Post subject: Reply with quote

thumper wrote:
I installed FF4 to see what all the hoopla was about, yep it's faster, but gecko-mediaplayer no longer will build and FF4 crashes on some pages, for example http://trailers.apple.com/trailers/wb/suckerpunch/

In light of the crash, I thought there was some irony to the link.


The link works fine for me (not running quicktime) but the link shows.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum