Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Erledigt]Masked Packages
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
cronic
n00b
n00b


Joined: 02 Feb 2011
Posts: 26

PostPosted: Sat Mar 19, 2011 7:43 pm    Post subject: [Erledigt]Masked Packages Reply with quote

Hey ho,

habe zur Zeit ein wenig Probleme mit den masked Packages. Ich habe ~x86 in meine make.conf hinzugefügt als Arch.
Nun schreibt er mir das meine Portage version die EAPI nicht unterstützt , wenn ich es richtig verstanden habe.

Allerdings habe ich erst vor ca. 2 wochen ein emerge --rsync durchgeführt.

Habt ihr den springenden Punkt entdeckt den ich vergessen habe?

hier nochmal ein Beispiel einer solchen Fehlermeldung:

Code:
fruchtgummi ~ # emerge ppp
Calculating dependencies \
!!! All ebuilds that could satisfy "net-dialup/ppp" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-dialup/ppp-2.4.5-r1 (masked by: EAPI 2)
- net-dialup/ppp-2.4.5 (masked by: EAPI 2)
- net-dialup/ppp-2.4.4-r25 (masked by: EAPI 2)

The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.


Last edited by cronic on Sun Mar 20, 2011 10:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
Knieper
l33t
l33t


Joined: 10 Nov 2005
Posts: 846

PostPosted: Sat Mar 19, 2011 8:13 pm    Post subject: Reply with quote

Mach mal ein sync (aktualisiert die "Portage Verzeichnisstruktur") und dann ein portage update (emerge portage; aktualisiert das "zugehörige Programm").
_________________
Je dümmer desto Gnome/KDE.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sat Mar 19, 2011 8:15 pm    Post subject: Reply with quote

Hi

Du nutzt vermutlich immer noch eine veraltete (defekte) portage Version?!
Mache am besten ein "emerge --sync" und dann ein Update auf die aktuelle portage Version, dann sollte es auch mit EAPI 1 2 3 und 4 klappen.
Back to top
View user's profile Send private message
cronic
n00b
n00b


Joined: 02 Feb 2011
Posts: 26

PostPosted: Sun Mar 20, 2011 3:23 pm    Post subject: Reply with quote

Habe den sync durchgeführt allerdings sagt er mir beim updaten schon das ich dies nicht könnte wegen der EAPI

Code:
fruchtgummi ~ # emerge portage
Calculating dependencies /
!!! All ebuilds that could satisfy ">=sys-devel/libtool-2.2.6b" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-devel/libtool-9999 (masked by: missing keyword)
- sys-devel/libtool-2.4-r1 (masked by: EAPI 2)
- sys-devel/libtool-2.2.10 (masked by: EAPI 2)

The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "dev-lang/python-2.5.4-r4" [ebuild])


Na wenn sich nun nicht mal portage updaten lässt, ja wie soll ich denn nun weiterkommen?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sun Mar 20, 2011 3:52 pm    Post subject: Reply with quote

Hmm.., was hast du den eigentlich installiert?
Magst du bitte mal deine "emerge --info" Ausgabe posten.
Back to top
View user's profile Send private message
cronic
n00b
n00b


Joined: 02 Feb 2011
Posts: 26

PostPosted: Sun Mar 20, 2011 4:01 pm    Post subject: Reply with quote

Klar,

hier :

Code:
emerge --info
--- Invalid atom in /etc/portage/package.keywords: sys-devel/libtool-2.2.10
--- Invalid atom in /etc/portage/package.keywords: dev-lang/python-2.5.4-r4
Portage 2.1.4.4 (default/linux/x86/10.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r5 i686)
=================================================================
System uname: 2.6.24-gentoo-r5 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Timestamp of tree: Sun, 20 Mar 2011 15:30:01 +0000
app-shells/bash:     3.2_p17-r1
dev-lang/python:     2.4.4-r13
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1asked
sys-devel/automake:  1.5, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc:       4.1.2
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
sys-devel/make:      3.81
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt ctype cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gd gdbm gdu gif gnome gpm gtk hal howl iconv imap ipv6 jpeg lcms ldap libnotify libtool mad maildirpng mikmod mmx mng modules mp3 mp4 mpeg mudflap mysql mysqli ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support qt4 readline sdl session spell ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 x86 xcb xml xml2 xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


ersten beiden Zeilen habe ich zu verschulden, habe versucht eine package.keywords anzulegen. Half mir aber auch nicht weiter :p
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Sun Mar 20, 2011 4:05 pm    Post subject: Reply with quote

Code:
--- Invalid atom in /etc/portage/package.keywords: sys-devel/libtool-2.2.10
--- Invalid atom in /etc/portage/package.keywords: dev-lang/python-2.5.4-r4


wenn du ein paket mit einer version angibst, dann mit = davor


Quote:
Ich habe ~x86 in meine make.conf hinzugefügt als Arch.

scheinst du nciht zu haben, laut ausgabe. aber ist vllt. auch erstmal besser so, das system hat irgendwie viele alte pakete und gehört erstmal auf den stabilen stand gebracht.
Back to top
View user's profile Send private message
cronic
n00b
n00b


Joined: 02 Feb 2011
Posts: 26

PostPosted: Sun Mar 20, 2011 4:13 pm    Post subject: Reply with quote

Hatte ~x86 kurz rausgenommen aus den ACCEPT_KEYWORDS, gibt es eine "Stable" option beim emergen von portage?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sun Mar 20, 2011 4:24 pm    Post subject: Reply with quote

cronic wrote:
Portage 2.1.4.4 (default/linux/x86/10.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r5 i686)

Ahrg..., du hast ja wirklich noch eine sehr alte portage Version installiert...

Schau mal ob du sie wie Hier beschrieben auf den aktuellen Stand bekommst.

Viel Erfolg
Back to top
View user's profile Send private message
cronic
n00b
n00b


Joined: 02 Feb 2011
Posts: 26

PostPosted: Sun Mar 20, 2011 4:34 pm    Post subject: Reply with quote

Josef.95 wrote:
cronic wrote:
Portage 2.1.4.4 (default/linux/x86/10.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r5 i686)

Ahrg..., du hast ja wirklich noch eine sehr alte portage Version installiert...

Schau mal ob du sie wie Hier beschrieben auf den aktuellen Stand bekommst.

Viel Erfolg


Leider ist auch diese Version von Portage nicht installationsfähig, EAPI 2. Welche wäre denn die letzte Portage Version mit Masked EAPI1 die aber EAPI2 unterstützt?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sun Mar 20, 2011 4:44 pm    Post subject: Reply with quote

Dann versuche es zunächst mit
Code:
emerge -av1 =sys-apps/portage-2.1.6.13
emerge -av1 =sys-apps/portage-2.1.8.3
emerge -1 portage
Back to top
View user's profile Send private message
cronic
n00b
n00b


Joined: 02 Feb 2011
Posts: 26

PostPosted: Sun Mar 20, 2011 4:48 pm    Post subject: Reply with quote

Gleich gibts tote Rechner ,
Code:
fruchtgummi ~ # emerge -av1 =sys-apps/portage-2.1.6.13

These are the packages that would be merged, in order:

Calculating dependencies |
!!! All ebuilds that could satisfy ">=sys-devel/libtool-2.2.6b" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-devel/libtool-9999 (masked by: missing keyword)
- sys-devel/libtool-2.4-r1 (masked by: EAPI 2)
- sys-devel/libtool-2.2.10 (masked by: EAPI 2)

The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "dev-lang/python-2.5.4-r4" [ebuild])


Ich habe
Code:
=sys-devel/libtool-2.2.6b ~x86
=dev-lang/python-2.5.4-r4 ~x86
nochmal in die package.keywords geschrieben, aber auch dies erzielt nicht den gewünschten Effekt :(
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Sun Mar 20, 2011 4:51 pm    Post subject: Reply with quote

2.2.6b is nicht mehr im tree vorhanden, steht in dem emerge error aber drin, welche versionen du nutzen sollst. also:

=sys-devel/libtool-2.2.10 ~x86

(was aber eapi2 braucht, was dein portage nicht mitmacht)

evtl. hilft ein zwischenschritt über portage 2.1.6.7?


Last edited by ScytheMan on Sun Mar 20, 2011 4:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
cronic
n00b
n00b


Joined: 02 Feb 2011
Posts: 26

PostPosted: Sun Mar 20, 2011 4:55 pm    Post subject: Reply with quote

ScytheMan wrote:
2.2.6b is nicht mehr im tree vorhanden, steht in dem emerge error aber drin, welche versionen du nutzen sollst. also:

=sys-devel/libtool-2.2.10 ~x86


2.2.10 ist aber wiederum EAPI2 , welches mein Portage nicht Unterstützt , auch nicht wenn ich es in die package.keywords reinschreibe ;)
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Sun Mar 20, 2011 4:59 pm    Post subject: Reply with quote

eine andere möglichkeit wäre natürlich:
http://www.gentoo.org/proj/en/portage/doc/manually-fixing-portage.xml

falls der zwischenschritt über portage 2.1.6.7 nicht funktioniert. wichtig hierbei is die warnung
Quote:
Warning: If your currently installed version of python reported by python -V is less than 2.6 then you must choose a version of portage that is compatible with it. If you have at least python 2.6 then use portage-2.1.9.42.tar.bz2. If you have python 2.4 or 2.5 then use portage-2.1.6.tar.bz2.

sonst gibts da probleme.
Back to top
View user's profile Send private message
cronic
n00b
n00b


Joined: 02 Feb 2011
Posts: 26

PostPosted: Sun Mar 20, 2011 5:32 pm    Post subject: Reply with quote

Funzt auch nicht :( Ab dem Punkt "emerge sys-apps/portage"

spuckt er mir folgendes raus:

Code:
emerge sys-apps/portage

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild  N    ] app-arch/xz-utils-5.0.1-r1  USE="nls threads -static-libs"
[ebuild     U ] app-admin/eselect-1.2.15 [1.0.10]
[ebuild  N    ] dev-libs/libffi-3.0.10_rc5  USE="-debug -static-libs -test"
[ebuild  N    ] app-misc/mime-types-8
[ebuild     U ] sys-devel/binutils-2.21 [2.18-r1]
[ebuild     U ] sys-devel/automake-wrapper-5 [3-r1]
[ebuild     U ] sys-devel/autoconf-wrapper-10-r1 [4-r3]
[ebuild  N    ] app-admin/eselect-python-20100321
[ebuild     U ] app-misc/pax-utils-0.2.3 [0.1.16]
[ebuild  N    ] virtual/libffi-0
[ebuild     U ] sys-devel/autoconf-2.68 [2.61-r1]
[ebuild     U ] sys-apps/sandbox-2.5 [1.2.18.1-r2] USE="(-multilib)"
[ebuild  NS   ] sys-devel/automake-1.11.1 [1.5, 1.8.5-r3, 1.9.6-r2, 1.10.1]
[ebuild  NS   ] sys-devel/libtool-2.4-r1 [1.3.5, 1.5.24] USE="-vanilla"
[ebuild  NS   ] dev-lang/python-2.7.1-r1 [2.4.4-r13] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -sqlite -tk -wininst"
[ebuild     U ] sys-apps/portage-2.1.9.44 [2.1.4.4] USE="(ipc%*) -build* -python2% -python3%"
*** Portage will stop merging at this point and reload itself,
    then resume the merge.
[blocks B     ] <sys-apps/portage-2.1.9 ("<sys-apps/portage-2.1.9" is blocking dev-lang/python-2.7.1-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Habe darauf geachtet den älteren Tarball zu nehmen..
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Sun Mar 20, 2011 5:54 pm    Post subject: Reply with quote

versuch doch mal, vor portage python 2.5 zu installieren:
Code:
emerge -1 =python-2.5.4-r4
Back to top
View user's profile Send private message
cronic
n00b
n00b


Joined: 02 Feb 2011
Posts: 26

PostPosted: Sun Mar 20, 2011 6:51 pm    Post subject: Reply with quote

Christian99 wrote:
versuch doch mal, vor portage python 2.5 zu installieren:
Code:
emerge -1 =python-2.5.4-r4
#

Er läuft durch, bis zum Punkt libtool.. damit hat er wohl die meisten Probleme:

Code:
>>> Installing sys-devel/libtool-2.4-r1
 * This package will overwrite one or more files that may belong to other
 * packages (see list below). You can use a command such as `portageq
 * owners / <filename>` to identify the installed package that owns a
 * file. If portageq reports that only one package owns a file then do
 * NOT file a bug report. A bug report is only useful if it identifies at
 * least two or more packages that are known to install the same file(s).
 * If a collision occurs and you can not explain where the file came from
 * then you should simply ignore the collision since there is not enough
 * information to determine if a real problem exists. Please do NOT file
 * a bug report at http://bugs.gentoo.org unless you report exactly which
 * two packages install the same file(s). Once again, please do NOT file
 * a bug report unless you have completely understood the above message.
 *
 * Detected file collision(s):
 *
 *    /usr/include/ltdl.h
 *    /usr/bin/libtool
 *    /usr/bin/libtoolize
 *    /usr/share/libtool/libltdl/configure
 *    /usr/share/libtool/libltdl/Makefile.in
 *    /usr/share/libtool/libltdl/README
 *    /usr/share/libtool/libltdl/COPYING.LIB
 *    /usr/share/libtool/libltdl/ltdl.c
 *    /usr/share/libtool/libltdl/config-h.in
 *    /usr/share/libtool/libltdl/Makefile.am
 *    /usr/share/libtool/libltdl/configure.ac
 *    /usr/share/libtool/libltdl/aclocal.m4
 *    /usr/share/libtool/libltdl/ltdl.h
 *    /usr/share/info/libtool.info.bz2
 *    /usr/share/aclocal/libtool.m4
 *    /usr/share/aclocal/ltdl.m4
 *    /usr/share/man/man1/libtool.1.bz2
 *    /usr/share/man/man1/libtoolize.1.bz2
 *    /usr/lib/libltdl.a
 *    /usr/lib/libltdl.la
 *    /usr/lib/libltdl.so
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * sys-devel/libtool-1.5.24
 *    /usr/bin/libtool
 *    /usr/bin/libtoolize
 *    /usr/include/ltdl.h
 *    /usr/lib/libltdl.a
 *    /usr/lib/libltdl.la
 *    /usr/lib/libltdl.so
 *    /usr/share/aclocal/libtool.m4
 *    /usr/share/aclocal/ltdl.m4
 *    /usr/share/info/libtool.info.bz2
 *    /usr/share/libtool/libltdl/COPYING.LIB
 *    /usr/share/libtool/libltdl/Makefile.am
 *    /usr/share/libtool/libltdl/Makefile.in
 *    /usr/share/libtool/libltdl/README
 *    /usr/share/libtool/libltdl/aclocal.m4
 *    /usr/share/libtool/libltdl/config-h.in
 *    /usr/share/libtool/libltdl/configure
 *    /usr/share/libtool/libltdl/configure.ac
 *    /usr/share/libtool/libltdl/ltdl.c
 *    /usr/share/libtool/libltdl/ltdl.h
 *    /usr/share/man/man1/libtool.1.bz2
 *    /usr/share/man/man1/libtoolize.1.bz2
 *
 * Package 'sys-devel/libtool-2.4-r1' NOT merged due to file collisions.
 * If necessary, refer to your elog messages for the whole content of the
 * above message.

>>> Failed to install sys-devel/libtool-2.4-r1, Log file:

>>>  '/var/tmp/portage/sys-devel/libtool-2.4-r1/temp/build.log'

 * Messages for package sys-devel/libtool-2.4-r1:

 * This package will overwrite one or more files that may belong to other
 * packages (see list below). You can use a command such as `portageq
 * owners / <filename>` to identify the installed package that owns a
 * file. If portageq reports that only one package owns a file then do
 * NOT file a bug report. A bug report is only useful if it identifies at
 * least two or more packages that are known to install the same file(s).
 * If a collision occurs and you can not explain where the file came from
 * then you should simply ignore the collision since there is not enough
 * information to determine if a real problem exists. Please do NOT file
 * a bug report at http://bugs.gentoo.org unless you report exactly which
 * two packages install the same file(s). Once again, please do NOT file
 * a bug report unless you have completely understood the above message.
 *
 * Detected file collision(s):
 *
 *    /usr/include/ltdl.h
 *    /usr/bin/libtool
 *    /usr/bin/libtoolize
 *    /usr/share/libtool/libltdl/configure
 *    /usr/share/libtool/libltdl/Makefile.in
 *    /usr/share/libtool/libltdl/README
 *    /usr/share/libtool/libltdl/COPYING.LIB
 *    /usr/share/libtool/libltdl/ltdl.c
 *    /usr/share/libtool/libltdl/config-h.in
 *    /usr/share/libtool/libltdl/Makefile.am
 *    /usr/share/libtool/libltdl/configure.ac
 *    /usr/share/libtool/libltdl/aclocal.m4
 *    /usr/share/libtool/libltdl/ltdl.h
 *    /usr/share/info/libtool.info.bz2
 *    /usr/share/aclocal/libtool.m4
 *    /usr/share/aclocal/ltdl.m4
 *    /usr/share/man/man1/libtool.1.bz2
 *    /usr/share/man/man1/libtoolize.1.bz2
 *    /usr/lib/libltdl.a
 *    /usr/lib/libltdl.la
 *    /usr/lib/libltdl.so
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * sys-devel/libtool-1.5.24
 *    /usr/bin/libtool
 *    /usr/bin/libtoolize
 *    /usr/include/ltdl.h
 *    /usr/lib/libltdl.a
 *    /usr/lib/libltdl.la
 *    /usr/lib/libltdl.so
 *    /usr/share/aclocal/libtool.m4
 *    /usr/share/aclocal/ltdl.m4
 *    /usr/share/info/libtool.info.bz2
 *    /usr/share/libtool/libltdl/COPYING.LIB
 *    /usr/share/libtool/libltdl/Makefile.am
 *    /usr/share/libtool/libltdl/Makefile.in
 *    /usr/share/libtool/libltdl/README
 *    /usr/share/libtool/libltdl/aclocal.m4
 *    /usr/share/libtool/libltdl/config-h.in
 *    /usr/share/libtool/libltdl/configure
 *    /usr/share/libtool/libltdl/configure.ac
 *    /usr/share/libtool/libltdl/ltdl.c
 *    /usr/share/libtool/libltdl/ltdl.h
 *    /usr/share/man/man1/libtool.1.bz2
 *    /usr/share/man/man1/libtoolize.1.bz2
 *
 * Package 'sys-devel/libtool-2.4-r1' NOT merged due to file collisions.
 * If necessary, refer to your elog messages for the whole content of the
 * above message.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Sun Mar 20, 2011 7:30 pm    Post subject: Reply with quote

dann einfach mal
Code:
emerge -1 libtool-1.5.26-r1

und weiter mit emerge portage. Wenn es nochmal bei einem paket probleme gibt, dann versuch mal eine ältere version davon zu emergen.
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Sun Mar 20, 2011 7:42 pm    Post subject: Reply with quote

wieso libtool-2.4-r1?
hast du den evtl. noch demaskiert?
würde die stable 2.2.10er version nehmen
Back to top
View user's profile Send private message
cronic
n00b
n00b


Joined: 02 Feb 2011
Posts: 26

PostPosted: Sun Mar 20, 2011 10:18 pm    Post subject: Reply with quote

Habe es nun hoffentlich geschafft, mit ein paar schwierigkeiten, gcc brauchte noch ein update usw.

Sollte aber nun eigentlich funktionieren. Bekomme zumindest keine auffäligen Fehler mehr..

Vielen dank für eure Hilfe, ich machs mal solved. Bei weiteren Problemem poaste ich gerne wieder..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum