Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Guide to installing gnome 3 from overlay?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
snoopy212
n00b
n00b


Joined: 21 Mar 2011
Posts: 9

PostPosted: Mon Mar 21, 2011 11:42 am    Post subject: Guide to installing gnome 3 from overlay? Reply with quote

Is there a guide anywhere to installing gnome 3 using the overlay, or could someone take me through how to do it currently? I tried following instructions in german I found in another thread here, but after doing that it just wanted to merge 2.3, and after I unmasked everything using autounmask there was a conflict that I couldn't figure out how to resolve.

I have since removed the overlays and installed the current gnome version from portage but I would still like to use gnome 3 (i installed it on arch previously and it was surprisingly usable even though it isn't finished).
Back to top
View user's profile Send private message
h2sammo
Veteran
Veteran


Joined: 11 Mar 2009
Posts: 1025
Location: Michigan

PostPosted: Mon Mar 21, 2011 12:51 pm    Post subject: Reply with quote

these overlays: http://gpo.zugaina.org/gnome-base/gnome dont show gnome 3 yet.
Back to top
View user's profile Send private message
snoopy212
n00b
n00b


Joined: 21 Mar 2011
Posts: 9

PostPosted: Mon Mar 21, 2011 1:00 pm    Post subject: Reply with quote

sorry i mean the 2.91 overlay that is there

the guide i tried following was this one:
http://reinemuth.info/gnome3-unter-gentoo-installieren-20101214.html

but it still wanted to merge 2.3, and once I fixed that using autounmask it failed to merge.

I thought I could just add the gnome overlay and then emerge gnome but that doesnt seem to work.
Back to top
View user's profile Send private message
h2sammo
Veteran
Veteran


Joined: 11 Mar 2009
Posts: 1025
Location: Michigan

PostPosted: Mon Mar 21, 2011 1:12 pm    Post subject: Reply with quote

do you have the gnome overlay installed properly and updated?
Back to top
View user's profile Send private message
snoopy212
n00b
n00b


Joined: 21 Mar 2011
Posts: 9

PostPosted: Mon Mar 21, 2011 1:24 pm    Post subject: Reply with quote

i only just installed gentoo on my machine a few days ago, installed layman and then did layman -a gnome

then trying to do emerge gnome just wanted to merge 2.3. I will try again shortly and post the error i get after autounmasking 2.91
Back to top
View user's profile Send private message
snoopy212
n00b
n00b


Joined: 21 Mar 2011
Posts: 9

PostPosted: Mon Mar 21, 2011 1:39 pm    Post subject: Reply with quote

Here is the problem, having done
Code:

layman -a gnome
autounmask gnome-base/gnome-2.91.90
....


after unmasking several packages, autounmask eventually says this:

Code:

...
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/gst-plugins-base:0.10

  (media-libs/gst-plugins-base-0.10.31, ebuild scheduled for merge) pulled in by
    ~media-libs/gst-plugins-base-0.10.31 required by (media-plugins/gst-plugins-x-0.10.31, ebuild scheduled for merge)
    (and 4 more with the same problem)

  (media-libs/gst-plugins-base-0.10.32, ebuild scheduled for merge) pulled in by
    >=media-libs/gst-plugins-base-0.10.32:0.10 required by (gnome-base/gnome-2.91.90, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

 * Added '=sys-apps/accountsservice-0.6.6 ~amd64' to /etc/portage/package.keywords/autounmask-gnome

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/gst-plugins-base:0.10

  (media-libs/gst-plugins-base-0.10.31, ebuild scheduled for merge) pulled in by
    ~media-libs/gst-plugins-base-0.10.31 required by (media-plugins/gst-plugins-x-0.10.31, ebuild scheduled for merge)
    (and 4 more with the same problem)

  (media-libs/gst-plugins-base-0.10.32, ebuild scheduled for merge) pulled in by
    >=media-libs/gst-plugins-base-0.10.32:0.10 required by (gnome-base/gnome-2.91.90, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

 * Added '=gnome-base/gsettings-desktop-schemas-9999 **' to /etc/portage/package.keywords/autounmask-gnome
 * Added '=gnome-base/gsettings-desktop-schemas-2.91.91 ~amd64' to /etc/portage/package.keywords/autounmask-gnome

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/gst-plugins-base:0.10

  (media-libs/gst-plugins-base-0.10.31, ebuild scheduled for merge) pulled in by
    ~media-libs/gst-plugins-base-0.10.31 required by (media-plugins/gst-plugins-x-0.10.31, ebuild scheduled for merge)
    (and 4 more with the same problem)

  (media-libs/gst-plugins-base-0.10.32, ebuild scheduled for merge) pulled in by
    >=media-libs/gst-plugins-base-0.10.32:0.10 required by (gnome-base/gnome-2.91.90, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

 * done!


I don't understand what the problem is or how to fix it, any help would be much appreciated
Back to top
View user's profile Send private message
h2sammo
Veteran
Veteran


Joined: 11 Mar 2009
Posts: 1025
Location: Michigan

PostPosted: Mon Mar 21, 2011 1:47 pm    Post subject: Reply with quote

can you post
Code:
cat /etc/portage/package.keywords
and
Code:
cat /etc/make.conf
Back to top
View user's profile Send private message
snoopy212
n00b
n00b


Joined: 21 Mar 2011
Posts: 9

PostPosted: Mon Mar 21, 2011 1:52 pm    Post subject: Reply with quote

sure:

Code:


$ cat /etc/portage/package.keywords/autounmask-gnome

# ---
# BEGIN: gnome-base/gnome-2.91.90
# ---
=gnome-base/gnome-2.91.90 ~amd64
=gnome-base/gvfs-9999 **
=gnome-base/gvfs-1.7.2 ~amd64
=gnome-extra/gconf-editor-2.91.91.1 ~amd64
=net-misc/vino-9999 **
=net-misc/vino-2.99.3 ~amd64
=gnome-base/gnome-panel-9999 **
=gnome-base/gnome-panel-2.91.91 ~amd64
=gnome-extra/zenity-2.91.90 ~amd64
=gnome-base/gnome-control-center-9999 **
=gnome-base/gnome-control-center-2.91.91 ~amd64
=gnome-base/libgnomekbd-9999 **
=gnome-base/libgnomekbd-2.91.91 ~amd64
=app-cdr/brasero-9999 **
=app-cdr/brasero-2.91.91 ~amd64
=app-editors/gedit-9999 **
=app-editors/gedit-2.91.9 ~amd64
=media-libs/clutter-9999 ~amd64
=media-libs/clutter-1.6.8 ~amd64
=media-libs/clutter-1.6.6 ~amd64
=media-libs/clutter-1.6.4 ~amd64
=x11-terms/gnome-terminal-9999 **
=x11-terms/gnome-terminal-2.33.90 ~amd64
=dev-libs/atk-1.33.6 ~amd64
=gnome-extra/gcalctool-9999 **
=gnome-extra/gcalctool-5.91.90 ~amd64
=gnome-base/gnome-shell-9999 **
=gnome-base/gnome-shell-2.91.91-r1 ~amd64
=x11-themes/gnome-themes-standard-9999 **
=x11-themes/gnome-themes-standard-2.91.91.1 ~amd64
=gnome-base/nautilus-9999 **
=gnome-base/nautilus-2.91.91 ~amd64
=gnome-base/gdm-2.91.93 ~amd64
=x11-wm/mutter-9999 **
=x11-wm/mutter-2.91.91 ~amd64
=app-arch/file-roller-9999 **
=app-arch/file-roller-2.91.91 ~amd64
=x11-libs/libwnck-2.91.90 ~amd64
=net-misc/vinagre-9999 **
=net-misc/vinagre-2.91.8 ~amd64
=gnome-base/gnome-keyring-9999 **
=gnome-base/gnome-keyring-2.91.92-r300 ~amd64
=gnome-base/gnome-keyring-2.91.92 ~amd64
=gnome-extra/gnome-utils-9999 **
=gnome-extra/gnome-utils-2.91.90 ~amd64
=x11-themes/gnome-icon-theme-symbolic-2.91.7 ~amd64
=gnome-base/gnome-session-9999 **
=gnome-base/gnome-session-2.91.91.3 ~amd64
=app-crypt/seahorse-9999 **
=app-crypt/seahorse-2.91.91 ~amd64
=dev-libs/glib-9999 ~amd64
=dev-libs/glib-2.28.3 ~amd64
=dev-libs/glib-2.28.2 ~amd64
=gnome-extra/gnome-system-monitor-2.99.1 ~amd64
=app-text/evince-9999 **
=app-text/evince-2.91.90 ~amd64
=net-analyzer/gnome-nettool-9999 **
=net-analyzer/gnome-nettool-2.91.5 ~amd64
=x11-themes/gnome-themes-2.91.90 ~amd64
=media-libs/gstreamer-0.10.32-r1 ~amd64
=media-libs/gstreamer-0.10.32 ~amd64
=gnome-extra/yelp-2.91.91 ~amd64
=gnome-extra/gnome-power-manager-9999 **
=gnome-extra/gnome-power-manager-2.91.90 ~amd64
=gnome-extra/gnome-user-docs-2.91.91 ~amd64
=gnome-base/gnome-desktop-9999 **
=gnome-base/gnome-desktop-2.91.91 ~amd64
=media-video/totem-9999 **
=media-video/totem-2.91.91 ~amd64
=gnome-base/gnome-settings-daemon-9999 **
=gnome-base/gnome-settings-daemon-2.91.91 ~amd64
=mail-client/evolution-9999 **
=mail-client/evolution-2.91.91 ~amd64
=www-client/epiphany-9999 **
=www-client/epiphany-2.91.91 ~amd64
=gnome-base/gnome-menus-2.91.91 ~amd64
=media-libs/gst-plugins-base-0.10.32 ~amd64
=x11-libs/gdk-pixbuf-2.23.1-r1 ~amd64
=gnome-extra/gnome-screensaver-9999 **
=gnome-extra/gnome-screensaver-2.91.91 ~amd64
=gnome-base/libgnome-keyring-2.91.92 ~amd64
=media-gfx/eog-9999 **
=media-gfx/eog-2.91.91 ~amd64
=gnome-extra/gnome-games-2.91.91 ~amd64
=gnome-extra/evolution-data-server-9999 **
=gnome-extra/evolution-data-server-2.91.91 ~amd64
=x11-libs/gtk+-9999 ~amd64
=x11-libs/gtk+-3.0.3 ~amd64
=media-libs/libcanberra-0.26-r2 ~amd64
=x11-libs/libnotify-0.7.1 ~amd64
=x11-libs/libxklavier-5.1 ~amd64
=sys-apps/accountsservice-0.6.6 ~amd64
=gnome-base/gsettings-desktop-schemas-9999 **
=gnome-base/gsettings-desktop-schemas-2.91.91 ~amd64
# ---
# END: gnome-base/gnome-2.91.90
# ---


(the only other thing in package.keywords is autounmask-texlive, which I doubt has anything to do with this)

Code:

$cat /etc/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -fomit-frame-pointer -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j9"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="mmx sse sse2 gtk gnome X dbus hal -qt4 -kde dvd alsa cdr pulseaudio kpathsea"

GENTOO_MIRRORS="http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/"

SYNC="rsync://rsync.uk.gentoo.org/gentoo-portage"

ACCEPT_LICENSE="*"

PORTDIR_OVERLAY="/usr/local/portage/wmfs"
source /var/lib/layman/make.conf


thanks for helping
Back to top
View user's profile Send private message
h2sammo
Veteran
Veteran


Joined: 11 Mar 2009
Posts: 1025
Location: Michigan

PostPosted: Mon Mar 21, 2011 1:57 pm    Post subject: Reply with quote

i think there is conflict between current installed gnome pulled media-libs/gst-plugins-base and the gnome version you want to install. what is the message of
Code:
emerge -pv gnome
Back to top
View user's profile Send private message
snoopy212
n00b
n00b


Joined: 21 Mar 2011
Posts: 9

PostPosted: Mon Mar 21, 2011 2:09 pm    Post subject: Reply with quote

I'm pretty sure I was getting these errors before I installed my current gnome, but now there seems to be a new problem!

Code:
emerge -pv gnome

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "x11-libs/pango[introspection]".
(dependency required by "gnome-base/gnome-shell-9999" [ebuild])
(dependency required by "gnome-base/gnome-session-9999" [ebuild])
(dependency required by "gnome-base/gdm-2.91.93" [ebuild])
(dependency required by "gnome-base/gnome-2.91.90" [ebuild])
(dependency required by "gnome" [argument])

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


I already tried adding x11-libs/pango introspection to package.use and that didn't make any difference for some reason
Code:
cat /etc/portage/package.use
dev-lang/python sqlite
dev-libs/libxml2 icu
dev-libs/libgcrypt static-libs
dev-libs/libgpg-error static-libs
x11-libs/pango introspection
media-video/ffmpeg threads
# ---
# BEGIN: gnome-base/gnome-2.91.90
# ---
# ---
# END: gnome-base/gnome-2.91.90
# ---


# ---
# BEGIN: app-text/texlive-2010
# ---
# ---
# END: app-text/texlive-2010
# ---


# ---
# BEGIN: gnome-base/gnome-2.91.90
# ---
# ---
# END: gnome-base/gnome-2.91.90
# ---


# ---
# BEGIN: x11-libs/gtk+-9999
# ---
# ---
# END: x11-libs/gtk+-9999
# ---


# ---
# BEGIN: x11-libs/gdk-pixbuf-2.22.0
# ---
# ---
# END: x11-libs/gdk-pixbuf-2.22.0
# ---
Back to top
View user's profile Send private message
h2sammo
Veteran
Veteran


Joined: 11 Mar 2009
Posts: 1025
Location: Michigan

PostPosted: Mon Mar 21, 2011 2:24 pm    Post subject: Reply with quote

what does
Code:
emerge -pv x11-libs/pango
give you?
Back to top
View user's profile Send private message
snoopy212
n00b
n00b


Joined: 21 Mar 2011
Posts: 9

PostPosted: Mon Mar 21, 2011 2:37 pm    Post subject: Reply with quote

Code:
emerge -pv x11-libs/pango

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/pango-1.28.3-r1  USE="X -debug -doc (-introspection) -test" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


i guess that is the problem! not sure how to force it to use introspection
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Mon Mar 21, 2011 2:38 pm    Post subject: Reply with quote

in case you havent, you have to unmask the introspection flag :

Code:
echo -introspection >> /etc/portage/profile/use.mask


which means you will probably have to rebuild half of the gnome packages before proceeding.
I dont really remember having to add so many packages to p.keywords, just 5 or 6, which makes me think that you are using stable. If thats the case, first switch to unstable and then try again. Trying to run a gnome3 snapshot on a stable system wont work, unless you unmask half of the tree.

In any case, i dont really think it is worth it, i have it installed and it is far from being stable or usable.
Not all apps have been ported to the new toolkit, networkmanager apparently doesnt work accurately, gstreamer has to be bumped i think ( im not sure but i think we have this in the tree now), it depends on eds and pulseaudio now and mutter segfaults here after using it for 10 minutes or so. Apart from that some dependencies were not pulled in by the ebuilds last time i tried.

EDIT : and BTW also unmask the gtk3 USE.

cheers
Back to top
View user's profile Send private message
snoopy212
n00b
n00b


Joined: 21 Mar 2011
Posts: 9

PostPosted: Mon Mar 21, 2011 2:59 pm    Post subject: Reply with quote

oh i see, I didn't realise you needed to switch to running unstable. that sounds like a big job, but I think I will try it and reinstall if it all goes wrong.

can I just set ACCEPT_KEYWORDS in make.conf and then emerge -uDN world or do i need to start from scratch?
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Mon Mar 21, 2011 3:32 pm    Post subject: Reply with quote

you can switch to unstable but im not sure if it would not make more sense to just start from scratch again, by switching you will hit breakages like libpng, libnotify, poppler and others i dont remember right now.

cheers
Back to top
View user's profile Send private message
snoopy212
n00b
n00b


Joined: 21 Mar 2011
Posts: 9

PostPosted: Mon Mar 21, 2011 3:56 pm    Post subject: Reply with quote

ok thanks, I guess I will try from scratch and see how it goes!
Back to top
View user's profile Send private message
Mythos
l33t
l33t


Joined: 02 May 2004
Posts: 953
Location: Portugal

PostPosted: Wed Apr 27, 2011 10:03 am    Post subject: Reply with quote

Code:
layman -a gnome

autounmask =gnome-base/gnome-3.0.0


autounmask will do the unmask for you.

I'm using gnome 2.32 got many emerge errors when try to emerge gnome3 it's better to install gnome3 in fresh installation that update prior version...
I will wait until gnome3 went to official portage
_________________
Best Regards,
Sérgio Henrique
Linux dune 3.0.6-gentoo #1 SMP Thu Oct 27 16:47:29 WEST 2011 x86_64 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 534

PostPosted: Thu Apr 28, 2011 4:14 am    Post subject: Reply with quote

Here is what I have, from a clean installation (there might be some influence from GCC 4.6, though):

Code:
#layman -a gnome


Code:
$cat /etc/portage/package.keywords/gnome3
gnome-base/gnome
gnome-base/gnome-shell
x11-themes/gnome-icon-theme-extras
gnome-base/gnome-core-libs
gnome-base/gnome-fallback
gnome-base/gnome-extra-apps
x11-themes/gnome-backgrounds
gnome-base/gdm
gnome-base/gnome-core-apps
x11-wm/mutter
gnome-base/gvfs
dev-libs/glib
gnome-extra/gnome-system-monitor
media-video/cheese
app-arch/file-roller
gnome-extra/gconf-editor
net-misc/vinagre
gnome-extra/gucharmap
media-sound/sound-juicer
www-client/epiphany
gnome-extra/gnome-utils

~gnome-base/gconf-2.32.2
gnome-extra/gnome-tweak-tool

net-misc/vino
gnome-extra/gnome-games
gnome-extra/gcalctool
mail-client/evolution
net-analyzer/gnome-nettool
<=x11-libs/gtk+-3.0.8
media-libs/libcanberra
gnome-base/gnome-desktop
gnome-extra/gtkhtml
dev-libs/libgweather

~x11-libs/pango-1.28.4
~dev-libs/libunique-3.0.0

gnome-extra/evolution-data-server
gnome-base/gsettings-desktop-schemas
>=sys-fs/udev-160
dev-libs/libpeas
net-libs/gtk-vnc
dev-python/pygobject
x11-libs/libwnck
dev-cpp/glibmm
dev-cpp/gtkmm
dev-cpp/cairomm
dev-cpp/pangomm
media-libs/clutter-gtk

~media-libs/gstreamer-0.10.32
~media-plugins/gst-plugins-pango-0.10.32
~media-libs/gst-plugins-base-0.10.32
~media-libs/gst-plugins-theora-0.10.32
~media-plugins/gst-plugins-theora-0.10.32
<=media-plugins/gst-plugins-cdparanoia-0.10.32
<=media-plugins/gst-plugins-gio-0.10.32
~media-plugins/gst-plugins-meta-0.10-r5
~media-plugins/gst-plugins-x-0.10.32
~media-plugins/gst-plugins-alsa-0.10.32
~media-plugins/gst-plugins-vorbis-0.10.32
~media-plugins/gst-plugins-ogg-0.10.32
~media-plugins/gst-plugins-xvideo-0.10.32
~media-libs/gst-plugins-good-0.10.28
~media-libs/gst-plugins-bad-0.10.21

media-video/gnome-video-effects
media-libs/clutter
<=x11-libs/mx-1.1.9

<=media-libs/clutter-gst-1.3.8
<=dev-libs/json-glib-0.12.2
media-libs/libgnome-media-profiles:3
app-cdr/brasero
<=net-libs/webkit-gtk-1.3.13
net-libs/libsoup-gnome
<=net-libs/libsoup-2.35
<=net-libs/glib-networking-2.29
<=sys-apps/accountsservice-0.6.7
gnome-base/gnome-session
gnome-base/gnome-settings-daemon
x11-themes/gnome-themes-standard
gnome-base/libgnomekbd
media-fonts/cantarell
x11-themes/gnome-icon-theme-symbolic
<=x11-libs/libxklavier-5.1
net-wireless/gnome-bluetooth
<=sys-auth/polkit-0.101

~dev-lang/vala-0.12.0
net-libs/telepathy-glib

net-im/telepathy-logger
<=dev-libs/gjs-0.7.14
<=gnome-base/dconf-0.7.3
gnome-base/gnome-control-center
gnome-extra/nm-applet
net-misc/networkmanager
net-libs/libsocialweb
x11-libs/gdk-pixbuf
net-libs/rest
net-dialup/ppp
dev-libs/gobject-introspection
<=net-libs/xulrunner-2.0-r1
<=dev-libs/nss-3.12.9
<=dev-libs/nspr-4.8.7
dev-libs/atk
x11-wm/metacity
gnome-base/gnome-panel
gnome-base/gnome-menus
gnome-base/libgnome-keyring
media-gfx/eog
x11-themes/gnome-icon-theme
app-crypt/seahorse
gnome-extra/gnome-screensaver
app-editors/gedit
gnome-base/nautilus
gnome-extra/gnome-user-docs
gnome-base/gnome-keyring
media-video/totem
x11-terms/gnome-terminal
gnome-extra/yelp
net-im/empathy
gnome-extra/gnome-power-manager
app-text/evince
app-text/gnome-doc-utils
x11-libs/vte
x11-libs/gnome-pty-helper
gnome-extra/yelp-xsl
media-libs/libexif
~app-text/poppler-0.16.4
dev-libs/totem-pl-parser
~media-libs/quvi-0.2.15
<=sys-devel/autoconf-2.68
<=dev-libs/folks-0.4.2
<=media-libs/libchamplain-0.10.0
net-im/telepathy-mission-control
<=media-libs/memphis-0.2.3
x11-libs/gtksourceview
gnome-extra/polkit-gnome
net-libs/libbluedevil
<=net-libs/libproxy-0.4.6-r300

~app-misc/geoclue-0.12.0_p20110307
~x11-libs/libfm-0.1.15_pre20110422


Code:
$cat /etc/portage/package.unmask/gnome3
gnome-base/gnome
gnome-base/gdm
x11-wm/metacity


Code:
$cat /etc/portage/profile/use.mask
-introspection


Sorry if this post is too long!
Back to top
View user's profile Send private message
olek
Apprentice
Apprentice


Joined: 22 Oct 2011
Posts: 173

PostPosted: Sat Oct 22, 2011 6:14 pm    Post subject: Reply with quote

If this is still of your interest, check this out:
http://oleeekchoff.blogspot.com/2011/10/gnome-3-on-gentoo.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum