Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge -avuDN world: cairo verlangt "-qt4"
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Wed Mar 23, 2011 8:38 pm    Post subject: emerge -avuDN world: cairo verlangt "-qt4" Reply with quote

Hallo,

ich bin etwas verwirrt. Ich habe hier ein KDE System und jetzt verlangt cairo beim world update von mir, dass ich das qt4 useflag deaktiviere. Wie kann das sein? Auf meinem Laptop habe ich ebenfalls eine amd64 System, bei dem das nicht aufgetreten ist. Was läuft hier falsch?

Code:

emerge: there are no ebuilds built with USE flags to satisfy ">=x11-libs/cairo-1.10.0[-qt4]".
!!! One of the following packages is required to complete your request:
- x11-libs/cairo-1.10.2-r1 (Change USE: -qt4)
(dependency required by "x11-libs/qt-gui-4.6.3-r2" [ebuild])
(dependency required by "kde-base/kdeartwork-iconthemes-4.4.5" [installed])
(dependency required by "kde-base/kdeartwork-meta-4.4.5" [installed])
(dependency required by "kde-base/kde-meta-4.4.5" [installed])
(dependency required by "@selected")
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Mar 23, 2011 9:02 pm    Post subject: Reply with quote

Dann fährst du auf dem Laptop aber nicht stable, sondern testing, denn die Einschränkung gilt nur für qt <4.7.

Der Grund ist der qgtkstyle. Dieser wurde automatisch bei aktiviertem gtk-USE-Flag mitgebaut. Der machte Probleme bei cairo[+qt4].
Seit qt-4.7 ist qgtkstyle ein eigenes Paket.

Also:
Qt auf Testing setzen (und auf qgtkstyle verzichten) oder cairo mit -qt4 bauen.

// nachtrag:
Das ChangeLog gibt auch genauere Infos:
Code:
*qt-gui-4.7.1-r1 (10 Nov 2010)
*qt-gui-4.6.3-r1 (10 Nov 2010)

  10 Nov 2010; Alex Alexander <wired@gentoo.org> +qt-gui-4.6.3-r1.ebuild,
  +qt-gui-4.7.1-r1.ebuild:
  moved Qt's GTK style to x11-themes/qgtkstyle - this fixes the nasty
  qt-gui/cairo bug #336801
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum