Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11-themes/gnome-themes is blocking x11-themes/gnome-themes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Shelnutt2
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2007
Posts: 122

PostPosted: Fri Mar 25, 2011 3:27 am    Post subject: x11-themes/gnome-themes is blocking x11-themes/gnome-themes Reply with quote

So I ran into this issue on my desktop and it fixed itself after a emerge --sync and layman -S. However on my netbook this isn't fixing it. I can't seem to figure out how to work around this block. If I open the ebuild to gnome-light-2.91.90, it doesn't depend on gnome-themes but for some reason portage thing it depends on it. Anyone have any ideas?

Code:

[blocks B     ] x11-themes/gnome-themes ("x11-themes/gnome-themes" is blocking x11-themes/gnome-themes-standard-2.91.92.1)

Total: 50 packages (33 upgrades, 1 downgrade, 16 new, 47 binaries), Size of downloads: 66,682 kB
Conflict: 1 block (1 unsatisfied)
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/gnome
 [?] indicates that the source repository could not be determined

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-themes/gnome-themes-standard-2.91.92.1::gnome, installed) pulled in by
    >=x11-themes/gnome-themes-standard-2.91.92 required by (gnome-base/gnome-session-2.91.93::gnome, binary scheduled for merge)
    >=x11-themes/gnome-themes-standard-2.91 required by (gnome-base/gnome-settings-daemon-2.91.92::gnome, binary scheduled for merge)
    >=x11-themes/gnome-themes-standard-2.91.90 required by (gnome-base/gnome-light-2.91.90::gnome, binary scheduled for merge)

  (x11-themes/gnome-themes-2.91.90::gnome, binary scheduled for merge) pulled in by
    >=x11-themes/gnome-themes-2.91.90 required by (gnome-base/gnome-light-2.91.90::gnome, binary scheduled for merge)

_________________
E6300, Gigabyte P35-DS3R, 7800GT, 2x512 TeamGroup DDR2 (D9), Audigy 2 value
Back to top
View user's profile Send private message
Shelnutt2
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2007
Posts: 122

PostPosted: Sat Mar 26, 2011 9:12 pm    Post subject: Reply with quote

So I installed gnome instead of gnome light, and just removed the packages I didn't want. However now I get a green screen after logging in. Here is my .xsession-errors. Anyone have any ideas?

Code:
/etc/gdm/Xsession: Beginning session setup...
which: no keychain in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.4.5:/opt/android-sdk-update-manager/tools:/opt/android-sdk-update-manager/platform-tools:/usr/lib64/subversion/bin:/usr/games/bin)
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/dbus-launch --exit-with-session /usr/bin/ssh-agent -- gnome-session

** (gnome-settings-daemon:27861): WARNING **: Ignoring unknown module 'org.gnome.settings-daemon.plugins.gconf'
GNOME_KEYRING_CONTROL=/tmp/keyring-xM6CnY
SSH_AUTH_SOCK=/tmp/keyring-xM6CnY/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-xM6CnY
SSH_AUTH_SOCK=/tmp/keyring-xM6CnY/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-xM6CnY
SSH_AUTH_SOCK=/tmp/keyring-xM6CnY/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-xM6CnY
SSH_AUTH_SOCK=/tmp/keyring-xM6CnY/ssh
GPG_AGENT_INFO=/tmp/keyring-xM6CnY/gpg:0:1
** (<unknown>:27868): DEBUG: Client registered with session manager: /org/gnome/SessionManager/Client2

** (gnome-settings-daemon:27861): WARNING **: Connection failed, reconnecting...
Gtk-Message: Failed to load module "atk-bridge"

** (gnome-shell:28094): WARNING **: Accessibility: org.a11y.atspi schema not found. Are you sure that at-spi or at-spi2 is installed on your system?

** (gnome-shell:28094): WARNING **: Accessibility: invalid module path (NULL)

** (gnome-shell:28094): WARNING **: Accessibility: error loading the atk-bridge. Although the accessibility on the system is enabled and clutter accessibility is also enabled, accessibility support on GNOME Shell will not work
Gtk-Message: Failed to load module "atk-bridge"
Gtk-Message: Failed to load module "atk-bridge"
Gtk-Message: Failed to load module "atk-bridge"
Gtk-Message: Failed to load module "atk-bridge"
Gtk-Message: Failed to load module "atk-bridge"

(nm-applet:28186): Gtk-WARNING **: Unknown property: GtkDialog.has-separator

** (gnome-screensaver:28179): WARNING **: Config key not handled: disable-application-handlers

** (gnome-screensaver:28179): WARNING **: Config key not handled: disable-command-line

** (gnome-screensaver:28179): WARNING **: Config key not handled: disable-log-out

** (gnome-screensaver:28179): WARNING **: Config key not handled: disable-print-setup

** (gnome-screensaver:28179): WARNING **: Config key not handled: disable-printing

** (gnome-screensaver:28179): WARNING **: Config key not handled: disable-save-to-disk

(nm-applet:28186): Gtk-WARNING **: Unknown property: GtkDialog.has-separator

(nm-applet:28186): Gtk-WARNING **: Unknown property: GtkDialog.has-separator
E: main.c: Daemon startup failed.
** Message: applet now removed from the notification area

** (gnome-settings-daemon:27861): WARNING **: Connection failed, reconnecting...
/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
  set_interactive(1)

** (gnome-settings-daemon:27861): WARNING **: Connection failed, reconnecting...

(nm-applet:28186): libnotify-WARNING **: Failed to connect to proxy

_________________
E6300, Gigabyte P35-DS3R, 7800GT, 2x512 TeamGroup DDR2 (D9), Audigy 2 value
Back to top
View user's profile Send private message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 548
Location: Scotland

PostPosted: Sat Apr 23, 2011 6:47 pm    Post subject: Reply with quote

Do you have dev-libs/atk-2.0.0 installed?
_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 548
Location: Scotland

PostPosted: Tue Jun 14, 2011 1:32 pm    Post subject: Reply with quote

* bump *

Well? Is this still a problem or are we all fixed now?
_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
Shelnutt2
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2007
Posts: 122

PostPosted: Tue Jun 14, 2011 2:56 pm    Post subject: Reply with quote

Thistled wrote:
* bump *

Well? Is this still a problem or are we all fixed now?


I fixed it by just reinstalling from scratch. I can't figure out why there was a dependency when it wasn't listed in the ebuild. That I'm just not too sure about.
_________________
E6300, Gigabyte P35-DS3R, 7800GT, 2x512 TeamGroup DDR2 (D9), Audigy 2 value
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum