Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] udev legt keine Verknüpfung zu /dev/dvdram an
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Sun Mar 27, 2011 9:28 am    Post subject: [solved] udev legt keine Verknüpfung zu /dev/dvdram an Reply with quote

Hallo

Ich wollte mich mal wieder an dvdram versuchen. Das lief vor längerer Zeit mal mehr schlecht als recht. Leider kann ich jetzt mit Kernel 2.6.36-gentoo-r8 auf die RAM-Laufwerke gar nicht mehr zugreifen. Ich bin jetzt so weit, das ich weiß, das /dev/dvdram zu keinem Laufwerk verlinkt ist.
meine /etc/udev/rules.d/70-persistent-cd.rules sieht so aus:
Code:
# DVD-ROM_SD-M1712 (pci-0000:00:0f.1-scsi-1:0:1:0)
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1-scsi-1:0:1:0", SYMLINK+="cdrom", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1-scsi-1:0:1:0", SYMLINK+="dvd", ENV{GENERATED}="1"
# DVD-RW_DVR-111 (pci-0000:00:0f.1-scsi-0:0:1:0)
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1-scsi-0:0:1:0", SYMLINK+="cdrom1", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1-scsi-0:0:1:0", SYMLINK+="cdrw1", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1-scsi-0:0:1:0", SYMLINK+="dvd1", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1-scsi-0:0:1:0", SYMLINK+="dvdrw1", ENV{GENERATED}="1"
# PIONEER_DVD-RW_DVR-111 (pci-0000:00:0f.1-ide-0:1)
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1-ide-0:1", SYMLINK+="cdrom2", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1-ide-0:1", SYMLINK+="cdrw2", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1-ide-0:1", SYMLINK+="dvd2", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1-ide-0:1", SYMLINK+="dvdrw2", ENV{GENERATED}="1"
# TOSHIBA_DVD-ROM_SD-M1712 (pci-0000:00:0f.1-ide-1:1)
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1-ide-1:1", SYMLINK+="cdrom3", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1-ide-1:1", SYMLINK+="dvd3", ENV{GENERATED}="1"
# TOSHIBA_DVD-ROM_SD-M1712 (pci-0000:00:0f.1)
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1", SYMLINK+="cdrom4", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1", SYMLINK+="dvd4", ENV{GENERATED}="1"

# PIONEER_DVD-RW_DVR-111 (pci-0000:00:0f.1)
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1", SYMLINK+="cdrom5", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1", SYMLINK+="cdrw5", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1", SYMLINK+="dvd5", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:0f.1", SYMLINK+="dvdrw5", ENV{GENERATED}="1"

# DVD-ROM_SD-M1712 (pci-0000:00:06.0-scsi-0:0:0:0)
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:06.0-scsi-0:0:0:0", SYMLINK+="cdrom6", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:06.0-scsi-0:0:0:0", SYMLINK+="dvd6", ENV{GENERATED}="1"

# DVD-RW_DVR-111 (pci-0000:00:06.0-scsi-0:0:1:0)
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:06.0-scsi-0:0:1:0", SYMLINK+="cdrom7", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:06.0-scsi-0:0:1:0", SYMLINK+="cdrw7", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:06.0-scsi-0:0:1:0", SYMLINK+="dvd7", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:06.0-scsi-0:0:1:0", SYMLINK+="dvdrw7", ENV{GENERATED}="1"


Eigentlich müsste dvdram dort drinstehen. Ist aber nicht und wird nicht automatisch angelegt. Woran könnte das liegen? Reicht es dvdram per Hand nachzutragen? Gibt es einen besseren Weg?

Danke


Last edited by deranonyme on Sun Mar 27, 2011 4:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sun Mar 27, 2011 10:40 am    Post subject: Reply with quote

Hi

Hmm.., soweit mir bekannt gibt es kein /dev/dvdram , und wird zum mounten einer DVD-RAM normal auch nicht benötigt. Du solltest sie eigentlich ganz normal unter
Code:
mount -o rw /dev/cdrom /mnt/cdrom
mounten können.

Mir scheint aber das deine /etc/udev/rules.d/70-persistent-cd.rules reichlich zugemüllt ist, oder hast du wirklich so viele Laufwerke? ;)
Verschiebe sie (zur wegsicherung) doch bitte mal in ein anderes Verzeichnis und starte dann udev neu (mache am besten ein reboot)
udev sollte dann eine neue passende 70-persistent-cd.rules für deine vorhandenen Laufwerke anlegen.
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Sun Mar 27, 2011 12:38 pm    Post subject: Reply with quote

Ok, ich hab ausgemistet.

Code:

# DVD-RW_DVR-111 (pci-0000:00:06.0-scsi-0:0:1:0)
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:06.0-scsi-0:0:1:0", SYMLINK+="cdrom", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:06.0-scsi-0:0:1:0", SYMLINK+="cdrw", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:06.0-scsi-0:0:1:0", SYMLINK+="dvd", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:06.0-scsi-0:0:1:0", SYMLINK+="dvdrw", ENV{GENERATED}="1"

# DVD-ROM_SD-M1712 (pci-0000:00:06.0-scsi-0:0:0:0)
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:06.0-scsi-0:0:0:0", SYMLINK+="cdrom1", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:06.0-scsi-0:0:0:0", SYMLINK+="dvd1", ENV{GENERATED}="1"



Das dumme ist nur unter KDE wird jede CD/DVD erkannt, nur bei DVD-RAM rödelt das Laufwerk ewig und erkennt dann nicht mal das Medium. DVD-RAM howtos verweisen allerdings einhellig auf /dev/dvdram? UDF ist im Kernel aktiviert. Siehe auch:
http://www.multimedia4linux.de/howto/DE-DVD-RAM-HOWTO-5.html#ss5.2

Verdammt ich weiß nicht weiter.

Code:
udevadm info --query=all --name=/dev/sr1
P: /devices/pci0000:00/0000:00:06.0/host4/target4:0:1/4:0:1:0/block/sr1                                                                                   
N: sr1                                                                                                                                                     
S: block/11:1                                                                                                                                             
S: scd1                                                                                                                                                   
S: disk/by-path/pci-0000:00:06.0-scsi-0:0:1:0                                                                                                             
S: cdrom                                                                                                                                                   
S: cdrw
S: dvd
S: dvdrw
E: UDEV_LOG=3
E: DEVPATH=/devices/pci0000:00/0000:00:06.0/host4/target4:0:1/4:0:1:0/block/sr1
E: MAJOR=11
E: MINOR=1
E: DEVNAME=/dev/sr1
E: DEVTYPE=disk
E: SUBSYSTEM=block
E: ID_CDROM=1
E: ID_CDROM_CD_R=1
E: ID_CDROM_CD_RW=1
E: ID_CDROM_DVD=1
E: ID_CDROM_DVD_R=1
E: ID_CDROM_DVD_RW=1
E: ID_CDROM_DVD_RAM=1
E: ID_CDROM_DVD_PLUS_R=1
E: ID_CDROM_DVD_PLUS_RW=1
E: ID_CDROM_DVD_PLUS_R_DL=1
E: ID_CDROM_MRW=1
E: ID_CDROM_MRW_W=1
E: ID_SCSI=1
E: ID_VENDOR=PIONEER
E: ID_VENDOR_ENC=PIONEER\x20
E: ID_MODEL=DVD-RW_DVR-111
E: ID_MODEL_ENC=DVD-RW\x20\x20DVR-111\x20
E: ID_REVISION=1.29
E: ID_TYPE=cd
E: ID_BUS=scsi
E: ID_PATH=pci-0000:00:06.0-scsi-0:0:1:0
E: ACL_MANAGE=1
E: GENERATED=1
E: UDISKS_PRESENTATION_NOPOLICY=0
E: DEVLINKS=/dev/block/11:1 /dev/scd1 /dev/disk/by-path/pci-0000:00:06.0-scsi-0:0:1:0 /dev/cdrom /dev/cdrw /dev/dvd /dev/dvdrw
[/
code]
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sun Mar 27, 2011 1:03 pm    Post subject: Reply with quote

Hmm, das unter Gentoo [udev] ein /dev/dvdram Symlink angelegt würde wäre mir neu (das muss aber nichts heißen) Hier bei mir gab es ihn soweit ich mich erinnere noch nie. (Ich mounte solche Laufwerke aber meist auch manuell)

deranonyme wrote:
Das dumme ist nur unter KDE wird jede CD/DVD erkannt, nur bei DVD-RAM rödelt das Laufwerk ewig und erkennt dann nicht mal das Medium.

Ok, KDE ist ja noch wieder eine andere Geschichte (hal udev udisks)
Könntest du denn nun deine DVD-RAM manuell mounten?
Was für eine KDE Version verwendest du denn - wird HAL oder udisks genutzt?

/edit:
Stelle doch bitte erst mal sicher das die DVD-RAM manuell korrekt mounted werden kann. Wenn das klappt dann kann man sich ja um KDE (HAL udisks) kümmern.
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Sun Mar 27, 2011 1:48 pm    Post subject: Reply with quote

Hm, sieht komisch aus:
Code:
#mount /dev/sr1 /media/dvdram
mount: no medium found on /dev/sr1

Laufwerk kaputt, erkennt keine RAMs mehr?

-> ok hab das LW mal gegen ein altes LG getauscht. Da läuft alles. Es muss also ein neues her :-(
Mal schauen was der Markt hergibt.

Danke erst mal
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum