Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X--tag=CC: problem when trying to compile Canon PIXMA driver
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Nazgul02
n00b
n00b


Joined: 25 Sep 2005
Posts: 20
Location: Prague

PostPosted: Sun Mar 27, 2011 2:08 pm    Post subject: X--tag=CC: problem when trying to compile Canon PIXMA driver Reply with quote

I own a Canon PIXMA MG 5250 Printer-scanner. I was able to make get the printing working by installing this ebuild: https://bugs.gentoo.org/130645. However, I can't get it to scan.

Canon provides a driver for linux, however, the binary driver doesn't work, and when I try to compile it, i get the following error:

Code:

make[2]: Entering directory `/root/scan/scangearmp-source-1.60-1/scangearmp/backend'
/bin/sh ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -I. -I./include   -DV_MAJOR=1 -DV_MINOR=6 -O2 -D__GIMP_PLUGIN_ENABLE__ -D_FILE_OFFSET_BITS=64 -MT libsane_canon_mfp_la-canon_mfp.lo -MD -MP -MF .deps/libsane_canon_mfp_la-canon_mfp.Tpo -c -o libsane_canon_mfp_la-canon_mfp.lo `test -f 'canon_mfp.c' || echo './'`canon_mfp.c
../libtool: line 760: X--tag=CC: command not found
../libtool: line 793: libtool: ignoring unknown tag : command not found
../libtool: line 760: X--mode=compile: command not found
../libtool: line 910: *** Warning: inferring the mode of operation is deprecated.: command not found
../libtool: line 911: *** Future versions of Libtool will require --mode=MODE be specified.: command not found
../libtool: line 1054: Xgcc: command not found
../libtool: line 1054: X-DHAVE_CONFIG_H: command not found
../libtool: line 1054: X-I.: command not found
../libtool: line 1054: X-I..: command not found
../libtool: line 1054: X-I.: command not found
../libtool: line 1054: X-I./include: No such file or directory
../libtool: line 1054: X-DV_MAJOR=1: command not found
../libtool: line 1054: X-DV_MINOR=6: command not found
../libtool: line 1054: X-O2: command not found
../libtool: line 1054: X-D__GIMP_PLUGIN_ENABLE__: command not found
../libtool: line 1054: X-D_FILE_OFFSET_BITS=64: command not found
../libtool: line 1054: X-MT: command not found
../libtool: line 1054: Xlibsane_canon_mfp_la-canon_mfp.lo: command not found
../libtool: line 1054: X-MD: command not found
../libtool: line 1054: X-MP: command not found
../libtool: line 1054: X-MF: command not found
../libtool: line 1054: X.deps/libsane_canon_mfp_la-canon_mfp.Tpo: No such file or directory
../libtool: line 1054: X-c: command not found
../libtool: line 1105: Xlibsane_canon_mfp_la-canon_mfp.lo: command not found
../libtool: line 1110: libtool: compile: cannot determine name of library object from `': command not found
make[2]: *** [libsane_canon_mfp_la-canon_mfp.lo] Error 1
make[2]: Leaving directory `/root/scan/scangearmp-source-1.60-1/scangearmp/backend'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/scan/scangearmp-source-1.60-1/scangearmp'
make: *** [all] Error 2


Any ideas?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Mon Mar 28, 2011 2:13 am    Post subject: Reply with quote

Well, depending on packaging, 'autoreconf -fi' might help.
Basically it's a macro/script version conflict for libtool.
Back to top
View user's profile Send private message
Nazgul02
n00b
n00b


Joined: 25 Sep 2005
Posts: 20
Location: Prague

PostPosted: Mon Apr 04, 2011 8:26 pm    Post subject: Reply with quote

Thank you, VoidMage.

Although I got a thousand warning, the driver compiled.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum