Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
system hang frequently
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message

Joined: 28 Mar 2011
Posts: 3

PostPosted: Mon Mar 28, 2011 5:03 pm    Post subject: system hang frequently Reply with quote

I use gentoo for almost 5 years, it always works very well. but recently the system hang frequently, here gives some details about my system:

my notebook is thinkpad x201, the cpu is i7-620M, other components are common. I use 2.6.38-gentoo as the kernel, and the keyword for packages is "amd64", which is stable version. i installed very few unstable packages, following is all the unstable packages I installed:

net-wireless/rtl8192se ~amd64
net-wireless/rtl8192se-firmware ~amd64
app-laptop/tp_smapi ~amd64
app-laptop/hdapsd ~amd64
www-plugins/mozplugger ~amd64
gnome-base/gdm ~amd64
net-dialup/ppp ~amd64
gnome-extra/dockbarx ~amd64
gnome-extra/gnome-globalmenu ~amd64
sys-apps/baselayout ~amd64
sys-apps/openrc ~amd64

the problem is:

1. sometimes when I am using my notebook, it suddently give "machine check exception", usually when I open a application. but the memtest, harddisk check and temperature of CPU are all OK.

2. sometimes when I want to open eclipse/openoffice/chromium, etc, then the mouse stop responding and then screen become black, after that, I have to long press the power button to shutdown the system and restart.

3. sometimes when I compile some source codes in eclipse, it will hang, the hanging procedure is the same like described in 2.

4. sometimes, even when the gdm starts, the system will hang (the same like described in 2)

all in all, when i am going to open some applications, or start to compile something, or some other conditions, the system will hang as described in 2. machine check exception happened in early times, after I recompile the kernel, MCE error never happens again.

but when I am building the system, the temperature of CPU is above 80 C, the system is ok, and seldom hang. only when I want to start a new application, system hang.


does it caused by wrongly configured kernel? should I post my kernel config here?
does it caused by my installed packages? I use dockbarx and gnome-globalmenu, they are unstable.
I use rtl8192se wireless card, the driver seems unstable, will it cause my problem?

I just tried debian and opensuse, system hang not happen. but I only use them for a very short time, and not heavy load tasks is running.

how can I get more log that related to my problem? so that I can do more analysis and fix my problem? any suggestion?
Back to top
View user's profile Send private message

Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Mon Mar 28, 2011 6:48 pm    Post subject: Reply with quote

Moved from Gentoo on AMD64 to Duplicate Threads.

No cross posting please.
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum