Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3 with ATI
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Katherine1
n00b
n00b


Joined: 06 Oct 2010
Posts: 26

PostPosted: Fri Apr 08, 2011 2:19 pm    Post subject: Gnome 3 with ATI Reply with quote

I've noticed that people have been talking about performance issues in Gnome 3. Given that I've seen nothing about ATI cards, I figured I'd give my experience in case it helps anyone else.

The first thing I noticed is that the proprietary ATI drivers have rendering issues with Gnome 3, making many menus pretty much unusable. I did not find any solution other than to switch to the open source drivers. This had it's own problems, however, as under the open source drivers, Gnome 3 ran unbearably slow. What managed to fix it was adding the following line to /etc/environment

Code:
export CLUTTER_VBLANK=none


With this in, Gnome 3 went from unusably slow to faster than it was with the ATI drivers.

I hope this helps anyone who wants to try Gnome 3 on an ATI card.
Back to top
View user's profile Send private message
tobbebobbe
n00b
n00b


Joined: 10 Feb 2011
Posts: 24

PostPosted: Wed May 25, 2011 6:36 am    Post subject: Reply with quote

I have an ATI 3400 and when I switched from proprietary driver to open source radeon there was a huge improvement (with mesa set to gallium). However, I am not sure wether "export CLUTTER_VBLANK=none" does anything for me.

How did you figure out to set this variable? Where can I read more about what it does?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum