Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-sheel is not starting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
jancici
Apprentice
Apprentice


Joined: 27 Jan 2004
Posts: 284
Location: Slovakia

PostPosted: Thu Apr 14, 2011 2:07 pm    Post subject: gnome-sheel is not starting Reply with quote

after login gnome-shell is not starting, I have to run this
Code:
gnome-shell --replace &

in terminal

after logout and login back situation is same, I have to start gnome-shell manually.

thanks for help
Back to top
View user's profile Send private message
LukynZ
Apprentice
Apprentice


Joined: 19 Dec 2008
Posts: 230
Location: The Czech Republic

PostPosted: Fri Apr 15, 2011 12:51 pm    Post subject: Reply with quote

I have same problem. But on my account only. Account of my family is fine, so some settings are wrong here...I think.
Back to top
View user's profile Send private message
bi3l
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 268
Location: France

PostPosted: Wed Apr 20, 2011 7:33 pm    Post subject: Reply with quote

Try removing /usr/share/gdm/autostart/LoginWindow/gnome-session-check-accelerated.desktop. It worked for me.
_________________
OGMRip - LCD filtering (Wiki)
Back to top
View user's profile Send private message
jancici
Apprentice
Apprentice


Joined: 27 Jan 2004
Posts: 284
Location: Slovakia

PostPosted: Thu Apr 21, 2011 6:37 am    Post subject: Reply with quote

I did move that file to another place.
logout and restart X
after login I had to start gnome-shell manually

so in my case it is not working :-(
Back to top
View user's profile Send private message
bi3l
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 268
Location: France

PostPosted: Thu Apr 21, 2011 7:34 am    Post subject: Reply with quote

Can you run /usr/libexec/gnome-session-check-accelerated-helper ? Does it print something ?
_________________
OGMRip - LCD filtering (Wiki)
Back to top
View user's profile Send private message
LukynZ
Apprentice
Apprentice


Joined: 19 Dec 2008
Posts: 230
Location: The Czech Republic

PostPosted: Thu Apr 21, 2011 10:42 am    Post subject: Reply with quote

for me no output...but here sometimes shell starts, sometimes not....its random
Back to top
View user's profile Send private message
jancici
Apprentice
Apprentice


Joined: 27 Jan 2004
Posts: 284
Location: Slovakia

PostPosted: Thu Apr 21, 2011 7:24 pm    Post subject: Reply with quote

running /usr/libexec/gnome-session-check-accelerated-helper is getting NO output and nothing happen
Back to top
View user's profile Send private message
LinuxFreakus
n00b
n00b


Joined: 23 Jan 2004
Posts: 30

PostPosted: Fri Dec 23, 2011 8:50 pm    Post subject: Reply with quote

I was having the same problem. I'm trying to run in virtualbox guest, I have 3d enabled and everything seems to be in order but it just won't automatically start gnome-shell. I've recompiled everything, etc, all my use flags look good.

When I do

Code:
gnome-shell --replace &


Then it starts up just fine, I don't see any problems but if I logout the gdm is using fallback, and when I login it uses fallback again. gnome-session-check-accelerated-helper causes my screen to flicker but there is no output.

So I tried:

Code:

mv /usr/libexec/gnome-session-check-accelerated-helper /usr/libexec/gnome-session-check-accelerated-helper.bak
ln -s /bin/true /usr/libexec/gnome-session-check-accelerated-helper


Now everything is happy. When the machine boots, gdm is no longer using fallback, and when I login it gets gnome-shell running automatically. I have no idea why gnome-session-check-accelerated-helper is not working. My guess is that the virtualbox video driver installed with the guest additions has an issue of some sort which will hopefully be fixed in the future, but at least it works for me now. I'm not sure if I like gnome 3 or not, but I wanted to give it a real try for a while to see if I can get used to it. Running in virtualbox lets me get a good feel for it without having to upgrade the host and possibly break stuff and lose productivity for a while.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum