Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome3: missing pango 1.29.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
RedOrc
n00b
n00b


Joined: 17 Apr 2011
Posts: 3

PostPosted: Sun Apr 17, 2011 3:49 pm    Post subject: Gnome3: missing pango 1.29.0 Reply with quote

Hi all,

I did everything by the book (used layman, added the flags to /etc/profile/* and so on), but right now I'm stymied: gnome3 wants to install pango 1.29.0 - which isn't available *anywhere*. So, does anyone know if there used to be a pango 1.29.0 and that version has been removed on the (gnome) master server and the mirrors or if it's an error in one of the overlays? If it's not an error - can someone supply me with a pango 1.29.0?

Thanks,
Mark
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Mon Apr 18, 2011 7:32 am    Post subject: Reply with quote

are you sure your overlay is up to date ? Because i installed gnome3 in my lappy yesterday and i didnt see this, installed pango version is 1.28.4.
what package is depending on pango 1.29.0 in your system ?
Anyways you can find an ebuild in the rubenqba overlay according to this -> http://gpo.zugaina.org/x11-libs/pango

cheers
Back to top
View user's profile Send private message
RedOrc
n00b
n00b


Joined: 17 Apr 2011
Posts: 3

PostPosted: Mon Apr 18, 2011 4:41 pm    Post subject: Reply with quote

gringo wrote:
are you sure your overlay is up to date ? Because i installed gnome3 in my lappy yesterday and i didnt see this, installed pango version is 1.28.4.
what package is depending on pango 1.29.0 in your system ?
Anyways you can find an ebuild in the rubenqba overlay according to this -> http://gpo.zugaina.org/x11-libs/pango
cheers


Of course I am - in fact I've just synced right now (did it a half an hour ago, too):

layman -S
* Running... # /usr/bin/svn up /var/lib/layman/suka
Revision 325.
* Running... # ( cd /var/lib/layman/keruspe && /usr/bin/git pull )
Already up-to-date.
* Running... # ( cd /var/lib/layman/rubenqba && /usr/bin/git pull )
Already up-to-date.
* Running... # ( cd /var/lib/layman/gnome && /usr/bin/git pull )
Already up-to-date.
*
* Success:
* ------
*
* Successfully synchronized overlay "suka".
* Successfully synchronized overlay "keruspe".
* Successfully synchronized overlay "rubenqba".
* Successfully synchronized overlay "gnome".

... and...

emerge gnome
Calculating dependencies... done!

>>> Verifying ebuild manifests
>>> Running pre-merge checks for net-misc/networkmanager-0.8.998-r1
* Adjusting permissions for FEATURES=ccache: '/tmp/tmpYCjETO/ccache'
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found kernel object directory:
* /lib/modules/2.6.38-gentoo-r2/build
* Found sources for kernel version:
* 2.6.38-gentoo-r2
* Checking for SYSFS_DEPRECATED support ... [ ok ]

>>> Starting parallel fetch

>>> Emerging (1 of 116) x11-libs/pango-1.29.0 from rubenqba

[ lots of failed fetches]

!!! Couldn't download 'pango-1.29.0.tar.bz2'. Aborting.
* Fetch failed for 'x11-libs/pango-1.29.0', Log file:
* '/var/tmp/portage/x11-libs/pango-1.29.0/temp/build.log'

>>> Failed to emerge x11-libs/pango-1.29.0, Log file:
Back to top
View user's profile Send private message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 548
Location: Scotland

PostPosted: Mon Apr 18, 2011 4:56 pm    Post subject: Reply with quote

Would it be crazy to suggest a revdep-rebuild at this point?

Just out of interest, when I type
Code:
equery depends pango

I get quite a list.
Code:
[ Searching for packages depending on pango... ]
app-admin/sabayon-2.30.1 (x11-libs/pango)
dev-cpp/pangomm-2.28.1 (>=x11-libs/pango-1.23.0)
dev-dotnet/libgdiplus-2.8.1 (!cairo? >=x11-libs/pango-1.20)
dev-dotnet/pango-sharp-2.12.10 (x11-libs/pango)
dev-java/icedtea6-bin-1.9.7 (nsplugin? >=x11-libs/pango-1.24.5)
dev-perl/Pango-1.221 (>=x11-libs/pango-1.0.0)
dev-php5/php-gtk-2.0.1-r4 (>=x11-libs/pango-1.8.0)
dev-python/pygtk-2.22.0-r1 (>=x11-libs/pango-1.16)
dev-python/wxpython-2.8.11.0 (>=x11-libs/pango-1.2)
gnome-base/gdm-3.0.0-r1 (>=x11-libs/pango-1.3)
gnome-base/gnome-core-libs-3.0.0 (>=x11-libs/pango-1.28.3)
gnome-base/gnome-panel-9999 (>=x11-libs/pango-1.15.4[introspection?])
gnome-base/gnome-shell-9999 (x11-libs/pango[introspection])
gnome-base/libgnomecanvas-2.30.3 (>=x11-libs/pango-1.0.1)
gnome-base/libgnomeprint-2.18.8 (>=x11-libs/pango-1.5)
gnome-base/libgnomeui-2.24.5 (>=x11-libs/pango-1.1.2)
gnome-base/librsvg-2.32.1 (>=x11-libs/pango-1.10)
gnome-base/nautilus-3.0.0 (>=x11-libs/pango-1.28.3)
gnome-extra/gucharmap-3.0.0 (>=x11-libs/pango-1.2.1)
mail-client/thunderbird-3.1.9 (x11-libs/pango[X])
                              (>=x11-libs/pango-1.10.1)
media-gfx/gimp-2.6.11-r1 (>=x11-libs/pango-1.18.0)
media-gfx/graphviz-2.26.3-r2 (cairo? >=x11-libs/pango-1.12)
                             (gtk? >=x11-libs/pango-1.12)
media-gfx/inkscape-0.48.0 (>=x11-libs/pango-1.4.0)
media-libs/clutter-1.6.14 (>=x11-libs/pango-1.20[introspection?])
media-libs/gegl-0.1.6 (x11-libs/pango)
media-libs/sdl-pango-0.1.2 (x11-libs/pango)
media-libs/swfdec-0.8.4 (>=x11-libs/pango-1.16.4)
media-plugins/gst-plugins-pango-0.10.32 (>=x11-libs/pango-1.16)
media-video/cheese-3.0.0 (>=x11-libs/pango-1.28.0)
net-libs/webkit-gtk-1.3.13 (>=x11-libs/pango-1.12)
net-libs/webkit-gtk-1.3.13-r200 (>=x11-libs/pango-1.12)
net-libs/xulrunner-2.0-r1 (x11-libs/pango[X])
                          (>=x11-libs/pango-1.10.1)
net-misc/vino-3.0.0 (x11-libs/pango[X])
sys-boot/plymouth-0.8.3-r1 (pango? >=x11-libs/pango-1.21)
sys-devel/gcc-4.4.5 (!build & gcj & gtk? x11-libs/pango)
sys-devel/gcc-4.5.2 (!build & gcj & gtk? x11-libs/pango)
www-client/opera-11.01.1190 (gtk? x11-libs/pango)
x11-libs/gtk+-2.24.3 (>=x11-libs/pango-1.20[introspection?])
x11-libs/gtk+-3.0.8 (>=x11-libs/pango-1.24.0[introspection?])
x11-libs/gtkglext-1.2.0 (>=x11-libs/pango-1[X])
x11-libs/libsexy-0.1.11-r2 (>=x11-libs/pango-1.4.0)
x11-libs/vte-0.28.0-r300 (>=x11-libs/pango-1.22.0)
x11-plugins/enigmail-1.1.2-r2 (>=x11-libs/pango-1.10.1)
x11-wm/metacity-2.34.0 (>=x11-libs/pango-1.2[X])
x11-wm/mutter-9999 (>=x11-libs/pango-1.2[X,introspection?])

Looks like gnome-core-libs, and nautilus are deffo looking for a pango later than 1.28.3
_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
Arkhelion
Apprentice
Apprentice


Joined: 07 Sep 2010
Posts: 151
Location: France

PostPosted: Mon Apr 18, 2011 5:03 pm    Post subject: Reply with quote

Hello,

My system runs gnome3 (from gnome-overlay) and a dependency check for pango indicates :
Code:
gnome-base/gnome-core-libs-3.0.0 (>=x11-libs/pango-1.28.3)
gnome-base/nautilus-3.0.0 (>=x11-libs/pango-1.28.3)

(Other dependencies are lower version number).

This dependency can be met with stable portage tree.

Maybe an "emerge -pt gnome" could show what tries to pull pango-1.29.

If you have gentoolkit installed "equery d pango" can tell that too.
_________________
Arkhelion
Back to top
View user's profile Send private message
RedOrc
n00b
n00b


Joined: 17 Apr 2011
Posts: 3

PostPosted: Mon Apr 18, 2011 5:25 pm    Post subject: Reply with quote

Well, fixed this by adding

=x11-libs/pango-1.29.0

to /etc/portage/package.mask/tmp

What baffles me why no one else had this problem - because there is a pango-1.29.0.ebuild in /var/lib/layman/rubenqba/x11-libs/pango/ (kind of strange, since there is no pango-1.29.0 anywhere)

Regards,
Mark
Back to top
View user's profile Send private message
meitnerium
n00b
n00b


Joined: 12 Feb 2003
Posts: 67

PostPosted: Tue Apr 19, 2011 6:35 am    Post subject: Reply with quote

I had the same problem, thank you :)
_________________
Voici la solution : http://www.perdu.com/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum