Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst]Keine dt Tastatur in X trotz Einstellung in der conf
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
kraileth
n00b
n00b


Joined: 12 Jan 2011
Posts: 23

PostPosted: Thu Apr 21, 2011 7:07 pm    Post subject: [gelöst]Keine dt Tastatur in X trotz Einstellung in der conf Reply with quote

Hallo zusammen!

Seit einer Weile treibe ich mich nun in der Gentoo-Welt herum und versuche, meine Linuxkenntnisse zu vertiefen. Mit vielen Dingen komme ich inzwischen auch wunderbar zurecht und konnte auch zahlreiche Probleme irgendwann selbst lösen. Jetzt bin ich allerdings wieder auf eines gestoßen, bei dem ich nicht weiterkomme.

Ich habe mich auf meinem Testsystem für LXDE entschieden. Mein System ist so eingerichtet, daß ich eine deutsche Tastatur eingestellt habe und auch Umlaute schreiben kann. Sobald ich aber (mittels startx) LXDE starte, habe ich keine deutsche Tastatur mehr. In der Gentoo-Anleitung stand zur Lokalisierung, daß ich nur in der xorg.conf eine Option setzen müßte. Das habe ich getan. Leider jedoch ohne Erfolg.

Anschließend habe ich nach einer Lösung gesucht, einiges gelesen und u.a. auch erreicht, daß ich mittels des Befehls
Code:
setxkbmap -layout de

die deutsche Tastatur einschalten kann. Das gibt zwar noch Probleme im Terminal, aber im eigentlichen LXDE sind anschließend die Tasten richtig gemapped und auch die Umlaute funktionieren.

Nun habe ich zwei Fragen:
1. Was müßte ich tun, damit die Tastatureinstellungen nicht nach jedem Start des grafischen Systems von Hand einzurichten wären?
2. Wie bekomme ich im Terminal der grafischen Oberfläche die Umlaute dazu (richtig gemapped sind sie wohl, aber es werden Fragezeichen angezeigt, da der Schriftsatz wohl unvollständig ist)?

Hier mein entsprechender Abschnitt der xorg.conf:

Code:
Section "InputDevice"
            Identifier  "Keyboard0"
            Driver       "kbd"
            Option "XkbLayout" "de"
EndSection


Hat jemand eine Idee, was ich falsch mache oder was noch an zusätzlichen Systemanpassungen notwendig sein könnte?


Last edited by kraileth on Fri Apr 22, 2011 6:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Thu Apr 21, 2011 7:31 pm    Post subject: Reply with quote

ich hab da zwar "Option "XkbLayout" "de,de"" stehen, aber nur de sollte eigentlich auch gehn. zeig doch mal bitte deine X logdatei.
Back to top
View user's profile Send private message
kraileth
n00b
n00b


Joined: 12 Jan 2011
Posts: 23

PostPosted: Thu Apr 21, 2011 7:51 pm    Post subject: Reply with quote

Christian99 wrote:
ich hab da zwar "Option "XkbLayout" "de,de"" stehen, aber nur de sollte eigentlich auch gehn. zeig doch mal bitte deine X logdatei.


Natürlich. Wie man an den Treibern sieht, habe ich mein Gentoo-Testsystem als VM in Virtualbox laufen. Ich sehe hier im Log auch mehrmals ein
Code:
Option "xkb_layout" "us"
auftauchen, bin aber weiterhin recht ratlos, was genau da meine xorg.conf-Einstellung überschreibt, bzw. wie ich das ändern kann (und worauf ich achten müßte).

Hier das komplette Log, da ich unsicher bin, worauf es alles ankommen kann. Habe einfach nur via startx LXDE starten lassen und es anschließend gleich wieder beendet. (Der Segfault tritt immer beim Beenden auf, ist aber sicher nichts, was mit dem gegenwärtigen Problem zusammenhängt, sondern leider ein Generelles, das ich mit diesem Rechner von Anfang an habe und gegen das ich bisher machtlos bin)

Code:
[  3526.779]
X.Org X Server 1.9.4
Release Date: 2011-02-04
[  3526.783] X Protocol Version 11, Revision 0
[  3526.785] Build Operating System: Linux 2.6.36-gentoo-r8 i686 Gentoo
[  3526.787] Current Operating System: Linux gentoo-vm 2.6.36-gentoo-r8 #1 SMP Tue Apr 19 18:01:06 CEST 2011 i686
[  3526.792] Kernel command line: root=/dev/sda3
[  3526.793] Build Date: 20 April 2011  10:41:25AM
[  3526.795] 
[  3526.799] Current version of pixman: 0.20.2
[  3526.800]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  3526.801] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  3526.804] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 21 21:42:01 2011
[  3526.805] (==) Using config file: "/etc/X11/xorg.conf"
[  3526.805] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  3526.806] (==) ServerLayout "X.org Configured"
[  3526.806] (**) |-->Screen "Screen0" (0)
[  3526.806] (**) |   |-->Monitor "Monitor0"
[  3526.806] (**) |   |-->Device "Card0"
[  3526.806] (**) |-->Input Device "Mouse0"
[  3526.806] (**) |-->Input Device "Keyboard0"
[  3526.806] (==) Automatically adding devices
[  3526.806] (==) Automatically enabling devices
[  3526.807] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[  3526.807]    Entry deleted from font path.
[  3526.807] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  3526.807]    Entry deleted from font path.
[  3526.807] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  3526.807]    Entry deleted from font path.
[  3526.807] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  3526.807]    Entry deleted from font path.
[  3526.807] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[  3526.807]    Entry deleted from font path.
[  3526.807] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[  3526.807]    Entry deleted from font path.
[  3526.807] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[  3526.807]    Entry deleted from font path.
[  3526.807] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  3526.807]    Entry deleted from font path.
[  3526.807] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  3526.807]    Entry deleted from font path.
[  3526.807] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  3526.807]    Entry deleted from font path.
[  3526.807] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[  3526.807]    Entry deleted from font path.
[  3526.807] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[  3526.807]    Entry deleted from font path.
[  3526.807] (**) FontPath set to:
   
[  3526.807] (**) ModulePath set to "/usr/lib/xorg/modules"
[  3526.807] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  3526.807] (WW) Disabling Mouse0
[  3526.807] (WW) Disabling Keyboard0
[  3526.807] (II) Loader magic: 0x81f4de0
[  3526.807] (II) Module ABI versions:
[  3526.807]    X.Org ANSI C Emulation: 0.4
[  3526.807]    X.Org Video Driver: 8.0
[  3526.807]    X.Org XInput driver : 11.0
[  3526.807]    X.Org Server Extension : 4.0
[  3526.809] (--) PCI:*(0:0:2:0) 80ee:beef:0000:0000 rev 0, Mem @ 0xe0000000/134217728
[  3526.809] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  3526.809] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
[  3526.809] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
[  3526.809] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[  3526.809] (II) "record" will be loaded. This was enabled by default and also specified in the config file.
[  3526.809] (II) "dri" will be loaded. This was enabled by default and also specified in the config file.
[  3526.809] (II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
[  3526.809] (II) LoadModule: "record"
[  3526.809] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[  3526.810] (II) Module record: vendor="X.Org Foundation"
[  3526.810]    compiled for 1.9.4, module version = 1.13.0
[  3526.810]    Module class: X.Org Server Extension
[  3526.810]    ABI class: X.Org Server Extension, version 4.0
[  3526.810] (II) Loading extension RECORD
[  3526.810] (II) LoadModule: "dbe"
[  3526.810] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[  3526.810] (II) Module dbe: vendor="X.Org Foundation"
[  3526.810]    compiled for 1.9.4, module version = 1.0.0
[  3526.810]    Module class: X.Org Server Extension
[  3526.810]    ABI class: X.Org Server Extension, version 4.0
[  3526.810] (II) Loading extension DOUBLE-BUFFER
[  3526.810] (II) LoadModule: "dri"
[  3526.810] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[  3526.810] (II) Module dri: vendor="X.Org Foundation"
[  3526.810]    compiled for 1.9.4, module version = 1.0.0
[  3526.810]    ABI class: X.Org Server Extension, version 4.0
[  3526.810] (II) Loading extension XFree86-DRI
[  3526.810] (II) LoadModule: "dri2"
[  3526.810] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[  3526.811] (II) Module dri2: vendor="X.Org Foundation"
[  3526.811]    compiled for 1.9.4, module version = 1.2.0
[  3526.811]    ABI class: X.Org Server Extension, version 4.0
[  3526.811] (II) Loading extension DRI2
[  3526.811] (II) LoadModule: "glx"
[  3526.811] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  3526.811] (II) Module glx: vendor="X.Org Foundation"
[  3526.811]    compiled for 1.9.4, module version = 1.0.0
[  3526.811]    ABI class: X.Org Server Extension, version 4.0
[  3526.811] (==) AIGLX enabled
[  3526.811] (II) Loading extension GLX
[  3526.811] (II) LoadModule: "extmod"
[  3526.811] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[  3526.811] (II) Module extmod: vendor="X.Org Foundation"
[  3526.811]    compiled for 1.9.4, module version = 1.0.0
[  3526.811]    Module class: X.Org Server Extension
[  3526.811]    ABI class: X.Org Server Extension, version 4.0
[  3526.811] (II) Loading extension MIT-SCREEN-SAVER
[  3526.811] (II) Loading extension XFree86-VidModeExtension
[  3526.811] (II) Loading extension XFree86-DGA
[  3526.811] (II) Loading extension DPMS
[  3526.811] (II) Loading extension XVideo
[  3526.811] (II) Loading extension XVideo-MotionCompensation
[  3526.811] (II) Loading extension X-Resource
[  3526.811] (II) LoadModule: "vboxvideo"
[  3526.812] (II) Loading /usr/lib/xorg/modules/drivers/vboxvideo_drv.so
[  3526.812] (II) Module vboxvideo: vendor="Oracle Corporation"
[  3526.812]    compiled for 1.5.99.901, module version = 1.0.1
[  3526.812]    Module class: X.Org Video Driver
[  3526.812]    ABI class: X.Org Video Driver, version 8.0
[  3526.812] (**) Load address of symbol "VBOXVIDEO" is 0xb72df340
[  3526.812] (II) VBoxVideo: guest driver for VirtualBox: vbox
[  3526.812] (--) using VT number 7

[  3526.822] (II) VBoxVideo(0): VirtualBox guest additions video driver version 3.2.12_OSE
[  3526.822] (II) Loading sub module "vbe"
[  3526.822] (II) LoadModule: "vbe"
[  3526.822] (II) Loading /usr/lib/xorg/modules/libvbe.so
[  3526.822] (II) Module vbe: vendor="X.Org Foundation"
[  3526.822]    compiled for 1.9.4, module version = 1.1.0
[  3526.822]    ABI class: X.Org Video Driver, version 8.0
[  3526.822] (II) Loading sub module "int10"
[  3526.822] (II) LoadModule: "int10"
[  3526.822] (II) Loading /usr/lib/xorg/modules/libint10.so
[  3526.823] (II) Module int10: vendor="X.Org Foundation"
[  3526.823]    compiled for 1.9.4, module version = 1.0.0
[  3526.823]    ABI class: X.Org Video Driver, version 8.0
[  3526.823] (II) VBoxVideo(0): initializing int10
[  3526.823] (II) VBoxVideo(0): Primary V_BIOS segment is: 0xc000
[  3526.826] (II) VBoxVideo(0): VESA BIOS detected
[  3526.826] (II) VBoxVideo(0): VESA VBE Version 2.0
[  3526.826] (II) VBoxVideo(0): VESA VBE Total Mem: 98304 kB
[  3526.826] (II) VBoxVideo(0): VESA VBE OEM: VirtualBox VBE BIOS http://www.virtualbox.org/
[  3526.826] (II) VBoxVideo(0): VESA VBE OEM Software Rev: 0.2
[  3526.826] (II) VBoxVideo(0): VESA VBE OEM Vendor: Oracle Corporation
[  3526.826] (II) VBoxVideo(0): VESA VBE OEM Product: Oracle VM VirtualBox VBE Adapter
[  3526.826] (II) VBoxVideo(0): VESA VBE OEM Product Rev: Oracle VM VirtualBox Version 4.0.4
[  3526.826] (II) Loading sub module "ramdac"
[  3526.826] (II) LoadModule: "ramdac"
[  3526.826] (II) Module "ramdac" already built-in
[  3526.826] (II) Loading sub module "fb"
[  3526.826] (II) LoadModule: "fb"
[  3526.826] (II) Loading /usr/lib/xorg/modules/libfb.so
[  3526.826] (II) Module fb: vendor="X.Org Foundation"
[  3526.826]    compiled for 1.9.4, module version = 1.0.0
[  3526.826]    ABI class: X.Org ANSI C Emulation, version 0.4
[  3526.826] (II) Loading sub module "shadowfb"
[  3526.826] (II) LoadModule: "shadowfb"
[  3526.826] (II) Loading /usr/lib/xorg/modules/libshadowfb.so
[  3526.826] (II) Module shadowfb: vendor="X.Org Foundation"
[  3526.826]    compiled for 1.9.4, module version = 1.0.0
[  3526.826]    ABI class: X.Org ANSI C Emulation, version 0.4
[  3526.826] (II) Loading sub module "vgahw"
[  3526.826] (II) LoadModule: "vgahw"
[  3526.827] (II) Loading /usr/lib/xorg/modules/libvgahw.so
[  3526.827] (II) Module vgahw: vendor="X.Org Foundation"
[  3526.827]    compiled for 1.9.4, module version = 0.1.0
[  3526.827]    ABI class: X.Org Video Driver, version 8.0
[  3526.827] (==) VBoxVideo(0): Depth 24, (--) framebuffer bpp 32
[  3526.827] (II) VBoxVideo(0): Output VBOX1 using monitor section Monitor0
[  3526.827] (II) VBoxVideo(0): Output VBOX1 has no monitor section
[  3526.827] (II) VBoxVideo(0): Not using default mode "640x350" (vrefresh out of range)
[  3526.827] (II) VBoxVideo(0): Not using default mode "320x175" (doublescan mode not supported)
[  3526.827] (II) VBoxVideo(0): Not using default mode "640x400" (vrefresh out of range)
[  3526.827] (II) VBoxVideo(0): Not using default mode "320x200" (doublescan mode not supported)
[  3526.827] (II) VBoxVideo(0): Not using default mode "720x400" (vrefresh out of range)
[  3526.827] (II) VBoxVideo(0): Not using default mode "360x200" (doublescan mode not supported)
[  3526.827] (II) VBoxVideo(0): Not using default mode "320x240" (doublescan mode not supported)
[  3526.827] (II) VBoxVideo(0): Not using default mode "640x480" (vrefresh out of range)
[  3526.827] (II) VBoxVideo(0): Not using default mode "320x240" (doublescan mode not supported)
[  3526.827] (II) VBoxVideo(0): Not using default mode "640x480" (vrefresh out of range)
[  3526.827] (II) VBoxVideo(0): Not using default mode "320x240" (doublescan mode not supported)
[  3526.827] (II) VBoxVideo(0): Not using default mode "640x480" (vrefresh out of range)
[  3526.827] (II) VBoxVideo(0): Not using default mode "320x240" (doublescan mode not supported)
[  3526.827] (II) VBoxVideo(0): Not using default mode "800x600" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "400x300" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "400x300" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "800x600" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "400x300" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "800x600" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "400x300" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "800x600" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "400x300" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1024x768i" (interlace mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "512x384i" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "512x384" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1024x768" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "512x384" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1024x768" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "512x384" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1024x768" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "512x384" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1152x864" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "576x432" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1280x960" (hsync out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "640x480" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1280x960" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "640x480" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1280x1024" (hsync out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "640x512" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1280x1024" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "640x512" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1280x1024" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "640x512" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1600x1200" (hsync out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "800x600" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1600x1200" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "800x600" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1600x1200" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "800x600" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1600x1200" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "800x600" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1600x1200" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "800x600" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1792x1344" (hsync out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "896x672" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1792x1344" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "896x672" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1856x1392" (hsync out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "928x696" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1856x1392" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "928x696" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1920x1440" (hsync out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "960x720" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1920x1440" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "960x720" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "832x624" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "416x312" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1400x1050" (hsync out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "700x525" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1400x1050" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "700x525" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1920x1440" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "960x720" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "2048x1536" (hsync out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1024x768" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "2048x1536" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1024x768" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Not using default mode "2048x1536" (vrefresh out of range)
[  3526.828] (II) VBoxVideo(0): Not using default mode "1024x768" (doublescan mode not supported)
[  3526.828] (II) VBoxVideo(0): Printing probed modes for output VBOX1
[  3526.828] (II) VBoxVideo(0): Modeline "1278x899"x60.0   69.72  1278 1280 1282 1284  899 901 903 905 (54.3 kHz)
[  3526.829] (II) VBoxVideo(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
[  3526.829] (II) VBoxVideo(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
[  3526.829] (II) VBoxVideo(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
[  3526.829] (II) VBoxVideo(0): Output VBOX1 connected
[  3526.829] (II) VBoxVideo(0): Using exact sizes for initial modes
[  3526.829] (II) VBoxVideo(0): Output VBOX1 using initial mode 1278x899
[  3526.829] (II) VBoxVideo(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[  3526.829] (==) VBoxVideo(0): RGB weight 888
[  3526.829] (==) VBoxVideo(0): Default visual is TrueColor
[  3526.829] (==) VBoxVideo(0): DPI set to (96, 96)
[  3526.829] (II) Loading sub module "dri"
[  3526.829] (II) LoadModule: "dri"
[  3526.829] (II) Reloading /usr/lib/xorg/modules/extensions/libdri.so
[  3526.829] (--) Depth 24 pixmap format is 32 bpp
[  3527.344] (==) VBoxVideo(0): Default visual is TrueColor
[  3527.344] drmOpenDevice: node name is /dev/dri/card0
[  3527.344] drmOpenDevice: open result is 11, (OK)
[  3527.344] drmOpenDevice: node name is /dev/dri/card0
[  3527.344] drmOpenDevice: open result is 11, (OK)
[  3527.344] drmOpenByBusid: Searching for BusID pci:0000:00:02.0
[  3527.344] drmOpenDevice: node name is /dev/dri/card0
[  3527.344] drmOpenDevice: open result is 11, (OK)
[  3527.344] drmOpenByBusid: drmOpenMinor returns 11
[  3527.344] drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
[  3527.344] (II) [drm] DRM interface version 1.4
[  3527.344] (II) [drm] DRM open master succeeded.
[  3527.344] (II) VBoxVideo(0): [drm] Using the DRM lock SAREA also for drawables.
[  3527.344] (II) VBoxVideo(0): [drm] framebuffer handle = 0xe0000000
[  3527.345] (II) VBoxVideo(0): [drm] added 1 reserved context for kernel
[  3527.345] (II) VBoxVideo(0): X context handle = 0x1
[  3527.345] (II) VBoxVideo(0): [drm] installed DRM signal handler
[  3527.345] (II) VBoxVideo(0): visual configurations initialized
[  3527.345] (==) VBoxVideo(0): Backing store disabled
[  3527.345] (II) VBoxVideo(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[  3527.351] (==) VBoxVideo(0): DPMS enabled
[  3527.352] (II) VBoxVideo(0): The VBox video extensions are now enabled.
[  3527.352] (II) VBoxVideo(0): [DRI] installation complete
[  3527.352] (--) RandR disabled
[  3527.352] (II) Initializing built-in extension Generic Event Extension
[  3527.352] (II) Initializing built-in extension SHAPE
[  3527.352] (II) Initializing built-in extension MIT-SHM
[  3527.352] (II) Initializing built-in extension XInputExtension
[  3527.352] (II) Initializing built-in extension XTEST
[  3527.352] (II) Initializing built-in extension BIG-REQUESTS
[  3527.352] (II) Initializing built-in extension SYNC
[  3527.352] (II) Initializing built-in extension XKEYBOARD
[  3527.352] (II) Initializing built-in extension XC-MISC
[  3527.352] (II) Initializing built-in extension XINERAMA
[  3527.352] (II) Initializing built-in extension XFIXES
[  3527.352] (II) Initializing built-in extension RENDER
[  3527.352] (II) Initializing built-in extension RANDR
[  3527.352] (II) Initializing built-in extension COMPOSITE
[  3527.352] (II) Initializing built-in extension DAMAGE
[  3527.360] (II) AIGLX: Screen 0 is not DRI2 capable
[  3527.360] drmOpenDevice: node name is /dev/dri/card0
[  3527.360] drmOpenDevice: open result is 12, (OK)
[  3527.360] drmOpenByBusid: Searching for BusID pci:0000:00:02.0
[  3527.360] drmOpenDevice: node name is /dev/dri/card0
[  3527.360] drmOpenDevice: open result is 12, (OK)
[  3527.360] drmOpenByBusid: drmOpenMinor returns 12
[  3527.360] drmOpenByBusid: Interface 1.4 failed, trying 1.1
[  3527.360] drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
[  3527.370] (EE) AIGLX error: Calling driver entry point failed
[  3527.378] (EE) AIGLX: reverting to software rendering
[  3527.381] (II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
[  3527.381] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[  3527.381] (II) VBoxVideo(0): Setting screen physical size to 338 x 237
[  3527.436] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[  3527.436] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  3527.436] (II) LoadModule: "evdev"
[  3527.436] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  3527.436] (II) Module evdev: vendor="X.Org Foundation"
[  3527.436]    compiled for 1.9.4, module version = 2.6.0
[  3527.436]    Module class: X.Org XInput Driver
[  3527.436]    ABI class: X.Org XInput driver, version 11.0
[  3527.436] (**) Power Button: always reports core events
[  3527.436] (**) Power Button: Device: "/dev/input/event0"
[  3527.442] (--) Power Button: Found keys
[  3527.442] (II) Power Button: Configuring as keyboard
[  3527.442] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[  3527.442] (**) Option "xkb_rules" "evdev"
[  3527.442] (**) Option "xkb_model" "evdev"
[  3527.442] (**) Option "xkb_layout" "us"
[  3527.483] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[  3527.483] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[  3527.483] (**) Sleep Button: always reports core events
[  3527.483] (**) Sleep Button: Device: "/dev/input/event1"
[  3527.488] (--) Sleep Button: Found keys
[  3527.488] (II) Sleep Button: Configuring as keyboard
[  3527.488] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD)
[  3527.488] (**) Option "xkb_rules" "evdev"
[  3527.488] (**) Option "xkb_model" "evdev"
[  3527.488] (**) Option "xkb_layout" "us"
[  3527.490] (II) config/udev: Adding input device VirtualBox USB Tablet (/dev/input/event4)
[  3527.490] (**) VirtualBox USB Tablet: Applying InputClass "evdev pointer catchall"
[  3527.490] (**) VirtualBox USB Tablet: always reports core events
[  3527.490] (**) VirtualBox USB Tablet: Device: "/dev/input/event4"
[  3527.500] (--) VirtualBox USB Tablet: Found 9 mouse buttons
[  3527.500] (--) VirtualBox USB Tablet: Found scroll wheel(s)
[  3527.500] (--) VirtualBox USB Tablet: Found relative axes
[  3527.500] (--) VirtualBox USB Tablet: Found absolute axes
[  3527.500] (--) VirtualBox USB Tablet: Found x and y absolute axes
[  3527.500] (II) VirtualBox USB Tablet: Configuring as mouse
[  3527.500] (II) VirtualBox USB Tablet: Adding scrollwheel support
[  3527.500] (**) VirtualBox USB Tablet: YAxisMapping: buttons 4 and 5
[  3527.500] (**) VirtualBox USB Tablet: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  3527.500] (II) XINPUT: Adding extended input device "VirtualBox USB Tablet" (type: MOUSE)
[  3527.500] (EE) VirtualBox USB Tablet: failed to initialize for relative axes.
[  3527.500] (II) VirtualBox USB Tablet: initialized for absolute axes.
[  3527.500] (II) config/udev: Adding input device VirtualBox USB Tablet (/dev/input/mouse1)
[  3527.500] (II) No input driver/identifier specified (ignoring)
[  3527.504] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event2)
[  3527.504] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[  3527.504] (**) AT Translated Set 2 keyboard: always reports core events
[  3527.504] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event2"
[  3527.514] (--) AT Translated Set 2 keyboard: Found keys
[  3527.514] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[  3527.515] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[  3527.515] (**) Option "xkb_rules" "evdev"
[  3527.515] (**) Option "xkb_model" "evdev"
[  3527.515] (**) Option "xkb_layout" "us"
[  3527.516] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/event3)
[  3527.516] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "evdev pointer catchall"
[  3527.516] (**) ImExPS/2 Generic Explorer Mouse: always reports core events
[  3527.516] (**) ImExPS/2 Generic Explorer Mouse: Device: "/dev/input/event3"
[  3527.524] (--) ImExPS/2 Generic Explorer Mouse: Found 9 mouse buttons
[  3527.524] (--) ImExPS/2 Generic Explorer Mouse: Found scroll wheel(s)
[  3527.524] (--) ImExPS/2 Generic Explorer Mouse: Found relative axes
[  3527.524] (--) ImExPS/2 Generic Explorer Mouse: Found x and y relative axes
[  3527.524] (II) ImExPS/2 Generic Explorer Mouse: Configuring as mouse
[  3527.524] (II) ImExPS/2 Generic Explorer Mouse: Adding scrollwheel support
[  3527.524] (**) ImExPS/2 Generic Explorer Mouse: YAxisMapping: buttons 4 and 5
[  3527.524] (**) ImExPS/2 Generic Explorer Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  3527.524] (II) XINPUT: Adding extended input device "ImExPS/2 Generic Explorer Mouse" (type: MOUSE)
[  3527.525] (**) ImExPS/2 Generic Explorer Mouse: (accel) keeping acceleration scheme 1
[  3527.525] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration profile 0
[  3527.525] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration factor: 2.000
[  3527.525] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration threshold: 4
[  3527.525] (II) ImExPS/2 Generic Explorer Mouse: initialized for relative axes.
[  3527.525] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/mouse0)
[  3527.525] (II) No input driver/identifier specified (ignoring)
[  3534.125]
Backtrace:
[  3534.125] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e930b]
[  3534.125] 1: /usr/bin/X (0x8048000+0x60645) [0x80a8645]
[  3534.126] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb771840c]
[  3534.126] 3: /usr/bin/X (0x8048000+0x6696e) [0x80ae96e]
[  3534.126] 4: /usr/bin/X (0x8048000+0x660ff) [0x80ae0ff]
[  3534.126] 5: /usr/bin/X (0x8048000+0x5dd46) [0x80a5d46]
[  3534.126] 6: /usr/bin/X (FlushAllOutput+0x157) [0x80a6807]
[  3534.126] 7: /usr/bin/X (0x8048000+0x29077) [0x8071077]
[  3534.127] 8: /usr/bin/X (0x8048000+0x1d77a) [0x806577a]
[  3534.127] 9: /lib/libc.so.6 (__libc_start_main+0xe6) [0xb7466bb6]
[  3534.127] 10: /usr/bin/X (0x8048000+0x1d331) [0x8065331]
[  3534.127] Segmentation fault at address (nil)
[  3534.127]
Fatal server error:
[  3534.127] Caught signal 11 (Segmentation fault). Server aborting
[  3534.127]
[  3534.127]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  3534.127] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  3534.128]
[  3534.132] (II) Power Button: Close
[  3534.132] (II) UnloadModule: "evdev"
[  3534.141] (II) Sleep Button: Close
[  3534.141] (II) UnloadModule: "evdev"
[  3534.158] (II) VirtualBox USB Tablet: Close
[  3534.158] (II) UnloadModule: "evdev"
[  3534.166] (II) AT Translated Set 2 keyboard: Close
[  3534.166] (II) UnloadModule: "evdev"
[  3534.183] (II) ImExPS/2 Generic Explorer Mouse: Close
[  3534.183] (II) UnloadModule: "evdev"
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Thu Apr 21, 2011 9:03 pm    Post subject: Re: Keine deutsche Tastatur in X11 trotz Einstellung in der Reply with quote

kraileth wrote:
.....
Hier mein entsprechender Abschnitt der xorg.conf:

Code:
Section "InputDevice"
            Identifier  "Keyboard0"
            Driver       "kbd"
            Option "XkbLayout" "de"
EndSection


Hat jemand eine Idee, was ich falsch mache oder was noch an zusätzlichen Systemanpassungen notwendig sein könnte?

Die gesamte Section "InputDevice" wird so vermutlich gar nicht genutzt.
Beachte das ab >=xorg-server-1.8 mit udev Section "InputClass" verwendet werden muss.
Versuche es mal mit folgendem:
Code:
Section "InputClass"
       Identifier  "Keyboard-all"
       Driver      "kbd"
       Option     "XkbLayout" "de"
       MatchIsKeyboard  "on"
EndSection

Ansonsten schau auch noch mal im Xorg-server 1.8 Upgrade Guide
Back to top
View user's profile Send private message
kraileth
n00b
n00b


Joined: 12 Jan 2011
Posts: 23

PostPosted: Fri Apr 22, 2011 6:30 pm    Post subject: Reply with quote

Vielen Dank (wieder einmal!), Josef.95!

Daß es das Upgrade-Guide gab, habe ich zwar im Handbuch gesehen, hatte aber beschlossen, es vorläufig zu ignorieren. Grund: Ich wollte ein funktionierendes X haben, welches nicht gerade das neueste sein mußte. Daß die Anleitungen nicht gerade eben den neusten Stand abbilden und seit dem das neuere X standardmäßig emerged wird, war mir nicht bewußt (man sollte halt doch die Augen aufmachen, wenn Versionsnummern vorkommen und das Mitdenken nicht vergessen...).

Auf meinem System habe ich nun in LXDE sowohl von sich aus deutsches Tastaturlayout als auch die Umlaute, usw. Im Terminal werden die Umlaute zwar noch als Fragezeichen angezeigt, aber das ist in jeder Hinsicht erstmal zweitrangig und vernachlässigbar.

Um hier nur noch - falls mal jemand mit ähnlichen Problemen auf dieses Thema stoßen sollte - mein Vorgehen zu dokumentieren:

Ich entschloss mich aus Gründen der Systemhygiene (und weil ich ohnehin noch am lernen bin und praktisch jedes Mal die eine oder andere neue Erfahrung gemacht habe) zu einer weiteren Neuinstallation. Diesmal unterdrückte ich HAL in der USE-Variable über die make.conf und baute mein neues System auf. Mir fiel dabei auf, daß ich zuvor beim emergen vom Xorg-server für zwei Elemente ein static-libs über package.use hinzufügen mußte, was nun nicht mehr der Fall war und also wohl mit HAL zu tun hatte. Nachdem nun alles wieder emerged war, ließ ich mir von X eine neue Konfigurationsdatei erstellen und dachte, daß diese ja dann auf einem HAL-freien System ja wohl dem neuen Format entsprechen würde. Das tat sie jedoch nicht, also editierte ich den Tastaturteil so, daß er mit dem hier von Josef.95 angegebenen übereinstimmte.

Konsequenz davon: Startx gab aus, keinen Bildschirm zu finden (was daran lag, daß er wegen eines Problems beim Parsen der xorg.conf nicht bis zum Monitorteil kam). Ich änderte schließlich noch die Maus-Sektion entsprechend ab und stellte fest, daß die Zeilen
Code:
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"

in der Sektion "ServerLayout" stören. Kommentiert man sie aus oder löscht sie, geht die ganze Sache und X startet. Allerdings versagten nun Maus und Tastatur ihren Dienst. Ich warf einen erneuten Blick auf die von Josef.95 verlinkte Anleitung (schadet ja nie) und sah, daß die eingetragenen Treiber abweichen. Und siehe da: Nach einem Austausch der Ursprünglichen gegen "evdev" ist auch dieses Problem behoben.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum