Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Net-snmp => Portage
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
arrakyn
n00b
n00b


Joined: 29 Apr 2011
Posts: 4

PostPosted: Fri Apr 29, 2011 10:06 am    Post subject: Net-snmp => Portage Reply with quote

Bonjour a tous,
Afin de supervisé un serveur gentoo je désire installer net-snmp sur celui-ci,
le emerge net-analyzer/net-snmp fonctionne très bien sur trois autre serveur similaire (gentoo 1.6.14) cependant le probleme est que quand j'essaye j'ai les erreurs suivantes :

Code:
ks etc # emerge net-analyzer/net-snmp
* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.
Calculating dependencies... done!
!!! All ebuilds that could satisfy "net-analyzer/net-snmp" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-analyzer/net-snmp-5.6.1 (masked by: EAPI 3)
- net-analyzer/net-snmp-5.5 (masked by: EAPI 3)
- net-analyzer/net-snmp-5.4.3 (masked by: EAPI 3)
- net-analyzer/net-snmp-5.4.2.1-r4 (masked by: EAPI 3)
The current version of portage supports EAPI '2'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


si je tente de mettre a jour mon portage j'ai le message suivant :

Code:
ks etc # emerge portage
* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.
Calculating dependencies... done!
[ebuild U ] app-misc/pax-utils-0.2.2 [0.1.13]
[ebuild N ] dev-libs/libffi-3.0.9-r2 USE="-debug -static-libs -test"
[ebuild N ] virtual/acl-0
[ebuild U ] dev-libs/expat-2.0.1-r3 [1.95.8]
[ebuild U ] sys-devel/gettext-0.18.1.1-r1 [0.14.4] USE="acl%* openmp%* -git% -nocxx%"
[ebuild U ] sys-apps/sandbox-2.4 [1.2.17] USE="(-multilib)"
[ebuild N ] virtual/libffi-0
[ebuild U ] sys-apps/findutils-4.4.2 [4.1.20-r2]
[ebuild U ] sys-devel/binutils-config-2-r1 [1.8-r7]
[ebuild U ] sys-devel/binutils-2.20.1-r1 [2.16.1-r2]
[ebuild NS ] sys-devel/libtool-2.2.10 [1.5.22] USE="-vanilla"
[ebuild U ] app-admin/eselect-1.2.11 [1.0.7]
[ebuild N ] app-admin/eselect-python-20100321
[ebuild U ] sys-apps/coreutils-8.5 [5.94-r1] USE="acl* unicode%* -caps% -gmp% -vanilla% -xattr%"
[ebuild U ] app-shells/bash-4.1_p9 [3.1_p16] USE="-examples% -mem-scramble% -net% -plugins% -vanilla%"
[ebuild NS ] dev-lang/python-2.7.1-r1 [2.4.2] USE="gdbm ncurses readline ssl (wide-unicode) xml -berkdb -build -doc -examples -ipv6 -sqlite -threads -tk -wininst"
[ebuild U ] sys-apps/portage-2.1.9.42 [2.1.1-r2] USE="(ipc%*) -epydoc% -python2% -python3%"
*** Portage will stop merging at this point and reload itself,
then resume the merge.
[ebuild N ] app-admin/python-updater-0.8-r1
[blocks B ] <app-shells/bash-3.2_p17 ("<app-shells/bash-3.2_p17" is blocking sys-apps/portage-2.1.9.42)
[blocks B ] <sys-apps/portage-2.1.7.16 ("<sys-apps/portage-2.1.7.16" is blocking app-shells/bash-4.1_p9)
[blocks B ] <sys-apps/util-linux-2.13 ("<sys-apps/util-linux-2.13" is blocking sys-apps/coreutils-8.5)
[blocks B ] <sys-apps/portage-2.1.9 ("<sys-apps/portage-2.1.9" is blocking dev-lang/python-2.7.1-r1)
* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.
For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Comment pourrais-je résoudre ces problèmes, une idée ?
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Fri Apr 29, 2011 11:00 am    Post subject: Reply with quote

mmmm le moins qu'on puisse dire, c'est que ton système n'a plus été mis à jour depuis longtemps... pour un serveur, niveau sécu, on a vu mieux.

Je proposerais de commencer par un
Code:

emerge -av1 bash

Voir si ça passe...
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Fri Apr 29, 2011 5:15 pm    Post subject: Reply with quote

'alute (et bienvenue sur le forum fr tant que j'y suis)

Poussin wrote:
mmmm le moins qu'on puisse dire, c'est que ton système n'a plus été mis à jour depuis longtemps... pour un serveur, niveau sécu, on a vu mieux.
(...)

Justement à ce propos, en prenant cette version tu vas devoir upgrader dans la bagarre des choses pas anodines du tout là (libtool, pax, expat, coreutils, python2.4, bash3)... je ne sais pas exactement à quoi sert ce serveur au juste mais dans la mesure ou tu évoques 3 serveurs synchone en version, un besoin de monitorer, que seul celui-ci plante etc : il me semble que penser à un plan de migration serait sans doute pas inutile avant de faire qqch sur ce dernier non ? Histoire de pas te retrouver en carafe - toi &| ta boite &| tes utilisateurs - pendant 48heures voire pire en cas de régression :roll:

Après moi j'dis çà j'dis rien hein ?! :wink:

Edit: Accessoirement, y'aurait qqch à faire sur le titre du fil au fait ^^
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7935
Location: ~Brussels - Belgique

PostPosted: Fri Apr 29, 2011 8:11 pm    Post subject: Reply with quote

Ca serait pas un Gentoo d'OVH ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
arrakyn
n00b
n00b


Joined: 29 Apr 2011
Posts: 4

PostPosted: Mon May 02, 2011 8:50 am    Post subject: Reply with quote

Bonne réponse, s'est effectivement un gentoo OVH
Actuellement je suis stagiaire en fait, et je doit m'occuper de supervision nagios, mais j'apprend qu'effectivement serveur est plus ou moins mort, donc migration.
Aussi il n'est pas nécessaire d'aller plus avant dans la supervision de celui ci puisqu'il va sans doute être supprimer du parc
autrement dit j'ai perdu du temps ;s

mais merci pour votre aide :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum