Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Adobe Flash unemerged
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
lukasletitburn
Apprentice
Apprentice


Joined: 17 Mar 2011
Posts: 209
Location: München

PostPosted: Sun May 01, 2011 7:04 am    Post subject: [solved]Adobe Flash unemerged Reply with quote

Hi Forum ich wollte eben flash emergen jedoch sagt er mir das dasd Paket maskiert ist. Wie ich kann ich das stable Paket installieren er gibt mir diese Meldung aus
Wie bekomme ich das nun installiert.
Code:
tux lukas # emerge -S adobe-flash
Searching...   
[ Results for search key : adobe-flash ]
[ Applications found : 1 ]

*  www-plugins/adobe-flash [ Masked ]
      Latest version available: 10.2.159.1_p201011173
      Latest version installed: [ Not Installed ]
      Size of files: 9,054 kB
      Homepage:      http://labs.adobe.com/technologies/flashplayer10/
      Description:   Adobe Flash Player
      License:       AdobeFlash-10.1

tux lukas # emerge www-plugin/10.2.159.1
!!! 'www-plugin/10.2.159.1' is not a valid package atom.
!!! Please check ebuild(5) for full details.


Last edited by lukasletitburn on Sun May 01, 2011 9:12 am; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sun May 01, 2011 7:22 am    Post subject: Reply with quote

http://packages.gentoo.org/package/www-plugins/adobe-flash
Welchen arch fährst du? Hast du adobe-flash maskiert (package.mask)? Evtl. etwas an ACCEPT_LICENSE rumgespielt?
http://en.gentoo-wiki.com/wiki/Licenses
Back to top
View user's profile Send private message
Knieper
l33t
l33t


Joined: 10 Nov 2005
Posts: 846

PostPosted: Sun May 01, 2011 8:00 am    Post subject: Re: Adobe Flash unemerged Reply with quote

lukasletitburn wrote:

Code:
tux lukas # emerge www-plugin/10.2.159.1

Dir ist klar, dass das kompletter Blödsinn ist? "emerge adobe-flash" reicht im Normalfall. Evtl. noch
Code:
www-plugins/adobe-flash AdobeFlash-10 AdobeFlash-10.1
in die /etc/portage/package.license einfügen.
_________________
Je dümmer desto Gnome/KDE.
Back to top
View user's profile Send private message
lukasletitburn
Apprentice
Apprentice


Joined: 17 Mar 2011
Posts: 209
Location: München

PostPosted: Sun May 01, 2011 8:19 am    Post subject: Reply with quote

Ich fahre x86_64

Wie stelle ich den und wo die License richtig ein das mir adobe-flash installiert wird? Kann es auch so einstellen das ich immer gefragt werde ob die License bei dem zu installierenden Paket annehme?

in /etc/make.globals

Steht sie auf EULA
Back to top
View user's profile Send private message
lukasletitburn
Apprentice
Apprentice


Joined: 17 Mar 2011
Posts: 209
Location: München

PostPosted: Sun May 01, 2011 8:23 am    Post subject: Reply with quote

So sieht es aus wenn ich die /etc/make.globals

bei ACCEPT_LICENSE auf:

FREE:

Code:

tux lukas # emerge adobe-flash

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy "www-plugins/nspluginwrapper" have been masked.
!!! One of the following masked packages is required to complete your request:
- www-plugins/nspluginwrapper-1.3.0 (masked by: GPL-2 license(s))
A copy of the 'GPL-2' license is located at '/usr/portage/licenses/GPL-2'.

- www-plugins/nspluginwrapper-1.2.2-r2 (masked by: GPL-2 license(s))

(dependency required by "www-plugins/adobe-flash-10.2.159.1" [ebuild])
(dependency required by "adobe-flash" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


EULA:

Code:

tux lukas # emerge adobe-flash

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy "adobe-flash" have been masked.
!!! One of the following masked packages is required to complete your request:
- www-plugins/adobe-flash-10.2.159.1_p201011173 (masked by: AdobeFlash-10.1 license(s), ~amd64 keyword)
A copy of the 'AdobeFlash-10.1' license is located at '/usr/portage/licenses/AdobeFlash-10.1'.

- www-plugins/adobe-flash-10.2.159.1 (masked by: AdobeFlash-10.1 license(s))
- www-plugins/adobe-flash-10.2.153.1_p201011173 (masked by: AdobeFlash-10.1 license(s), ~amd64 keyword)
- www-plugins/adobe-flash-10.2.153.1 (masked by: AdobeFlash-10.1 license(s))
- www-plugins/adobe-flash-10.2.152.27_p201011173-r2 (masked by: package.mask, AdobeFlash-10.1 license(s), ~amd64 keyword)
/usr/portage/profiles/package.mask:
# Jim Ramsay <lack@gentoo.org> (14 Apr 2011)
# Mask old unfetchable (Bug #360529) and security-vulnerable (Bug
# #354207,#359019) versions of Adobe flash player.
# Will be removed in a week or so.

- www-plugins/adobe-flash-10.2.152.27_p201011173-r1 (masked by: package.mask, AdobeFlash-10.1 license(s), ~amd64 keyword)
- www-plugins/adobe-flash-10.2.152.27 (masked by: package.mask, AdobeFlash-10.1 license(s))
- www-plugins/adobe-flash-10.1.102.64 (masked by: package.mask, AdobeFlash-10.1 license(s))
- www-plugins/adobe-flash-9.0.289.0 (masked by: package.mask, AdobeFlash-9.0.31.0 license(s), ~amd64 keyword)
A copy of the 'AdobeFlash-9.0.31.0' license is located at '/usr/portage/licenses/AdobeFlash-9.0.31.0'.


For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sun May 01, 2011 8:39 am    Post subject: Reply with quote

Andersrum sollte es sein: FREE beinhaltet GPL-2 (nspluginwrapper darf installiert werden), EULA NUR proprietäre Sachen (AdobeFlash-10, skype-eula, DOOM3, ...) (adobe-flash sollte installiert werden können).
Ich nehme an, du hast nicht verstanden, wie du die Licenses setzen musst. kannst du bitte den Eintrag posten, den du jeweils bei "FREE" und "EULA hattest?

//edit:
schau dir auch mal /usr/portage/profiles/license_groups an, da steht aufgelistet, was die einzelnen groups enthalten. Wurde aber auch in dem Gentoo-Wiki am Ende gesagt.


Last edited by franzf on Sun May 01, 2011 8:45 am; edited 1 time in total
Back to top
View user's profile Send private message
Knieper
l33t
l33t


Joined: 10 Nov 2005
Posts: 846

PostPosted: Sun May 01, 2011 8:42 am    Post subject: Reply with quote

lukasletitburn wrote:
Wie stelle ich den und wo die License richtig ein das mir adobe-flash installiert wird?

Das steht genau einen Beitrag vor dem zitierten. :roll:
_________________
Je dümmer desto Gnome/KDE.
Back to top
View user's profile Send private message
lukasletitburn
Apprentice
Apprentice


Joined: 17 Mar 2011
Posts: 209
Location: München

PostPosted: Sun May 01, 2011 9:12 am    Post subject: Reply with quote

Danke Kniper hatte deinen Eintrag nicht gesehen. Es funktioniert.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum