Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hylafax and usb-serial-adapter[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2231
Location: Germany

PostPosted: Sun May 01, 2011 5:13 pm    Post subject: hylafax and usb-serial-adapter[solved] Reply with quote

Hello,

who has this working? My Faxmodem work perfect with a native serial device, but if i use a usb->Serial adapter it will not work.

Code:
[    1.779031] usb 1-1.3: new full speed USB device using ehci_hcd and address 3
[    1.789982] hub 1-1:1.0: port 3 not reset yet, waiting 10ms
[    1.806283] usb 2-1: link qh256-0001/ffff88011346b200 start 1 [1/0 us]
[    1.864529] usb 1-1.3: default language 0x0409
[    1.865054] usb 1-1.3: udev 3, busnum 1, minor = 2
[    1.865058] usb 1-1.3: New USB device found, idVendor=067b, idProduct=2303
[    1.865181] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    1.865348] usb 1-1.3: Product: USB-Serial Controller
[    1.865455] usb 1-1.3: Manufacturer: Prolific Technology Inc.
[    1.865753] usb 1-1.3: usb_probe_device
[    1.865757] usb 1-1.3: configuration #1 chosen from 1 choice
[    1.865859] usb 1-1.3: adding 1-1.3:1.0 (config #1, interface 0)
[    1.865989] pl2303 1-1.3:1.0: usb_probe_interface
[    1.865993] pl2303 1-1.3:1.0: usb_probe_interface - got id
[    1.865998] pl2303 1-1.3:1.0: pl2303 converter detected
[    1.868464] usb 1-1.3: pl2303 converter now attached to ttyUSB0


I have the driver in my kernel and the Device seems to work, i could connect with

Code:
cu -l ttyUSB0
Connected


But thats it. No input through my keyboard works, must send a sigkill or sighup to free the session.

Have i missed something? I think i will brought another usb-modem... any suggestions? :D

I need this cause i will migrate the computer to newer hardware without a native serial device.

Update: Ok i was wrong! This work fine, my mistake: i check inside of CU my keyboard with typing random stuff like: kerhlkadsfztuio but the CU just accept instructions in a clear syntax. So "at+fclass=?" works fine and the modem too.

My migration would still not work cause of some name-changes in ttyS0 to ttyUSB0 and the device-override every reboot of my soft link ttyS0 -> ttyUSB0, during my tests.

Thanks all for reading and have a nice day :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum