Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[XEN] Lancement DomU Error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
spy20
Tux's lil' helper
Tux's lil' helper


Joined: 02 Nov 2010
Posts: 140

PostPosted: Tue May 03, 2011 7:43 am    Post subject: [XEN] Lancement DomU Error Reply with quote

Bonjour,

j'ai bien mon Dom0 qui tourne.

Je souhaite lancer une VM, sauf que ça marche pas.

Voici le contenu du fichier de configuration
Code:
import os, re
arch = os.uname()[4]
if re.search('64', arch):
    arch_libdir = 'lib64'
else:
    arch_libdir = 'lib'

kernel = "/usr/lib/xen/boot/hvmloader"
builder='hvm'
memory = 1024

# Should be at least 2KB per MB of domain memory, plus a few MB per vcpu.
shadow_memory = 8
name = "xenwin7"
vif = [ 'type=ioemu, bridge=xenbr0' ]
acpi = 1
apic = 1
disk = [ 'file:/home/xen/xenwin7.img,hda,w', 'file:/home/xen/windows7.iso,hdc:cdrom,r' ]

device_model = '/usr/' + arch_libdir + '/xen/bin/qemu-dm'

#-----------------------------------------------------------------------------
# boot on floppy (a), hard disk (c) or CD-ROM (d)
# default: hard disk, cd-rom, floppy
boot="dc"
sdl=0
vnc=1
vncconsole=1
vncpasswd=''

serial='pty'
usbdevice='tablet'



Mais au lancement j'ai ceci
Quote:
Error: Errors were found at line 5 while processing ./Windows7.cfg: else:

Et je ne comprends pas le soucis.
Ai-je un problème de Python ou je ne sais quoi ?

Merci d'avance pour vos conseils.
Cordialement,
Spy20
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8131
Location: ~Brussels - Belgique

PostPosted: Tue May 03, 2011 11:08 am    Post subject: Reply with quote

pas de ":" après le else ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
spy20
Tux's lil' helper
Tux's lil' helper


Joined: 02 Nov 2010
Posts: 140

PostPosted: Tue May 03, 2011 11:18 am    Post subject: Reply with quote

Je ne suis pas certains car le ":" est également présent sur le IF
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8131
Location: ~Brussels - Belgique

PostPosted: Tue May 03, 2011 11:24 am    Post subject: Reply with quote

Si tu n'est pas certain, vérifie la doc ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
spy20
Tux's lil' helper
Tux's lil' helper


Joined: 02 Nov 2010
Posts: 140

PostPosted: Tue May 03, 2011 2:54 pm    Post subject: Reply with quote

J'ai essayé avec et sans, le résultat est le même ; même erreur.

Je me suis appuyé sur ceci
http://www.virtuatopia.com/index.php/Installing_and_Running_Windows_7_as_a_Xen_HVM_domainU_Guest

Et si suppression du début de fichier je me retrouve avec ceci

spy20 xen # xm create Windows7.cfg
Using config file "./Windows7.cfg".
Error: Errors were found at line 7 while processing ./Windows7.cfg:
kernel = "/usr/lib/xen/boot/hvmloader"

Or le fichier existe bien
spy20 xen # ls -l /usr/lib/xen/boot/hvmloader
*-rw-r--r-- 1 root root 459736 3 mai 11:25 /usr/lib/xen/boot/hvmloader

J'ai dû loupé un truc, et je comprends pas le blocage
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum