Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VirtualBox 4.0.6 - USB does not work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Thu May 05, 2011 1:16 am    Post subject: VirtualBox 4.0.6 - USB does not work Reply with quote

Don't bother upgrading if you use USB devices from the host, in the guest.
_________________
...Lyall
Back to top
View user's profile Send private message
gqman69
n00b
n00b


Joined: 11 Jul 2007
Posts: 50

PostPosted: Thu May 05, 2011 3:28 am    Post subject: Reply with quote

Yep, tried everything. Not working here either.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Thu May 05, 2011 5:12 am    Post subject: Reply with quote

I looked at thread, then changed my /etc/fstab entry to be:
Code:
none /proc/bus/usb usbfs devgid=31,devmode=664

Then remount /proc/bus/usb - and now it works :)

Note that the first word in that line is "none". I had previously tried "usbfs", which weirdly kinda half-works :? Unless it works sometimes :?:

My 31 is taken from:
Code:
grep ^usb: /etc/group | cut -d: -f3
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Thu May 05, 2011 5:35 am    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=364719

:wink:
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Thu May 05, 2011 5:52 am    Post subject: Reply with quote

I don't have a /proc/bus/usb directory.
It's a deprecated facility.
Also, 4.0.4 works just fine on my system with no change.

The solution in gentoo bug 364719 talks about a VBoxCreateUSBNode.sh script, which is not part of app-emulation/virtualbox ebuild.

For me, the solution is to simply mask 4.0.6 as useless and downgrade to 4.0.4, which worked fine, at least, for me.

About ever 3rd release of virtualbox results in some form of regression, this is one of those.
_________________
...Lyall
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Thu May 05, 2011 7:53 am    Post subject: Reply with quote

lyallp wrote:
deprecated

Yeah. I tested again, after running: umount /proc/bus/usb
It still works :?

I'm a bit confused as to why I had problems yesterday, which have mysteriously disappeared now.

I'm using virtualbox's own .run file, which installs /etc/udev/rules.d/10-vboxdrv.rules containing:
Code:
KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
SUBSYSTEM=="usb_device", ACTION=="add", RUN="/opt/VirtualBox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN="/opt/VirtualBox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN="/opt/VirtualBox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN="/opt/VirtualBox/VBoxCreateUSBNode.sh --remove $major $minor"
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Thu May 05, 2011 10:42 am    Post subject: Reply with quote

You can get the script from here http://www.virtualbox.org/browser/trunk/src/VBox/Installer/linux/VBoxCreateUSBNode.sh
Remember to make it executable!
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Thu May 05, 2011 11:22 am    Post subject: Reply with quote

Easier to simply revert and wait till 4.0.8 - it will be out soon, you can bet on it.
_________________
...Lyall
Back to top
View user's profile Send private message
gqman69
n00b
n00b


Joined: 11 Jul 2007
Posts: 50

PostPosted: Thu May 05, 2011 8:02 pm    Post subject: Reply with quote

I don't know...

Why should we start using some rules where it creates devices which exists
simply for virtualbox?

All this seems amateurish at best...
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Tue May 17, 2011 7:20 am    Post subject: Reply with quote

4.0.8 is out.
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Tue May 17, 2011 5:30 pm    Post subject: Reply with quote

PaulBredbury wrote:
4.0.8 is out.


Yeah and there is nothing in changelog about the this USB problem :wink:
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
fivebulldogs
n00b
n00b


Joined: 18 May 2011
Posts: 1
Location: Stockholm/Sweden

PostPosted: Wed May 18, 2011 9:27 am    Post subject: Reply with quote

I just upgraded to 4.0.8 (not via portage) and got a USB mass storage device to appear in a Win7 guest on a Gentoo host for the first time! Wohoo!
Back to top
View user's profile Send private message
gqman69
n00b
n00b


Joined: 11 Jul 2007
Posts: 50

PostPosted: Thu May 19, 2011 12:09 am    Post subject: Reply with quote

4.0.6-r1 seems to fix all
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Thu May 19, 2011 4:18 am    Post subject: Reply with quote

4.0.6-r1 and 4.0.8 rolled in the usb dev rules hack, described above.
_________________
...Lyall
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum