Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Résolu]Problème de Grub à l'installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
nost4r
Apprentice
Apprentice


Joined: 08 Oct 2006
Posts: 164
Location: Bordeaux

PostPosted: Sat May 07, 2011 12:54 pm    Post subject: [Résolu]Problème de Grub à l'installation Reply with quote

Bonjour

J'ai voulu me remettre à Gentoo depuis quelques années d'abstinence mais j'ai découvert Funtoo que j'ai voulu tester.

Donc j'ai suivi ca http://www.funtoo-quebec.org/wiki/index.php/Formation_%C3%A0_Funtoo_GNU/Linux_-_Atelier_5

J'en suis à l'étape de boot-update, quand je fais un boot-update, je n'ai que ma partition windows 7 qui apparait dans /boot/grub/grub.cfg , le voici : ( avec une petite erreur lors du boot-update :
Code:
 * Generating config for grub...

 DEFAULT > Windows 7

 * WARN : No boot/default match found - using first boot entry by default.
 * Completed successfully with warnings.


Code:
 /boot/grub/grub.cfg

set timeout=10

menuentry "Windows 7" {
  insmod part_msdos
  insmod ntfs
  set root=(hd0,3)
  search --no-floppy --fs-uuid --set f40206aa020671c2
  chainloader +4
}
set default=0




Voici mon etc/boot.conf :

Code:
 /etc/boot.conf
                         
        boot {
        generate grub
        default "Funtoo Linux"
        timeout 10
}

"Funtoo Linux" {
        kernel vmlinuz[-v]
}

"Funtoo Linux genkernel" {
        kernel kernel[-v]
        initrd initramfs[-v]
        params += real_root=auto
}

"Windows 7" {
        type win7
        params root=/dev/sda3
}



J'ai remplacé bzimage par vmlinuz pour voir mais ca n'a rien changé

Voici mon fstab :

Code:

#/dev/cdrom             /mnt/cdrom      auto            noauto,ro       0 0
/dev/sda5               /boot           ext2            noauto,noatime  1 2
/dev/sda6               none            swap            sw              0 0
/dev/sda7               /               ext4            noatime         0 1



Ce sont toutes des partitions étendues
dev/sda1 est une partition recovery du bios
sda2 est la partition systeme de win7 et sda3 est ma partition windows7.

Donc la je suis bloqué sur mon live cd de system rescue .
J'attends votre aide avec impatience...
Merci


Last edited by nost4r on Sun May 08, 2011 9:48 am; edited 1 time in total
Back to top
View user's profile Send private message
fb99
l33t
l33t


Joined: 09 Apr 2003
Posts: 998
Location: Le Locle (Suisse,Neuchâtel)

PostPosted: Sat May 07, 2011 1:29 pm    Post subject: Reply with quote

Je suis pas spécialiste de funtoo, mais tu ne devrais pas lui dire ou est ta partitions de boot (sda5). Car la en fait il te dit qu'il ne la trouve pas il qu'il utilise le mbr(ou la premiere entrée par défaut) par défaut.

Code:
emerge --ask boot-update grub
grub-install /dev/sda


la je crois qu'il faudrait peut-etre rajouter un 5 pas de gentoo sur la main pour t'en dire plus mais un grub-install --help ou un simple recherche devrait t'aider



bon courage
_________________
L'ami aime en tout temps, et dans le malheur il se montre un frère ( Prov. 17,17 )
L'insensé même, quand il se tait, passe pour sage ( Prov. 17;28a )
Back to top
View user's profile Send private message
nost4r
Apprentice
Apprentice


Joined: 08 Oct 2006
Posts: 164
Location: Bordeaux

PostPosted: Sat May 07, 2011 1:34 pm    Post subject: Reply with quote

Aie je vois ton message trop tard, en fait j'ai regardé le handbook de gentoo et j'ai fais un
Code:
cp arch/x86_64/boot/bzImage /boot/linuxl-2.6.38-gentoo-r4
qui n'est pas précisé dans la doc de funtoo et lors du boot-update il a bien reconnu la partition, la j'ai quitté le chroot, je vais tenté un reboot
Back to top
View user's profile Send private message
fb99
l33t
l33t


Joined: 09 Apr 2003
Posts: 998
Location: Le Locle (Suisse,Neuchâtel)

PostPosted: Sat May 07, 2011 2:05 pm    Post subject: Reply with quote

C'est encore mieux de se débrouiller tout seul, c'est comme ca qu'on apprend. N'hésite pas a demander comment fonctionne une commande, et --help + man ... + handbook + moteur de recherche (web+forums gentoo) + demande sur forums.

Depuis quelque temps je ne cours plus apres les mise a jour. Je change quand c'est nécessaire. Je préfere avoir un system stable et qui fonctionne plutot que de tout le temps bidouiller (dépenser du temps). Mais je reste sous gentoo les premiers amours... ca dure. et puis je peux ce que je veux si j'y consacre le temps nécessaires.


PS: oubli pas le résolu si ca fonctionne et bon change sur funtoo
_________________
L'ami aime en tout temps, et dans le malheur il se montre un frère ( Prov. 17,17 )
L'insensé même, quand il se tait, passe pour sage ( Prov. 17;28a )
Back to top
View user's profile Send private message
nost4r
Apprentice
Apprentice


Joined: 08 Oct 2006
Posts: 164
Location: Bordeaux

PostPosted: Sat May 07, 2011 7:00 pm    Post subject: Reply with quote

Juste une petite question avant de passer en résolu, je me rappelle que sur gentoo il fallait faire des liens symboliques du kernel et de /boot dans /boot , ce n'est pas obligatoire ?


Juste oublié de dire que tout marche bien, enfin il me reste à installer gnome pour avoir un système fonctionnel.
Et aussi chose que je n'ai vu nul part , pour pouvoir booter sur win7 depuis grub, il faut dans la config de grub mettre comme partition, la partition système de 100 mo et non la partition windows sinon on a un "BOOTMGR ABSENT" au démarrage
Back to top
View user's profile Send private message
nost4r
Apprentice
Apprentice


Joined: 08 Oct 2006
Posts: 164
Location: Bordeaux

PostPosted: Sun May 08, 2011 9:48 am    Post subject: Reply with quote

Bon j'abandonne, j'ai voulu installer gnome mais erreur de compilation sur erreur de compilation , je vais m'installer une debian , je vais être tranquille.

Merci quand même.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8131
Location: ~Brussels - Belgique

PostPosted: Mon May 09, 2011 7:21 am    Post subject: Reply with quote

Si tu ne veux même pas qu'on t'aide... c'est bien dommage !
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum