Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Help with kradview ebuild please :)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Sun May 08, 2011 8:45 am    Post subject: Help with kradview ebuild please :) Reply with quote

There is an ebuild in bugzilla but it's old and does not work.
I pirated some other ebuilds and achieved some progress but my knowledge ends here :

Quote:
emerge kradview
Calculating dependencies ... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) kde-misc/kradview-1.1.0 from repo_name-seti
* kradview-1.1.0.tgz RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* Package: kde-misc/kradview-1.1.0
* Repository: repo_name-seti
* USE: amd64 elibc_glibc kernel_linux multilib userland_GNU
* FEATURES: ccache preserve-libs sandbox
>>> Unpacking source...
>>> Unpacking kradview-1.1.0.tgz to /var/tmp/portage/kde-misc/kradview-1.1.0/work
>>> Source unpacked in /var/tmp/portage/kde-misc/kradview-1.1.0/work
>>> Preparing source in /var/tmp/portage/kde-misc/kradview-1.1.0/work/kradview-1.1.0 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/kde-misc/kradview-1.1.0/work/kradview-1.1.0 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-misc/kradview-1.1.0/work/kradview-1.1.0_build"
* Unable to locate CMakeLists.txt under:
* "/var/tmp/portage/kde-misc/kradview-1.1.0/work/kradview-1.1.0/CMakeLists.txt"
* Consider not inheriting the cmake eclass.
* ERROR: kde-misc/kradview-1.1.0 failed (configure phase):
* FATAL: Unable to find CMakeLists.txt
*
* Call stack:
* ebuild.sh, line 56: Called src_configure
* environment, line 4064: Called kde4-base_src_configure
* environment, line 3188: Called cmake-utils_src_configure
* environment, line 1287: Called _execute_optionaly 'src_configure'
* environment, line 653: Called enable_cmake-utils_src_configure
* environment, line 1548: Called die
* The specific snippet of code:
* die "FATAL: Unable to find CMakeLists.txt";
*
* If you need support, post the output of 'emerge --info =kde-misc/kradview-1.1.0',
* the complete build log and the output of 'emerge -pqv =kde-misc/kradview-1.1.0'.
* This ebuild is from an overlay named 'repo_name-seti': '/usr/local/portage/'
* The complete build log is located at '/var/log/portage/buildlog/kde-misc:kradview-1.1.0:20110508-083125.log'.
* The ebuild environment file is located at '/var/tmp/portage/kde-misc/kradview-1.1.0/temp/environment'.
* S: '/var/tmp/portage/kde-misc/kradview-1.1.0/work/kradview-1.1.0'


Well i don`t know how not to inherit cmake eclass and build with make :roll:

Developer's page : http://www.orcero.org/irbis/kradview/

my current ebuild "kradview-1.1.0.ebuild"

Code:

# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=4
inherit kde4-base
IUSE=""

DESCRIPTION="DICOM/Radiology viewer"
HOMEPAGE="http://www.orcero.org/irbis/kradview"
SRC_URI="http://www.orcero.org/irbis/${PN}/${P}.tgz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND=""
DEPEND="${RDEPEND}"
DOCS=( AUTHORS ChangeLog )
S="${WORKDIR}/${P}"


The bugzilla entry: https://bugs.gentoo.org/show_bug.cgi?id=189541
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Sun May 08, 2011 9:03 am    Post subject: Reply with quote

Just made some progress i disabled "inherit kde4-base" and added "EAPI=1"

Code:
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=1
#inherit kde4-base
IUSE=""

DESCRIPTION="DICOM/Radiology viewer"
HOMEPAGE="http://www.orcero.org/irbis/kradview"
SRC_URI="http://www.orcero.org/irbis/${PN}/${P}.tgz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND=""
DEPEND="${RDEPEND}"
DOCS=( AUTHORS ChangeLog )
S="${WORKDIR}/${P}"


The error is:
Code:
checking for libXext... yes
checking for pthread_create in -lpthread... yes
checking for extra includes... no
checking for extra libs... no
checking for libz... -lz
checking for libpng... -lpng -lz -lm
checking for libjpeg6b... no
checking for libjpeg... -ljpeg
checking for perl... /usr/bin/perl
checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.


config.log

Code:
configure:28807: checking for Qt
configure: 28872: /usr/lib/qt3/include/qstyle.h
configure: 28872: /usr/lib/qt3/qstyle.h
configure: 28872: /usr/lib/qt/include/qstyle.h
configure: 28872: /usr/lib/qt/qstyle.h
configure: 28872: /usr/share/qt3/include/qstyle.h
configure: 28872: /usr/share/qt3/qstyle.h
configure: 28872: /usr/local/qt/include/qstyle.h
configure: 28872: /usr/include/qt/qstyle.h
configure: 28872: /usr/include/qstyle.h
configure: 28872: /usr/X11R6/include/X11/qt/qstyle.h
configure: 28872: /usr/X11R6/include/qt/qstyle.h
configure: 28872: /usr/X11R6/include/qt2/qstyle.h
configure: 28872: /usr/include/qt3/qstyle.h
configure: 28872: ./qstyle.h
tried NO
tried /usr/lib/qt3/lib
tried /usr/lib/qt3
tried /usr/lib/qt/lib
tried /usr/lib/qt
tried /usr/share/qt3/lib
tried /usr/share/qt3
tried /usr/X11R6/lib
tried /usr/lib
tried /usr/local/qt/lib
tried /usr/lib64
configure:28989: rm -rf SunWS_cache; x86_64-pc-linux-gnu-g++ -o conftest -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -O2 -march=athlon64-sse3 -O2 -pipe -fomit-frame-pointer -ftree-vectorize -ftree-loop-linear -fvisibility-inlines-hidden -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -INO -I.  -DQT_THREAD_SUPPORT  -D_REENTRANT -Wl,-O1 -Wl,--as-needed -Wl,--enable-new-dtags -LNONE -L/usr/lib64   conftest.cpp  -lqt-mt -lpng -lz -lm -ljpeg -ldl  -lXext -lX11 -lSM -lICE  -lpthread 1>&5
conftest.cpp:2:21: fatal error: qglobal.h: No such file or directory
compilation terminated.
configure:28992: $? = 1
configure: failed program was:
#include "confdefs.h"
#include <qglobal.h>
#include <qapplication.h>
#include <qcursor.h>
#include <qstylefactory.h>
#include <private/qucomextra_p.h>
#if ! (QT_VERSION >= 300)
#error 1
#endif

int main() {
    (void)QStyleFactory::create(QString::null);
    QCursor c(Qt::WhatsThisCursor);
    return 0;
}
configure:29032: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
SamuliSuominen
Retired Dev
Retired Dev


Joined: 30 Sep 2005
Posts: 2133
Location: Finland

PostPosted: Sun May 08, 2011 10:48 am    Post subject: Reply with quote

It's a Qt3/KDE3 app. None of which is in Portage. You can get this into the kde-sunset overlay at most, where rest of the obsolete Qt3/KDE3 stuff is.
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Sun May 08, 2011 10:56 am    Post subject: Reply with quote

ssuominen wrote:
It's a Qt3/KDE3 app. None of which is in Portage. You can get this into the kde-sunset overlay at most, where rest of the obsolete Qt3/KDE3 stuff is.


Too bad :cry:

Thank you ssuominen !
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Mon May 09, 2011 6:29 pm    Post subject: Reply with quote

Kollin wrote:
...
Too bad :cry:
...

Today, while surfing, I came across to a software called Ginkgo CADx and then just remembered your post I read here a few days ago. Although, it is not in portage, you can create an ebuild. It seems to be an active project latest version is 2.4.1.0 from (2011-04-29).
From their web site:
Quote:

a multi-platform Open Source Medical Imaging software which provides a complete DICOM Viewer solution with advanced capabilities and extensions support.

Maybe it works for you.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Mon May 09, 2011 7:30 pm    Post subject: Reply with quote

keenblade wrote:
Kollin wrote:
...
Too bad :cry:
...

Today, while surfing, I came across to a software called Ginkgo CADx and then just remembered your post I read here a few days ago. Although, it is not in portage, you can create an ebuild. It seems to be an active project latest version is 2.4.1.0 from (2011-04-29).
From their web site:
Quote:

a multi-platform Open Source Medical Imaging software which provides a complete DICOM Viewer solution with advanced capabilities and extensions support.

Maybe it works for you.


Thank you keenblade for you concern!
It looks really interesting. The ginkgo deps (from the website http://ginkgo-cadx.com/en/download/ ) are :

Quote:
libstdc++ = 6, Xorg = 7.4, Cairo 1.8, GTK = 2.14, OpenSSL = 0.9.8 and OpenGL (all these libraries are installed by default on Ubuntu = 8.x).


I downloaded the tgz file and tried to start the binary, it complains also for:

Quote:

libpng12.so.0
libjpeg.so.62


I created simlinks for those and libssl but still it complains ( libpng seems to be the real culprit here):
Quote:
./ginkgo-x86_64: /usr/lib64/libpng12.so.0: version `PNG12_0' not found (required by ./libwx_gtk2u-2.8.so.0)


Yes i`m running testing and those libs versions are old, almost on the verge to be ditchet from portage :(
I really don't know how to write an build for that :?
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Mon May 09, 2011 7:42 pm    Post subject: Reply with quote

I wrote to kradvioew's developer and here is the answer:

Quote:
Hello!

At this time I am still using KDE3, and KDE4 is not lightweight enough
and uses too much memory to work on my computer, so I am waiting to KDE4
fixes it, then I change to new version and migrate kradivew.

Yours:

David


So there is still hope...
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Tue May 10, 2011 2:08 am    Post subject: Reply with quote

I created an ebuild for ginkgocadx. Since its dependency sci-libs/vtk could not emerge for me, ginkgocadx ebuild fails, too.
If system sci-libs/vtk fails to emerge for you, too, you can try to use the one that comes with ginkgocadx.
You have to tinker with cmake for it. I hope that works for you.
media-gfx/ginkgocadx-2.4.1.1.ebuild
Code:

# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI="2"

WX_GTK_VER="2.8"

inherit cmake-utils eutils wxwidgets

DESCRIPTION="multi-platform Open Source Medical Imaging Software which provides a complete DICOM Viewer solution"
HOMEPAGE="http://ginkgo-cadx.com"
SRC_URI="mirror://sourceforge/${PN}/2.4.1.0/${P}.tgz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]
   virtual/libstdc++
   dev-libs/openssl
   sci-libs/vtk
   x11-libs/cairo
   x11-libs/libXt
   x11-libs/libX11
   dev-libs/libxml2
   =sci-libs/dcmtk-3.6.0
   sci-libs/itk"
RDEPEND="${DEPEND}"

src_compile() {
   cmake-utils_src_make
}

src_install() {
   cmake-utils_src_install
}



The Change Logs

  • dev-util/cableswig at b.g.o is needed for sci-libs/itk. Lets see, it is compiling now. DONE.
  • sci-libs/itk is compiling (needed "review shared" useflags). DONE
  • Another dep sci-libs/dcmtk needed from science overlay. This provides the DICOM image file libs..
    I renamed ebuild to dcmtk-3.6.1_pre20110225.ebuild. Compiling... DONE.
  • Finally, ginkgocadx started to compile.... Nope.
  • It seems dcmtk-3.6.0 is the way to go. DONE.
  • ginkgocadx still fails something with sci-libs/itk ?

_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"


Last edited by keenblade on Wed May 11, 2011 12:15 pm; edited 5 times in total
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Tue May 10, 2011 8:41 pm    Post subject: Reply with quote

Thank you keenblade!
I think we are close.

Now media-gfx/ginkgocadx fails with:
Quote:


>>> Emerging (3 of 3) media-gfx/ginkgocadx-2.4.1.1 from repo_name-seti
* ginkgocadx-2.4.1.1.tgz RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* Package: media-gfx/ginkgocadx-2.4.1.1
* Repository: repo_name-seti
* USE: amd64 elibc_glibc kernel_linux multilib userland_GNU
* FEATURES: ccache preserve-libs sandbox
>>> Unpacking source...
>>> Unpacking ginkgocadx-2.4.1.1.tgz to /var/tmp/portage/media-gfx/ginkgocadx-2.4.1.1/work
>>> Source unpacked in /var/tmp/portage/media-gfx/ginkgocadx-2.4.1.1/work
>>> Preparing source in /var/tmp/portage/media-gfx/ginkgocadx-2.4.1.1/work/ginkgocadx-2.4.1.1 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/media-gfx/ginkgocadx-2.4.1.1/work/ginkgocadx-2.4.1.1 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/media-gfx/ginkgocadx-2.4.1.1/work/ginkgocadx-2.4.1.1_build"
cmake --no-warn-unused-cli -C /var/tmp/portage/media-gfx/ginkgocadx-2.4.1.1/temp/gentoo_common_config.cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_INSTALL_DO_STRIP=OFF -DCMAKE_USER_MAKE_RULES_OVERRIDE=/var/tmp/portage/media-gfx/ginkgocadx-2.4.1.1/temp/gentoo_rules.cmake /var/tmp/portage/media-gfx/ginkgocadx-2.4.1.1/work/ginkgocadx-2.4.1.1
Not searching for unused variables given on the command line.
loading initial cache file /var/tmp/portage/media-gfx/ginkgocadx-2.4.1.1/temp/gentoo_common_config.cmake
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- <<< Gentoo configuration >>>
Build type Gentoo
Install path /usr
Compiler flags:
C -march=athlon64-sse3 -O2 -pipe -fomit-frame-pointer -ftree-vectorize -ftree-loop-linear
C++ -march=athlon64-sse3 -O2 -pipe -fomit-frame-pointer -ftree-vectorize -ftree-loop-linear -fvisibility-inlines-hidden
Linker flags:
Executable -Wl,-O1 -Wl,--as-needed -Wl,--enable-new-dtags
Module -Wl,-O1 -Wl,--as-needed -Wl,--enable-new-dtags
Shared -Wl,-O1 -Wl,--as-needed -Wl,--enable-new-dtags

-- Found Freetype: /usr/lib64/libfreetype.so
-- Found GTK2_GTK: /usr/lib64/libgtk-x11-2.0.so
Using system wxWidgets
-- Found wxWidgets: TRUE (Required is at least version "2.8.11")
Using system VTK
Using system ITK
CMake Error at /usr/share/cmake/Modules/FindITK.cmake:52 (MESSAGE):
Please set ITK_DIR to the directory containing ITKConfig.cmake. This is
either the root of the build tree, or PREFIX/lib/InsightToolkit for an
installation.
Call Stack (most recent call first):
src/CMakeLists.txt:63 (FIND_PACKAGE)


_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Tue May 10, 2011 9:42 pm    Post subject: Reply with quote

Kollin wrote:

I think we are close.

Now media-gfx/ginkgocadx fails with:
Quote:

Using system ITK
CMake Error at /usr/share/cmake/Modules/FindITK.cmake:52 (MESSAGE):
Please set ITK_DIR to the directory containing ITKConfig.cmake. This is
either the root of the build tree, or PREFIX/lib/InsightToolkit for an
installation.
Call Stack (most recent call first):
src/CMakeLists.txt:63 (FIND_PACKAGE)


We need InsightToolkit lib, and fortunately there is an ebuild for sci-libs/itk. at b.g.o with some patches.
I'd try renaming the itk ebuild latest version like: sci-libs/itk-3.20.0.ebuild , without patches and see if it compile.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Wed May 11, 2011 12:12 pm    Post subject: Reply with quote

ginkgocadx-2.4.1.1.ebuild fails with this error:
Code:

Linking CXX shared library libCADxCore.so
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKAlgorithms
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKStatistics
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKFEM
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKNumerics
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -litkNetlibSlatec
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKBasicFilters
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKIO
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKNrrdIO
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -litkgdcm
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -litkjpeg8
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -litkjpeg12
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -litkjpeg16
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -litkopenjpeg
collect2: ld returned 1 exit status
make[2]: *** [src/cadxcore/libCADxCore.so.2.4.1.1] Error 1
make[1]: *** [src/cadxcore/CMakeFiles/CADxCore.dir/all] Error 2
make: *** [all] Error 2
emake failed

InsightToolkit-3.2.0 is installed and patched with ITK-3.20.0-patch.diff.
Any idea?
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Wed May 11, 2011 3:35 pm    Post subject: Reply with quote

keenblade wrote:
ginkgocadx-2.4.1.1.ebuild fails with this error:
Code:

Linking CXX shared library libCADxCore.so
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKAlgorithms
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKStatistics
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKFEM
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKNumerics
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -litkNetlibSlatec
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKBasicFilters
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKIO
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lITKNrrdIO
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -litkgdcm
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -litkjpeg8
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -litkjpeg12
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -litkjpeg16
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -litkopenjpeg
collect2: ld returned 1 exit status
make[2]: *** [src/cadxcore/libCADxCore.so.2.4.1.1] Error 1
make[1]: *** [src/cadxcore/CMakeFiles/CADxCore.dir/all] Error 2
make: *** [all] Error 2
emake failed

InsightToolkit-3.2.0 is installed and patched with ITK-3.20.0-patch.diff.
Any idea?


Thank you keenblade, you are very kind and helpful but sadly I went out of ideas few posts ago. :roll:
May be someone else will be able to continue further your work :(
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
redwood
Apprentice
Apprentice


Joined: 27 Jan 2006
Posts: 286

PostPosted: Tue Aug 23, 2011 2:16 pm    Post subject: Gingko-CADx-2.5.2.0 Reply with quote

I didn't try your ebuild to build from source, but I did try out the binary:
Ginkgo_CADx-2.5.2.0_linux_x86 (which the site said worked with Ubuntu)

I simply unpacked the tarball to /opt/gingko.
The package unpacked 131 library files into the same folder, along with
the executables ginkgocadx and ginkgocadx-x86

I used Gingko-CADx for viewing MRI DICOM images of
my nephew's knee and torn ACL ligament. I did not configure
the local AET on port 11112 for communicating with a PACS server as I simply
wanted to view/print some of the images for myself and my sister. That said,
the program worked just fine for me on my Gentoo x86 system.

I also installed sci-libs/dcmtk from the science overlay,
after googling for how to read/convert DICOM images:
http://fixunix.com/dicom/49926-commandline-dicom-jpeg-convertion-tool.html

I planned to convert the images to either jpg or jpeg2000:

Code:

DCM -> JPG
dcmj2pnm -d -v -im +oj +Jq 90 +Wi 1 foo.dcm foo.jpg

1.- DCM -> PGM / PPM
dcmj2pnm -d -v -im +op +Wi 1 foo.dcm foo.pgm

2.- PGM -> JPEG2000
jasper --input-format pnm --input foo.pgm --output-format jp2 --output foo.jp2 -O rate=0.1


I haven't tried out this commandline toolkit yet as the Gingko-CADx gui worked like a charm.
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Tue Aug 23, 2011 8:10 pm    Post subject: Reply with quote

That's wonderful, redwood! Thank you for this information :wink:
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum