Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[CONFIG] ATI Radeon HD 6850 sous Gentoo [resolu]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
drdivx
n00b
n00b


Joined: 09 May 2011
Posts: 15

PostPosted: Tue May 10, 2011 8:31 am    Post subject: [CONFIG] ATI Radeon HD 6850 sous Gentoo [resolu] Reply with quote

Bonjour,
Je viens de terminer ma compilation de mon Gentoo, qui fonctionne plutôt pas mal.
Mais j'ai un petit soucis pour configurer ma carte graphique ATI Radeon HD 6850.
J'ai essayé plusieurs wiki dont celui de Gentoo Quebec avec le KMS.
J'ai aussi essayé le wiki officiel de Gentoo.
J'ai même essayé les pilote propriétaire.
Mais rien n'y fait, cela ne fonctionne pas.
Je n'arrive que sur mon Gnome avec la configuration 'vesa' mais c'est pas top car je n'ai pas ma résolution Full HD.
Voici ce que j'ai quand je met 'radeon' :
gentoo ~ # cat /etc/X11/xorg.conf
Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "radeon"
VendorName "Unknown"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

gentoo ~ # startx
hostname: Hôte inconnu
xauth: file /root/.serverauth.20983 does not exist


X.Org X Server 1.9.5
Release Date: 2011-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.37-gentoo-r4 x86_64 Gentoo
Current Operating System: Linux gentoo 2.6.37-gentoo-r4 #3 SMP Mon May 9 22:44:20 CEST 2011 x86_64
Kernel command line: root=/dev/sda7
Build Date: 10 May 2011 09:08:37AM

Current version of pixman: 0.20.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue May 10 10:02:46 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
dlopen: libdrm_radeon.so.1: cannot open shared object file: No such file or directory
(EE) Failed to load /usr/lib64/xorg/modules/drivers/radeon_drv.so
(EE) Failed to load module "radeon" (loader failed, 7)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Voici ce que j'ai quand je met 'fglrx' :
gentoo ~ # cat /etc/X11/xorg.conf
Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "fglrx"
VendorName "Unknown"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection
gentoo ~ # startx
hostname: Hôte inconnu
xauth: file /root/.serverauth.21086 does not exist


X.Org X Server 1.9.5
Release Date: 2011-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.37-gentoo-r4 x86_64 Gentoo
Current Operating System: Linux gentoo 2.6.37-gentoo-r4 #3 SMP Mon May 9 22:44:20 CEST 2011 x86_64
Kernel command line: root=/dev/sda7
Build Date: 10 May 2011 09:08:37AM

Current version of pixman: 0.20.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue May 10 10:27:32 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:0:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:2:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:10:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:5) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
FATAL: Error inserting fglrx (/lib/modules/2.6.37-gentoo-r4/kernel/drivers/char/drm/fglrx.ko): Invalid module format
(EE) fglrx(0): ACPI: DRM connection failed
(EE) fglrx(0): ACPI: DRM connection failed
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(EE) fglrx(0): XMM failed to open CMMQS connection.(EE) fglrx(0):
(EE) fglrx(0): XMM failed to initialize

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x3e) [0x7f8d8d520ece]
1: /usr/bin/X (0x7f8d8d459000+0x82e0e) [0x7f8d8d4dbe0e]
2: /lib64/libpthread.so.0 (0x7f8d8c77d000+0xf120) [0x7f8d8c78c120]
3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_x760_swlDriOpenConnection+0x3a) [0x7f8d89121daa]
4: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (swlDriOpenConnection+0xd) [0x7f8d8904e20d]
5: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f8d8a3cb000+0x1bd74) [0x7f8d8a3e6d74]
6: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f8d8a3cb000+0x1e075) [0x7f8d8a3e9075]
7: /usr/bin/X (InitExtensions+0x92) [0x7f8d8d504382]
8: /usr/bin/X (0x7f8d8d459000+0x3b5c0) [0x7f8d8d4945c0]
9: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f8d8b6f5bfd]
10: /usr/bin/X (0x7f8d8d459000+0x3b2d9) [0x7f8d8d4942d9]
Segmentation fault at address 0xa0

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

(EE) fglrx(0): firegl_SetSuspendResumeState FAILED -9.
^Cxinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: unexpected signal 2

Franchement cela fait deux jours que je suis dessus et je vais surement repasser à un Debian, même si sous Gentoo mon système est plus stable et rapide.
C'est pour cela que je vous demande si vous n'avez pas une idée, s'il vous plait.
Merci d'avance.
Cordialement.


Last edited by drdivx on Thu May 12, 2011 7:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3087
Location: Paris

PostPosted: Tue May 10, 2011 3:48 pm    Post subject: Reply with quote

...
Repasse sous debian si tu le souhaites et si tu penses que cela te convient mieux... ces "menaces" ne nous fera pas intervenir plus vite ni mieux sur ton problème...
C'est toujours un plaisir de voir ce genre de postes-ultimatum :/

Sinon, à tout hasard, tu ne t'es pas demandé si les drivers supportait ta carte, avant d'essayer un peu tout?
Par exemple, le driver libre radeon, c'est sûr, c'est non.
Pour fglrx, renseigne toi si la combinaison Xorg/Kernel est supportée par la version de fglrx que tu utilises.

--
edit: ahem, désolé, ça sonne un peu "rugueux" comme ton... bon, j'ai oublié qu'on était plus lundi ;)
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
drdivx
n00b
n00b


Joined: 09 May 2011
Posts: 15

PostPosted: Tue May 10, 2011 4:07 pm    Post subject: Reply with quote

Hola,
Bonsoir, d'abord et j’espère que vous avez passé une bonne journée.
Je ne voulais pas du tout faire un ultimatum.
Je disais cela car je suis plus habituer au variante Debian comme ubuntu.
Vous avez mal compris mon ton, qui est un ton de désespoir.
J'aime gentoo et le faite qu'il est compiler pour et par ma machine et donc plus stable et rapide.
Je ne veux pas le quitter.
Je veux juste faire fonctionner mon accélération graphique pour avoir du full HD.
Je suis désolé de vous avoir froissé, je me suis sûrement mal exprimer.
Mais auriez vous une idée pour flgrx.
Merci d'avance.
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue May 10, 2011 4:07 pm    Post subject: Reply with quote

El_Goretto wrote:

edit: ahem, désolé, ça sonne un peu "rugueux" comme ton... bon, j'ai oublié qu'on était plus lundi ;)

En même temps sur le forum debian, t'arrives tu sort que "ça marche pas, je vais repasser à une autre truc"... le ton serais le même voir pire et pour seul soluce un tonitruant "rtfm!" :lol:

Sinon passes nous ton make.conf (je voudrais voir les USE et le VIDEO_CARDS). Sinon kms et fglrx ça va pas trop ensemble, si tant est que as les deux ensemble.
Back to top
View user's profile Send private message
drdivx
n00b
n00b


Joined: 09 May 2011
Posts: 15

PostPosted: Tue May 10, 2011 4:11 pm    Post subject: Reply with quote

Oui je m'en excuse encore.
Je me suis mal exprimer.
C'est juste que sur ubuntu il y a un gestionnaire de pilote propriétaire qui configure et installe ta carte.
Aussi non voici mon make :
gentoo ~ # cat /etc/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=k8 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="video_cards_radeon gnome gtk -kde nls -qt3 -qt3support -qt4 truetype unicode userlocales dvd alsa cdr sqlite static-libs X dbus hal"
MAKEOPTS="-j5"

GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"

SYNC="rsync://rsync2.fr.gentoo.org/gentoo-portage"

VIDEO_CARDS="r600"
INPUT_DEVICES="keyboard mouse evdev"
LINGUAS="fr fr_FR"
gentoo ~ # cat /etc/conf.d/modules
modules_2_6="radeon"
module_radeon_args="modeset=1"


PS : Merci encore de bien vouloir m'aider.
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue May 10, 2011 4:16 pm    Post subject: Reply with quote

ouais ton VIDEO_CARDS est mauvais.

Fais un eix xorg-drivers
tu vas avoir une liste possible (sachant qu'il faut vire le video_cards_ devant). USE="video_cards_radeon" c'est pas bon (même si ça l'applique surement)

un VIDEO_CARDS="radeon fglrx" ça serait déjà mieux je pense. Fais un emerge -DuN world ensuite.

Re-testes et dis nous ce qui va pas.
Back to top
View user's profile Send private message
drdivx
n00b
n00b


Joined: 09 May 2011
Posts: 15

PostPosted: Tue May 10, 2011 4:37 pm    Post subject: Reply with quote

Je suis désolé mais cela ne fonctionne pas.
gentoo ~ # startx
hostname: Hôte inconnu
xauth: file /root/.serverauth.5008 does not exist


X.Org X Server 1.9.5
Release Date: 2011-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.37-gentoo-r4 x86_64 Gentoo
Current Operating System: Linux gentoo 2.6.37-gentoo-r4 #3 SMP Mon May 9 22:44:2 0 CEST 2011 x86_64
Kernel command line: root=/dev/sda7
Build Date: 10 May 2011 09:08:37AM

Current version of pixman: 0.20.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue May 10 18:34:47 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load module "dri" (module does not exist, 0)
(EE) Failed to load module "dri2" (module does not exist, 0)
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:0:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:2:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:10:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:5) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
FATAL: Error inserting fglrx (/lib/modules/2.6.37-gentoo-r4/kernel/drivers/char/ drm/fglrx.ko): Invalid module format
(EE) fglrx(0): ACPI: DRM connection failed
(EE) fglrx(0): ACPI: DRM connection failed
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(EE) fglrx(0): XMM failed to open CMMQS connection.(EE) fglrx(0):
(EE) fglrx(0): XMM failed to initialize

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x3e) [0x7f71615e0ece]
1: /usr/bin/X (0x7f7161519000+0x82e0e) [0x7f716159be0e]
2: /lib64/libpthread.so.0 (0x7f716083d000+0xf120) [0x7f716084c120]
3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_x760_swlDriOpenConnection+0 x3a) [0x7f715d802daa]
4: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (swlDriOpenConnection+0xd) [0x7f 715d72f20d]
5: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f715e48b000+0x1bd74) [0x7f71 5e4a6d74]
6: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f715e48b000+0x1e075) [0x7f71 5e4a9075]
7: /usr/bin/X (InitExtensions+0x92) [0x7f71615c4382]
8: /usr/bin/X (0x7f7161519000+0x3b5c0) [0x7f71615545c0]
9: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f715f7b5bfd]
10: /usr/bin/X (0x7f7161519000+0x3b2d9) [0x7f71615542d9]
Segmentation fault at address 0xa0

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional informati on.

(EE) fglrx(0): firegl_SetSuspendResumeState FAILED -9.
^Cxinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: unexpected signal 2
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue May 10, 2011 5:15 pm    Post subject: Reply with quote

et après un eselect opengl set ati ?
Back to top
View user's profile Send private message
drdivx
n00b
n00b


Joined: 09 May 2011
Posts: 15

PostPosted: Tue May 10, 2011 5:26 pm    Post subject: Reply with quote

Il est deja a ati :
gentoo ~ # eselect opengl list
Available OpenGL implementations:
[1] ati *
[2] xorg-x11
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue May 10, 2011 6:17 pm    Post subject: Reply with quote

Code:
FATAL: Error inserting fglrx (/lib/modules/2.6.37-gentoo-r4/kernel/drivers/char/ drm/fglrx.ko): Invalid module format

En console, quand tu fais modprobe fglrx, ça donne quoi? ça doit déconner et c'est pas normal, tu pourrais refaire un emerge x11-drivers/ati-drivers ?

Quelle version des x11-drivers/ati-drivers? Apparemment le support des séries 6xxx est pas si vieux (version 11.3)

Tiens et d'ailleurs, t'as cherchés sur ce forum? Je trouve un résultat intéressant (pour la suite, parce que là ton module se charge pas): https://forums.gentoo.org/viewtopic-t-861431-highlight-fglrx+6850.html
Back to top
View user's profile Send private message
drdivx
n00b
n00b


Joined: 09 May 2011
Posts: 15

PostPosted: Tue May 10, 2011 6:24 pm    Post subject: Reply with quote

j'ai ceci :
gentoo ~ # modprobe fglrx
FATAL: Error inserting fglrx (/lib/modules/2.6.37-gentoo-r4/kernel/drivers/char/drm/fglrx.ko): Invalid module format

J'utilise la version 11.3
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3087
Location: Paris

PostPosted: Tue May 10, 2011 6:26 pm    Post subject: Reply with quote

D'où ma question à l'origine, est ce qu'il support un 2.6.37?
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
drdivx
n00b
n00b


Joined: 09 May 2011
Posts: 15

PostPosted: Tue May 10, 2011 6:27 pm    Post subject: Reply with quote

Ok si je comprend bien il faudrait que je change de version de noyau.
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue May 10, 2011 6:29 pm    Post subject: Reply with quote

El_Goretto wrote:
D'où ma question à l'origine, est ce qu'il support un 2.6.37?

Quote:
kernel_is ge 2 6 37 && if ! linux_chkconfig_present BKL ; then
trouvé ça dans l'ebuild, donc apparemment oui.

Tiens testes voir avec la dernière version 11.4/11.5? (echo x11-drivers/ati-drivers >> /etc/portage/package.keywords et rulez)

[edit] tiens d'ailleurs bien moche ça, le support bkl ... ^^ [/edit]
Back to top
View user's profile Send private message
drdivx
n00b
n00b


Joined: 09 May 2011
Posts: 15

PostPosted: Tue May 10, 2011 6:52 pm    Post subject: Reply with quote

Voici ce que ca donne quand je met radeon :
hostname: Hôte inconnu
xauth: file /root/.serverauth.19626 does not exist


X.Org X Server 1.9.5
Release Date: 2011-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.37-gentoo-r4 x86_64 Gentoo
Current Operating System: Linux gentoo 2.6.37-gentoo-r4 #3 SMP Mon May 9 22:44:20 CEST 2011 x86_64
Kernel command line: root=/dev/sda7
Build Date: 10 May 2011 09:08:37AM

Current version of pixman: 0.20.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue May 10 20:49:32 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load module "dri" (module does not exist, 0)
(EE) Failed to load module "dri2" (module does not exist, 0)
(II) [KMS] No DRICreatePCIBusID symbol, no kernel modesetting.
(EE) RADEON(0): Chipset: "AMD Radeon HD 6800 Series" (ChipID = 0x6739) requires KMS
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

^Cxinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: unexpected signal 2

Voici ce que ca donne quand je met fglrx :
hostname: Hôte inconnu
xauth: file /root/.serverauth.19662 does not exist


X.Org X Server 1.9.5
Release Date: 2011-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.37-gentoo-r4 x86_64 Gentoo
Current Operating System: Linux gentoo 2.6.37-gentoo-r4 #3 SMP Mon May 9 22:44:20 CEST 2011 x86_64
Kernel command line: root=/dev/sda7
Build Date: 10 May 2011 09:08:37AM

Current version of pixman: 0.20.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue May 10 20:50:07 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load module "dri" (module does not exist, 0)
(EE) Failed to load module "dri2" (module does not exist, 0)
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:0:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:2:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:10:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:5) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
FATAL: Error inserting fglrx (/lib/modules/2.6.37-gentoo-r4/video/fglrx.ko): Invalid module format
(EE) fglrx(0): ACPI: DRM connection failed
(EE) fglrx(0): ACPI: DRM connection failed
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(EE) fglrx(0): XMM failed to open CMMQS connection.(EE) fglrx(0):
(EE) fglrx(0): XMM failed to initialize

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x3e) [0x7f49f08b2ece]
1: /usr/bin/X (0x7f49f07eb000+0x82e0e) [0x7f49f086de0e]
2: /lib64/libpthread.so.0 (0x7f49efb0f000+0xf120) [0x7f49efb1e120]
3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_x760_swlDriOpenConnection+0x3a) [0x7f49ecad4daa]
4: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (swlDriOpenConnection+0xd) [0x7f49eca0120d]
5: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f49ed75d000+0x1be84) [0x7f49ed778e84]
6: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f49ed75d000+0x1e185) [0x7f49ed77b185]
7: /usr/bin/X (InitExtensions+0x92) [0x7f49f0896382]
8: /usr/bin/X (0x7f49f07eb000+0x3b5c0) [0x7f49f08265c0]
9: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f49eea87bfd]
10: /usr/bin/X (0x7f49f07eb000+0x3b2d9) [0x7f49f08262d9]
Segmentation fault at address 0xa0

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

(EE) fglrx(0): firegl_SetSuspendResumeState FAILED -9
Back to top
View user's profile Send private message
drdivx
n00b
n00b


Joined: 09 May 2011
Posts: 15

PostPosted: Tue May 10, 2011 7:41 pm    Post subject: Reply with quote

Je voudrais savoir si il y a un moyen de dire quand meme a XORG de me mettre met 1920x1080 dans son fichier de config.
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue May 10, 2011 7:54 pm    Post subject: Reply with quote

drdivx wrote:
Je voudrais savoir si il y a un moyen de dire quand meme a XORG de me mettre met 1920x1080 dans son fichier de config.

Avant faudrait que xorg démarre sans problème non? :|

pour fglrx, t'as essayés la version 11.4?
Et sinon pour radeon il en veut pas si kms n'est pas présent.
Back to top
View user's profile Send private message
drdivx
n00b
n00b


Joined: 09 May 2011
Posts: 15

PostPosted: Tue May 10, 2011 8:13 pm    Post subject: Reply with quote

En mode vesa xorg ce lance mais avec une resolution de 1280x1024.
Le mode radeon me dit que KMS n'est pas present et que le module DRI et DRI2 n'ont plus.
Alors que j'ai respecter le tutos pour les activer.
Comment peut on savoir si il le sont vraiment ?
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue May 10, 2011 8:15 pm    Post subject: Reply with quote

drdivx wrote:
En mode vesa xorg ce lance mais avec une resolution de 1280x1024.

Limitation VESA, tu peux pas aller plus haut.

Retravaille sur fglrx, il supporte la 6850. Prends la version 11.4
Back to top
View user's profile Send private message
drdivx
n00b
n00b


Joined: 09 May 2011
Posts: 15

PostPosted: Tue May 10, 2011 8:32 pm    Post subject: Reply with quote

Je l'ai je viens de le faire mais il y a encore des erreur.
Je reviendrais demain dessus.
Je te tiendrais au courant demain car la je vais me coucher.
@+
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue May 10, 2011 8:36 pm    Post subject: Reply with quote

drdivx wrote:
Je te tiendrais au courant demain car la je vais me coucher.

Y a plus de jeunesse!
Back to top
View user's profile Send private message
drdivx
n00b
n00b


Joined: 09 May 2011
Posts: 15

PostPosted: Wed May 11, 2011 5:08 pm    Post subject: Reply with quote

Coucou me revoilà.
Sur un autre forum il m'ont demander ceci http://paste.pocoo.org/show/386999/
C'est un descriptif de mon noyau.
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Wed May 11, 2011 5:58 pm    Post subject: Reply with quote

drdivx wrote:
Sur un autre forum il m'ont demander ceci http://paste.pocoo.org/show/386999/
C'est un descriptif de mon noyau.

Avec CONFIG_DRM_RADEON_KMS=y c'est sûr que fglrx va pas se charger. Ou alors c'est la config noyau pour le radeon uniquement?
Back to top
View user's profile Send private message
drdivx
n00b
n00b


Joined: 09 May 2011
Posts: 15

PostPosted: Wed May 11, 2011 7:36 pm    Post subject: Reply with quote

Bon sang ca fonctionne.
Tu est trop fort merci bien.
J'ai suivi ceci http://en.gentoo-wiki.com/wiki/Fglrx et recompiler mon kernel sans kms c'est parfait.
Comment savoir maintenant si j'ai de l’accélération 3D.
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Thu May 12, 2011 1:34 pm    Post subject: Reply with quote

Ah m'en doutait, je l'avais dis au début :wink:
kwenspc wrote:
.(..)
Sinon kms et fglrx ça va pas trop ensemble, si tant est que as les deux ensemble.


Pour la 3d, un ptit glxinfo et si il te sort un "direct rendering: Yes" au début: c'est bon.
glxinfo est dans le paquet x11-apps/mesa-progs

Un ptit "résolu" en topic sinon?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum