Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDM und PAM: Kein Login mehr möglich
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
xces
Guru
Guru


Joined: 11 Oct 2002
Posts: 515

PostPosted: Mon Nov 05, 2007 7:51 pm    Post subject: KDM und PAM: Kein Login mehr möglich Reply with quote

Hi,
nach irgendeinem der letzten Updates (ich kann es leider nicht mehr eingrenzen) ist ein Login via KDM auf meinem System nicht mehr möglich.

Der entsprechende Logeintrag bei einem Anmeldeversuch in KDM sieht folgendermaßen aus:
Code:
Nov  5 20:36:01 [kdm] :0[22883]: pam_unix(kde:auth): authentication failure; logname= uid=0 euid=0 tty=:0 ruser= rhost=  user=xces


Ein Login auf der Konsole (/bin/login) mit den gleichen Zugangsdaten funktioniert weiterhin:
Code:
Nov  5 20:41:06 [login] pam_tally(login:account): option deny=0 allowed in auth phase only
Nov  5 20:41:06 [login] pam_unix(login:session): session opened for user xces by LOGIN(uid=0)
Nov  5 20:41:06 [login] pam_mount(mount.c:181) realpath of volume "/home/xces" is "/home/xces"_


Wie zu sehen ist, benutze ich pam_mount, um mein via dm-crypt verschlüsseltes Homeverzeichnis einzubinden. Das hat bisher wunderbar geklappt. In /etc/pam.d/system-auth und /etc/pam.d/kde steht folgendes:
/etc/pam.d/system-auth
Code:
#%PAM-1.0

auth       required     pam_env.so
auth       optional     pam_mount.so
auth       sufficient   pam_unix.so likeauth nullok use_first_pass
auth       required     pam_deny.so use_first_pass

account    required     pam_unix.so

# This can be used only if you enabled the cracklib USE flag
password   required     pam_cracklib.so difok=2 minlen=8 dcredit=2 ocredit=2 try_first_pass retry=3
# This can be used only if you enabled the cracklib USE flag
password   sufficient   pam_unix.so try_first_pass use_authtok nullok md5 shadow
# This can be used only if you enabled the !cracklib USE flag
# password   sufficient pam_unix.so try_first_pass nullok md5 shadow
password   required     pam_deny.so

session    required     pam_limits.so
session    required     pam_unix.so
session    optional     pam_mount.so

/etc/pam.d/kde
Code:
#%PAM-1.0

auth       required     pam_nologin.so
auth       include      system-auth

account    include      system-auth

password   include      system-auth

session    include      system-auth

Die Dateien wurden mit dem letzten Update allerdings nicht verändert. Ich weiß so langsam leider nicht mehr, wo ich noch ansetzen könnte, um das Problem zu beheben. Hat vielleicht einer der Anwesenden mit erweiterten PAM-Kenntnissen noch eine Idee?
Back to top
View user's profile Send private message
tuxianer
Apprentice
Apprentice


Joined: 17 Dec 2005
Posts: 280
Location: Cologne - Germany

PostPosted: Tue Nov 06, 2007 7:05 am    Post subject: Reply with quote

Hi,

das sieht ganz nach einem Update von PAM aus, diesen Fehler hatte ich auch, hast du den Rechner schon mal neugestartet ?! Solltest du das bereits gemacht haben, dann mach ein downgrade auf Version 0.78-r5 damit sollte das auf jeden Fall wieder klappen sonst : http://www.gentoo.org/proj/en/base/pam/upgrade-0.99.xml
_________________
Bei Fragen bitte wie folgt vor gehen:
Forum Suche, Lesen, Denken, (NICHTS GEFUNDEN?), Tippen, Posten !
Wer Sorgen hat, der hat auch Likör ! ( Wilhelm Busch)
Back to top
View user's profile Send private message
a.forlorn
Guru
Guru


Joined: 12 Aug 2005
Posts: 412
Location: Ulm, Germany

PostPosted: Tue Nov 06, 2007 9:14 am    Post subject: Reply with quote

Oder wenn Du es nicht brauchst, dann -pam in /etc/make.conf eintragen, emerge -C pam, emerge -uDN world. Um einen Neustart kommt man nicht herum.
_________________
Gentoo update is sometimes harder than it should.
Back to top
View user's profile Send private message
schachti
Advocate
Advocate


Joined: 28 Jul 2003
Posts: 3765
Location: Gifhorn, Germany

PostPosted: Tue Nov 06, 2007 9:33 am    Post subject: Reply with quote

a.forlorn wrote:
Oder wenn Du es nicht brauchst, dann -pam in /etc/make.conf eintragen, emerge -C pam, emerge -uDN world. Um einen Neustart kommt man nicht herum.


Das wird er sicher nicht wollen:

xces wrote:

Wie zu sehen ist, benutze ich pam_mount, um mein via dm-crypt verschlüsseltes Homeverzeichnis einzubinden.

_________________
Never argue with an idiot. He brings you down to his level, then beats you with experience.

How-To: Daten verschlüsselt auf DVD speichern.
Back to top
View user's profile Send private message
xces
Guru
Guru


Joined: 11 Oct 2002
Posts: 515

PostPosted: Tue Nov 06, 2007 3:06 pm    Post subject: Reply with quote

tuxianer wrote:
das sieht ganz nach einem Update von PAM aus, diesen Fehler hatte ich auch, hast du den Rechner schon mal neugestartet ?!

Ja, der Rechner wurde schon neugestartet. Auch alte Abhängigkeiten auf PAM bestehen nicht mehr (sagt zumindest revdep-rebuild). Davon abgesehen hat es mit PAM 0.99.8.1-r1 noch geklappt, mit PAM 0.99.9.0 nicht mehr. Allerdings hat ein Downgrade da nichts gebracht. :?

Ich kann mir auch nicht vorstellen, dass es ein generelles Problem mit PAM ist, da sonst auch der Anmeldevorgang mit login(1) betroffen wäre und nicht nur KDM.

a.forlorn wrote:
Oder wenn Du es nicht brauchst, dann -pam in /etc/make.conf eintragen, emerge -C pam, emerge -uDN world. Um einen Neustart kommt man nicht herum.

Generell auf PAM verzichten wollte ich eigentlich nicht, da es doch ab und an sehr nützlich ist. ;)
Back to top
View user's profile Send private message
tuxianer
Apprentice
Apprentice


Joined: 17 Dec 2005
Posts: 280
Location: Cologne - Germany

PostPosted: Tue Nov 06, 2007 9:24 pm    Post subject: Reply with quote

Dann bau einmal kdm neu, oder solltest du keine split ebuilds verwenden , dann kdebase. Kann sein das die Abhängigkeit neu rein muss.
_________________
Bei Fragen bitte wie folgt vor gehen:
Forum Suche, Lesen, Denken, (NICHTS GEFUNDEN?), Tippen, Posten !
Wer Sorgen hat, der hat auch Likör ! ( Wilhelm Busch)
Back to top
View user's profile Send private message
xces
Guru
Guru


Joined: 11 Oct 2002
Posts: 515

PostPosted: Tue Nov 06, 2007 9:35 pm    Post subject: Reply with quote

tuxianer wrote:
Dann bau einmal kdm neu, oder solltest du keine split ebuilds verwenden , dann kdebase. Kann sein das die Abhängigkeit neu rein muss.

Das war auch meine erste Idee. Hat leider nicht funktioniert und wie geschrieben meckert revdep-rebuild bzw. ldd auch nicht herum.
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1627
Location: Schweiz

PostPosted: Fri May 13, 2011 2:04 pm    Post subject: Reply with quote

Hallo,

ich habe das selbe Problem nur mit lxdm anstelle von kdm.
Code:
lxdm-binary: pam_unix(lxdm:auth): authentication failure; logname=root uid=0 euid=0 tty= ruser= rhost=  user=schmidicom

"pam_unix.so" scheint nicht mehr zu funktionieren dabei habe ich sowohl das Paket in dem es enthalten ist als auch jede Abhängigkeit neu installiert.

Kann mir bitte jemand weiterhelfen?
So wie es jetzt ist kann ich ein grafisches Login komplett vergessen.

EDIT:
Vergesst es....
Nach dem update hat emerge wohl mal wieder die verdammte Tastatureinstellung komplett versaut und natürlich weiss ich nicht mehr was ich beim letzten mal für ein "XkbModel" angegeben hatte. :evil:


Last edited by schmidicom on Fri May 13, 2011 2:37 pm; edited 2 times in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3855
Location: Germany

PostPosted: Fri May 13, 2011 2:13 pm    Post subject: Reply with quote

Hmm, nur ein Schuss ins Blaue
gibt es eventuell noch configs die aktualisiert werden müssen - sprich etc-update ?
Klappt noch startx ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum