Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] seit KDE 4.6 schläft mein Laptop 2 mal ein
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
schmutzfinger
Veteran
Veteran


Joined: 26 Oct 2003
Posts: 1287
Location: Dresden/Germany

PostPosted: Thu May 12, 2011 9:27 pm    Post subject: [solved] seit KDE 4.6 schläft mein Laptop 2 mal ein Reply with quote

Ich habe suspend und hibernate über acpid eingerichtet und an die entsprechenden ACPI events von den Spezialtasten gebunden. Seit dem Update auf kde 4.6 sieht KDE anscheinend auch, wenn ich einen dieser Knöpfe drücke und lässt den Rechner einschlafen.
Aber das macht es erst, nachdem der Rechner aus dem Ruhezustand vom acpid wieder aufwacht. Ich drücke die Taste und der Rechner schläft normal ein. Nach dem Aufwachen schläft er dann sofort ein zweites Mal ein.

Ich habe jetzt eine Weile gesucht. Zuerst in den KDE Systemeinstellungen, dann in den configs von consolekit und upower. Ich weiss nicht, wo das eingestellt ist aber vermutlich schickt KDE eine Nachricht über dbus. Und upower und oder consolekit spielen da auch noch mit rein.

Ich will weiterhin acpid für hibernate und suspend benutzen. KDE soll die Tasten einfach ignorieren. Ich will KDE aber nicht generell verbieten die dbus/upower/wasauchimmer Magie zu machen, damit die Suspend/Hibernate Knöpfe im KDE-Menu noch gehen und powerdevil meinen Rechner noch vor nem leeren Akku retten kann.

Also hier die Frage: Wie bringe ich KDE bei die Tasten zu ignorieren? In den Energieprofilen von powerdevil finde ich unter Knopf-Ereignisbehandlung nur den Laptop-Deckel.


Last edited by schmutzfinger on Fri May 13, 2011 7:08 am; edited 1 time in total
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Thu May 12, 2011 9:35 pm    Post subject: Reply with quote

Tastenkürzel evtl.?
systemsettings ---> Kurzbefehle ---> globale Tastenkürzel ---> KDE-Dienst
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Fri May 13, 2011 5:02 am    Post subject: Reply with quote

Ja da hat sich ab kde-4.6 einiges geändert, nun erkennt KDE selbst die events von den sleep Tasten. (was idR auch gut funktioniert)
Siehe hierzu zb auch den Hinweis
Quote:
Double-hibernate or crashes after hibernate (bug 363363)

KDE 4.6 handles "sleep button" events on its own, and the system correctly hibernates. If you have manually set up any other programs to handle these events (e.g. acpid), please disable that, as you may otherwise get double hibernation and/or system instability.
aus dem KDE 4.4 - 4.6 Upgrade Guide
Wie man dieses neue Feature jedoch wieder deaktivieren kann (wenn man es nicht möchte) weiss ich zZt auch nicht...
Back to top
View user's profile Send private message
schmutzfinger
Veteran
Veteran


Joined: 26 Oct 2003
Posts: 1287
Location: Dresden/Germany

PostPosted: Fri May 13, 2011 7:08 am    Post subject: Reply with quote

Max Steel wrote:
Tastenkürzel evtl.?
systemsettings ---> Kurzbefehle ---> globale Tastenkürzel ---> KDE-Dienst


Genau da hatte ich das auch vermutet aber nicht selber gefunden. Danke! Wenn ich den beiden Aktionen einfach keine Taste zuweise geht es wie früher.

Oha da steht das also im Upgrade-Guide. Den hatte ich beim Suchen nach dem Problem nicht gefunden. Aber jetzt ist immerhin auch klar, wie man das im KDE abschaltet.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3687
Location: Hamburg

PostPosted: Sun May 15, 2011 10:16 am    Post subject: Reply with quote

Josef.95 wrote:
Wie man dieses neue Feature jedoch wieder deaktivieren kann (wenn man es nicht möchte) weiss ich zZt auch nicht...
Wenn man den ACPI event z.B. für die Power-Taste schon selbst programmiert hat, dann hilft dies her : System Settings -> Custom Shortcuts -> Global Keyboard Shortcuts
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum