Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Merkwürdiges Verhalten des X-Maustreibers
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
TheSmallOne
Guru
Guru


Joined: 22 Jan 2005
Posts: 461
Location: Germany

PostPosted: Thu May 12, 2011 9:37 pm    Post subject: Merkwürdiges Verhalten des X-Maustreibers Reply with quote

Hallo, mir ist heute etwas merkwürdiges in meinem Xorg.0.log aufgefallen.
Und zwar geht es um folgende Zeilen:
Code:
(WW) Hauptmaus: No Device specified, looking for one...
(II) Hauptmaus: Setting Device option to "/dev/input/mice"
(--) Hauptmaus: Device: "/dev/input/mice"

Der Treiber behaupted also er hätte keinen Wert für das Device gefunden und verwendet deshalb /dev/input/mice.

Aber in der /etc/X11/xorg.conf sieht der betreffende Abschnitt so aus:
Code:
Section "InputDevice"
        Identifier      "Hauptmaus"
        Driver  "mouse"
        Option  "Device"        "/dev/input/mouse0"
        Option  "Protocol"      "IMPS/2"
        Option  "Emulate3Buttons"       "no"
        Option  "ZAxisMapping"  "4 5"
        Option  "Buttons"       "6"
EndSection

Es ist also definitiv eine Option für Device angegeben; die betreffende Gerätedatei ist auch existent.

Was ich jetzt nicht verstehe ist: Wieso diese Fehlermeldung?
Zugegeben der Fehler ist nicht weiter tragisch und ich arbeite vermutlich schon eine ganze Weile ungestört mit diesem Zustand, aber ich würde irgendwie dennoch gerne verstehen, wo hier eigentlich der Fehler liegt. Irgendwelche Ideen?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Thu May 12, 2011 10:15 pm    Post subject: Re: Merkwürdiges Verhalten des X-Maustreibers Reply with quote

TheSmallOne wrote:
Irgendwelche Ideen?


Wie siehts denn aus, wenn du als device "/dev/input/mice" ind die xorg.conf schreibst?
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Fri May 13, 2011 12:58 am    Post subject: Reply with quote

Ich weiß ja nicht welchen X-Server du verwendest. Seit 1.8 gab es diese Hal-Kombination mit den fdi-Files. Seit 1.9 muss man das ganze in Dateien schreiben die in einem Verzeichnis Liegen das so heißt: /etc/X11/xorg.conf.d/

In die normale xorg.conf Datei schaut ein aktueller Xserver nicht mehr rein. Er verwendet dann automatische Einstellungen.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Fri May 13, 2011 4:41 am    Post subject: Reply with quote

ChrisJumper wrote:
Ich weiß ja nicht welchen X-Server du verwendest. Seit 1.8 gab es diese Hal-Kombination mit den fdi-Files. Seit 1.9 muss man das ganze in Dateien schreiben die in einem Verzeichnis Liegen das so heißt: /etc/X11/xorg.conf.d/

In die normale xorg.conf Datei schaut ein aktueller Xserver nicht mehr rein. Er verwendet dann automatische Einstellungen.


Hi Chris
Sorry, da muss ich ein kleines Veto einlegen...;)
Die xorg.conf war und ist immer noch die Hauptkonfigurations-Datei für X, und das wird auch hoffentlich immer so bleiben. Der X-Server schaut da mit als erstes nach.
Ab ca. xorg-server-1.5 konnte man ja HAL für die Eingabegeräte nutzen (das war aber optional), hatte man xorg-server mit HAL Unterstützung gebaut dann wurden die Eingabegeräte via hottplugging an HAL weitergereicht und man konnte sie in den berüchtigten fdi-Files abweichend vom default konfigurieren.
Hatte man keine HAL Unterstützung eingebaut, dann wurden die Eingabegeräte normal in der xorg.conf konfiguriert.

Dann ab xorg-server-1.8 kam die Unterstützung von udev (das ist auch optional) und es gibt die Möglichkeit die Eingabegeräte wie gewohnt in der xorg.conf zu konfigurieren. Nutzt man nicht das Hotplugging via udev dann wird normal das angewendet was in
Section "InputDevice"
definiert ist.
Nutzt man doch das Hotplugging, dann wird die Konfiguration aus
Section "InputClass"
verwendet, und alles andere aus Section "InputDevice" schlicht ignoriert. (ja auch wenn sie da sind)
Ob man nun die Section "InputClass" in einzelnen Dateien unter /etc/X11/xorg.conf.d/ ablegt ist ebenfalls optional, man kann sie nutzen, man muss aber nicht. Section "InputClass" kann auch direkt in der xorg.conf gesetzt werden.
Nutzt man beides, also /etc/X11/xorg.conf.d/Dateien und eine xorg.conf, dann hat die xorg.conf stets das letzte Wort :)
Sprich die gute alte xorg.conf ist noch lange nicht tot! :) Die Nutzung von xorg.conf.d/ (unter nutzung von Hotplugging via udev) ist optional.

.....................................................................................
@TheSmallOne
Dein
Code:
(WW) Hauptmaus: No Device specified, looking for one...
stammt vermutlich daher da du Section "InputDevice" gesetzt hast, aber vermutlich doch das Hotplugging über udev nutzt? (was aktuell Standard ist) , wenn ja, dann wird die gesamte Section "InputDevice" schlicht ignoriert.
Ich würde vorschlagen Section "InputClass" draus zu machen und statt des "mouse" Treibers besser den "evdev" Treiber zu verwenden.
Schau zb auch noch mal im Xorg-server 1.8 Upgrade Guide
und auch in der "man xorg.conf"

Section "InputDevice" wird nur dann verwendet wenn man kein Hotplugging via udev nutzt, sprich die Eingabegeräte wirklich vom xorg-server selbst verwalten lässt.
Back to top
View user's profile Send private message
TheSmallOne
Guru
Guru


Joined: 22 Jan 2005
Posts: 461
Location: Germany

PostPosted: Fri May 13, 2011 6:13 am    Post subject: Reply with quote

Josef.95 wrote:
@TheSmallOne
Dein
Code:
(WW) Hauptmaus: No Device specified, looking for one...
stammt vermutlich daher da du Section "InputDevice" gesetzt hast, aber vermutlich doch das Hotplugging über udev nutzt? (was aktuell Standard ist) , wenn ja, dann wird die gesamte Section "InputDevice" schlicht ignoriert.


Da bin ich mir nicht so sicher. Wie kann man das prüfen?
Ich habe jedenfalls kein /etc/X11/xorg.conf.d/ Verzeichniss und in der xorg.conf steht nirgends was von "InputClass".
Zudem habe ich die Option "AutoAddDevices" "off" bei den Server Flags gesetzt und im Logfile Meldungen wie diese hier:
Code:
(II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/mouse0)
(II) AutoAddDevices is off - not adding device.


Hinzu kommt, dass die Option "Device" scheinbar als einziges aus der betreffenden "InputDevice"-Section ignoriert wird; die ebenfalls vorhandenen Werte für "ZAxisMapping", "Emulate3Buttons" usw. werden offenbar korrekt verarbeitet.


Quote:
Ich würde vorschlagen Section "InputClass" draus zu machen und statt des "mouse" Treibers besser den "evdev" Treiber zu verwenden.
Schau zb auch noch mal im Xorg-server 1.8 Upgrade Guide
und auch in der "man xorg.conf"


Ich habe mal Testweise aus "InputDevice" ein "InputClass" gemacht, mit dem Resultat, dass der X-Server nicht mehr starten wollte, weil das Eingabegerät angeblich nicht definiert war.
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Fri May 13, 2011 7:03 am    Post subject: Reply with quote

Wenn du die InputClass verwendest musst du AutoAddDevices auf on schalten.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Fri May 13, 2011 7:08 am    Post subject: Reply with quote

Max Steel wrote:
Wenn du die InputClass verwendest musst du AutoAddDevices auf on schalten.

Das muss man normal nicht explizit setzen wenn man Xorg mit udev verwendet, es wird schon als default verwendet.
Sprich man müsste es nur setzen wenn man es explizit deaktivieren möchte.
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Fri May 13, 2011 7:33 am    Post subject: Reply with quote

Josef.95 wrote:
Das muss man normal nicht explizit setzen wenn man Xorg mit udev verwendet, es wird schon als default verwendet.
Sprich man müsste es nur setzen wenn man es explizit deaktivieren möchte.


Richtig, aber TheSmallOne hats explizit abgeschaltet.
Zumindest laut seinen eigenen Beitrag paar Zeilen weiter oben.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Fri May 13, 2011 7:43 am    Post subject: Reply with quote

Max Steel wrote:
Josef.95 wrote:
Das muss man normal nicht explizit setzen wenn man Xorg mit udev verwendet, es wird schon als default verwendet.
Sprich man müsste es nur setzen wenn man es explizit deaktivieren möchte.


Richtig, aber TheSmallOne hats explizit abgeschaltet.
Zumindest laut seinen eigenen Beitrag paar Zeilen weiter oben.

Ahhrg, ja sorry, ich hatte den in der Zwischenzeit hinzugekommenen Beitrag von TheSmallOne schlicht übersehen... :oops:
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Fri May 13, 2011 7:54 am    Post subject: Reply with quote

TheSmallOne wrote:
......
Quote:
Ich würde vorschlagen Section "InputClass" draus zu machen und statt des "mouse" Treibers besser den "evdev" Treiber zu verwenden.
Schau zb auch noch mal im Xorg-server 1.8 Upgrade Guide
und auch in der "man xorg.conf"


Ich habe mal Testweise aus "InputDevice" ein "InputClass" gemacht, mit dem Resultat, dass der X-Server nicht mehr starten wollte, weil das Eingabegerät angeblich nicht definiert war.

Ja das ist schon richtig, beachte das wenn du das hotplugging wieder anschaltest (bzw nicht deaktivierst) und Section "InputClass draus machst, das dann auch die Zeilen aus der Section "ServerLayout" für das Eingabegerät entfernt oder einkommentiert werden muss.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Fri May 13, 2011 6:51 pm    Post subject: Reply with quote

Quote:
Sprich die gute alte xorg.conf ist noch lange nicht tot! :) Die Nutzung von xorg.conf.d/ (unter nutzung von Hotplugging via udev) ist optional.


Sehr interessant! Ich hatte das in meinem letzten Post so sicher behauptet weil eben nach dem X-Server update auf 1.9 meine vorhandene xorg.conf komplett ignoriert wurde. Nach dem erstellen der Datein in xorg.conf.d hat es problemlos geklappt.

Anbei: Unter Ubuntu 10.x hatte ich ähnliche Erfahrungen, das eine Section für die Grafikkarte ignoriert wurde. Dort kann es aber auch ein Bug gewesen sein, weil dort alles verfügbare geladen wurde.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum