Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] IceWM und blueman/nm-applet
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
V10lator
Apprentice
Apprentice


Joined: 11 Jul 2004
Posts: 199

PostPosted: Fri May 13, 2011 8:05 am    Post subject: [gelöst] IceWM und blueman/nm-applet Reply with quote

Hi,
ich bin derzeit dabei auf meinem Netbook von LXDE auf IceWM umzusteigen. Bisher klappte das auch relativ gut.
Nun wollte ich aber LXDE komplett entfernen. Dafür verwendete ich in etwa folgenden Befehl:
Code:
emerge -av --unmerge \*lxde\*/\* \*/\*lxde\* openbox && emerge lxdm && emerge -av --depclean
welcher auch durchlief.
Doch nach einem reboot kann das nm-applet keine Verbindung mehr aufbauen:
Code:
nm-applet
** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area
** Message: <info>  No keyring secrets found for Auto <NetworkName>/802-11-wireless-security; asking user.


** (nm-applet:5619): CRITICAL **: nm_connection_get_setting: assertion `NM_IS_CONNECTION (connection)' failed

** (nm-applet:5619): CRITICAL **: applet_settings_new_secrets_requested_cb: assertion `s_con != NULL' failed
Auch wenn dort steht "asking user", das tut es nicht.

Auch das blueman-applet funktioniert nicht.

Ich habe die /etc/X11/Sessions/icewm schon durch folgendes ersetzt:
Code:
#!/bin/sh
exec ck-launch-session dbus-launch /usr/bin/icewm-session
Leider ohne Verbesserung.

Mich wundert am meisten das vor der Deinstallation von LXDE alles funktionierte.

//EDIT: Nach einer Neuinstallation von nm-applet werde ich wieder nach dem W-LAN Passwort gefragt und kann nach Eingabe dessen auch verbinden. Leider wird das Passwort jedoch nicht gespeichert... :(

//EDIT²: Okay, ich habe jetzt viel experimentiert. Zuerst einmal ist folgendes am Anfang meiner ~/.icewm/startup gelandet:
Code:
/usr/bin/gnome-keyring-daemon --start --components=gpg
/usr/bin/gnome-keyring-daemon --start --components=pkcs11
/usr/bin/gnome-keyring-daemon --start --components=secrets
/usr/bin/gnome-keyring-daemon --start --components=ssh
/usr/libexec/polkit-gnome-authentication-agent-1 &

Was ich sonst noch alles versucht habe kann ich nicht mehr genau sagen, jedenfalls kann ich nun das W-LAN Passwort speichern wenn die Verbindung als für alle benutzbar gesetzt ist. Nicht perfekt aber immerhin ein würgaround. ;)

Nun versuche ich noch das blueman-applet hinzubekommen: http://paste.pocoo.org/show/388021/
Code:
update_menuitems (/usr/lib/python2.7/site-packages/blueman/plugins/applet/DiscvManager.py:132)
warning: Adapter is None

Code:
lsusb
...
Bus 003 Device 002: ID 0a5c:2150 Broadcom Corp. BCM2046 Bluetooth Device
...


//EDIT³: Es war ein Fehler beim Umstieg auf OpenRC: das Bluetooth init Script hat im default runlevel gefehlt.

//EDIT⁴: https://forums.gentoo.org/viewtopic-p-6685341.html#6685341 + https://bbs.archlinux.org/viewtopic.php?pid=909243#p909243 = 1A funktionierendes nm-applet. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum