Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kann adobe-flash-10.3.181.14-r1 nicht maskieren [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Sun May 15, 2011 11:31 am    Post subject: Kann adobe-flash-10.3.181.14-r1 nicht maskieren [solved] Reply with quote

Hi Leute,

wasn jetzt los, bin ich auf einmal zu deppert ein Paket zu maskieren (liegt's vielleicht am Restalkohol ;-)

Also, Gestern ging's noch, damit mir mein gut funktionierender 64Bit adobe-flash Player nicht gegen die neue 32bit Variante adobe-flash-10.3.181.14 + www-plugins/nspluginwrapper-1.3.0 ausgetauscht wurde habe ich Gestern die Version maskiert durch die Eingabe von:
Code:
echo "=www-plugins/adobe-flash-10.3.181.14" >> /etc/portage/package.mask

Also world update gemacht -alles gut soweit.

Heute gibt's schon 'ne neue Version, nämlich adobe-flash-10.3.181.14-r1, also hab ich auch die noch in die package.mask aufgenommen, leider bewirkt das aber nichts, denn portage möchte sie stur trotzdem installieren. Hab auch schon verschiedene Arten des maskierens durchprobiert >= blah und blubb - doch nix.

Wenn ich dagegen noch den www-plugins/nspluginwrapper maskiere, dann behauptet portage ganz dreist:
Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-libs/libwpg-0.2.0-r1 [0.2.0] USE="-doc" 320 kB
[ebuild     U  ] app-admin/eselect-postgresql-1.0.10 [1.0.9] 4 kB
[ebuild     U  ] dev-python/numpy-1.6.0 [1.5.1] USE="-doc -lapack -test" 2,572 kB
[ebuild     U  ] sys-apps/grep-2.8 [2.7] USE="nls pcre" 993 kB
[ebuild     U  ] sys-fs/udev-168-r2 [168-r1] USE="extras (-selinux) -test" 595 kB
[ebuild   R    ] app-text/libspectre-0.2.6  USE="-debug -doc -static-libs (-test%)" 350 kB
[ebuild     U  ] sys-auth/consolekit-0.4.5 [0.4.4-r1] USE="pam policykit -debug -doc -test" 416 kB
[ebuild  N     ] kde-base/okteta-4.6.3  USE="handbook (-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 5,934 kB
[ebuild     U  ] kde-base/kwin-4.6.3-r1 [4.6.3] USE="opengl xinerama (-aqua) -debug (-kdeenablefinal) (-kdeprefix) -xcomposite" 67,724 kB
[ebuild     U  ] kde-base/kdeutils-meta-4.6.3-r1 [4.6.3] USE="cups (-aqua) -floppy (-kdeprefix)" 0 kB

Total: 10 packages (8 upgrades, 1 new, 1 reinstall), Size of downloads: 78,904 kB

!!! The following update has been skipped due to unsatisfied dependencies:

www-plugins/adobe-flash:0

!!! All ebuilds that could satisfy "www-plugins/nspluginwrapper" have been masked.
!!! One of the following masked packages is required to complete your request:
- www-plugins/nspluginwrapper-1.3.0::gentoo (masked by: package.mask)
- www-plugins/nspluginwrapper-1.2.2-r2::gentoo (masked by: package.mask)

(dependency required by "www-plugins/adobe-flash-10.3.181.14-r1" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Hier die package.mask zu obiger Ausgabe:
Code:

=www-plugins/adobe-flash-10.3.181.14
=www-plugins/adobe-flash-10.3.181.14-r1
www-plugins/nspluginwrapper

Kommentiere ich den nspluginwrapper Eintrag dagegen aus, dann sieht das Ergebnis so aus:
Code:

alculating dependencies... done!
[ebuild     U  ] media-libs/libwpg-0.2.0-r1 [0.2.0] USE="-doc" 320 kB
[ebuild     U  ] app-admin/eselect-postgresql-1.0.10 [1.0.9] 4 kB
[ebuild     U  ] dev-python/numpy-1.6.0 [1.5.1] USE="-doc -lapack -test" 2,572 kB
[ebuild     U  ] sys-apps/grep-2.8 [2.7] USE="nls pcre" 993 kB
[ebuild  N     ] www-plugins/nspluginwrapper-1.3.0  422 kB
[ebuild     U  ] sys-fs/udev-168-r2 [168-r1] USE="extras (-selinux) -test" 595 kB
[ebuild     U #] www-plugins/adobe-flash-10.3.181.14-r1 [10.2.159.1_p201011173] USE="vdpau (-kde) (-32bit%*) (-64bit%*) (-bindist%) (-multilib%*)" 5,320 kB                                                                                                   
[ebuild   R    ] app-text/libspectre-0.2.6  USE="-debug -doc -static-libs (-test%)" 350 kB
[ebuild     U  ] sys-auth/consolekit-0.4.5 [0.4.4-r1] USE="pam policykit -debug -doc -test" 416 kB
[ebuild  N     ] kde-base/okteta-4.6.3  USE="handbook (-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 5,934 kB
[ebuild     U  ] kde-base/kwin-4.6.3-r1 [4.6.3] USE="opengl xinerama (-aqua) -debug (-kdeenablefinal) (-kdeprefix) -xcomposite" 67,724 kB
[ebuild     U  ] kde-base/kdeutils-meta-4.6.3-r1 [4.6.3] USE="cups (-aqua) -floppy (-kdeprefix)" 0 kB

Total: 12 packages (9 upgrades, 2 new, 1 reinstall), Size of downloads: 84,644 kB

Verdächtig, was soll'n die (rote) # vor dem #] www-plugins/adobe-flash-10.3.181.14-r1
Könnte das an einer falschen Maskierung im profil liegen, wo war das noch gleich, ich glaub ich guck da mal nach...

Sonst noch Ideen von eurer Seite? Habt ihr das auch?

P.S.Bin auf 64-bit unstable arch ~

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!


Last edited by Randy Andy on Sun May 15, 2011 12:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sun May 15, 2011 11:49 am    Post subject: Reply with quote

Hallo Randy Andy

Nur ein Schuss ins Blaue
Ich vermute das du adobe-flash noch in der package.unmask mit drinnen hast?
Beachte das in package.unmask demaskierte Pakete die Einträge aus package.mask überstimmt ;)

/edit
Ich würde in deinem Fall adobe-flash in der package.mask komplett maskieren, und dann in der package.unmask nur die Version demaskieren die du wirklich möchtest.
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Sun May 15, 2011 12:18 pm    Post subject: Reply with quote

Hi Josef,

verdammt, du hast mal wieder recht - dankeschön. Vielleicht lag's doch am Restalkohol :oops:

Ich hatte www-plugins/adobe-flash in der package.unmask stehen,
hab's nun auf =www-plugins/adobe-flash-10.2.159.1_p201011173
gesetzt, und alles ist gut...


Ich war schon im Changelog und fragte mich schon was das damit zu tun haben soll...

Quote:

14 May 2011; Jim Ramsay <lack@gentoo.org> arch/amd64/package.use.mask:
Masking USE=kde for www-plugins/adobe-flash under amd64 since the config
plugin is 32-bit only.

14 May 2011; Jim Ramsay <lack@gentoo.org> package.mask:
Removed old adobe-flash versions as foretold in package.mask


@All
Was nutzt ihr denn so neuerdings, und läuft das nun weniger Prozzesorlastig?
Flash mit 32Bit und vdpau Unterstützung, auch unterm 64-Bit mit Multilib und welcher Browswervarinate.

Ich war eigentlich froh, dass es Flash endlich 64-Bit nativ gab, nach all dem früheren rumgehuddel mit dem
www-plugins/nspluginwrapper.

Wie sind denn eure Erfahrungen mit der aktuellen vdpau-Unterstützung für flash auf'm 64-Bit system?


Interessierten Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum