Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
suspend to ram geht nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
FrancisA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2010
Posts: 111

PostPosted: Tue May 24, 2011 6:03 pm    Post subject: suspend to ram geht nicht Reply with quote

Hallo,

suspen (mit logout => suspend) schaltet den Bildschirm weg, aber der PC läuft weiter (was man am Geräusch hört). Auch wenn ich manuell pm-suspend aufrufe, ist es das gleiche. Das "Aufwachen" geht natürlich auch nicht, ich muss den Notebook ein und ausschalten (In Ubuntu funktioniert das aber).

/var/log/suspend hat folgenden Inhalt:

Code:

Initial commandline parameters:
Blacklisting 01grub.
Blacklisting 55NetworkManager.
Blacklisting 90clock.
Tue May 24 21:56:27 CEST 2011: Running hooks for suspend.
Running hook /usr/lib/pm-utils/sleep.d/00logging suspend suspend:
Linux localhost 2.6.39+ #7 SMP Mon May 23 20:19:11 CEST 2011 i686 Intel(R) Core(TM) i3 CPU M 370 @ 2.40GHz GenuineIntel GNU/Linux
Module                  Size  Used by
ntfs                  155053  1
radeon                574682  2
ttm                    37363  1 radeon
wl                   2590410  0
drm_kms_helper         18640  1 radeon
             total       used       free     shared    buffers     cached
Mem:       3100668     235264    2865404          0      12268     109224
-/+ buffers/cache:     113772    2986896
Swap:      1999996          0    1999996

/usr/lib/pm-utils/sleep.d/00logging suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00powersave suspend suspend:
Blacklisting 01grub.
Blacklisting 55NetworkManager.
Blacklisting 90clock.

/usr/lib/pm-utils/sleep.d/00powersave suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/01grub suspend suspend:

/usr/lib/pm-utils/sleep.d/01grub suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend:

/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend:

/usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/75modules suspend suspend:

/usr/lib/pm-utils/sleep.d/75modules suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/90clock suspend suspend:

/usr/lib/pm-utils/sleep.d/90clock suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/91wicd suspend suspend:
Unable to connect to wicd daemon - is it running?

/usr/lib/pm-utils/sleep.d/91wicd suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend:

/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/95led suspend suspend:

/usr/lib/pm-utils/sleep.d/95led suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend:
Kernel modesetting video driver detected, not using quirks.

/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/99video suspend suspend:
kernel.acpi_video_flags = 0

/usr/lib/pm-utils/sleep.d/99video suspend suspend: success.
Tue May 24 21:56:27 CEST 2011: performing suspend


Vielleicht weiß jemand, woran das liegen könnte.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2224
Location: Germany

PostPosted: Tue May 24, 2011 8:44 pm    Post subject: Reply with quote

Wie hast du es denn eingerichtet? Gentoo ist nicht unbedingt so freundlich das all diese Optionen automatisch eingerichtet werden. Wirf doch mal einen Blick in den:

Power Management Guide
Back to top
View user's profile Send private message
FrancisA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2010
Posts: 111

PostPosted: Wed May 25, 2011 7:42 am    Post subject: Reply with quote

Danke für den Hinweis; dachte ich mir eigentlich fast, dass da noch was abgeht an Konfiguration. Eigentlich müsste ich das (zumindest teilweise) vom funktionierenden Ubuntu übernehmen können(?)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Wed May 25, 2011 11:25 am    Post subject: Reply with quote

Hmm. wenn du die USE-Flag "pm-utils" gesetzt hast (und die pm-utils installiert sind) sollte es i.d.R. ohne weitere Konfiguration funktionieren.
Doch falls es sich hier um das selbe System handelt würde ich vorschlagen das du dein world zunächst auf einen aktuellen gesunden Stand bringst bevor du hier weiter suchst.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3686
Location: Hamburg

PostPosted: Fri May 27, 2011 9:47 am    Post subject: Reply with quote

Und evtl. versuch doch auch herauszufinden, ob der eigentliche Befehl auch geht : https://forums.gentoo.org/posting.php?mode=quote&p=6701201
Back to top
View user's profile Send private message
FrancisA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2010
Posts: 111

PostPosted: Fri May 27, 2011 9:45 pm    Post subject: Reply with quote

toralf wrote:
Und evtl. versuch doch auch herauszufinden, ob der eigentliche Befehl auch geht : https://forums.gentoo.org/posting.php?mode=quote&p=6701201

Ja, der eigentliche Befehl müsste Deinen Anweisungen nach gehen.
@Josef: nein, funktioniert nicht. Was Du als "=>hier" bezeichnet hast, au weia, muss ich andersmal erzählen, wenn ich mit dem ganzen durch bin....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum