Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SIM PIN wird abgefragt und nicht akzeptiert
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Thu Jun 02, 2011 5:50 am    Post subject: SIM PIN wird abgefragt und nicht akzeptiert Reply with quote

Moin,
seit neustem muss ich für meine im Sony Ericsson f3507g UMTS-Modem eingeschobene SIM-Card beim Systemstart eine PIN eingeben. Diese PIN wird wohl von networkmanager/ModemManager abgefragt. Wenn ich die PIN eingebe, wird mir das mit "This request requires the 'org.freedesktop.ModemManager.Device.Control' authorization" abgewiesen.

Ich kann die (richtige) PIN beliebig oft eingeben, sie wird weder akzeptiert, noch gespeichert. Das Problem trat zuerst bei einem Ubuntu auf (habs seinerzeit nur als LiveCD kurz angetestet) und wurde mit irgendeiner neuen Version von irgendwas (ModemManager?) jetzt auch in mein Gentoo importiert. :(

»Nimm doch die SIM Karte raus, stecke sie in ein Telefon und deaktiviere die SIM-Abfrage« ist irgendwie nicht die Lösung, die ich mir wünschen würde. Kann doch nicht sein, dass das jahrelang funktionierte und plötzlich nicht mehr geht.

Wie erteilt man die Berechtigung für org.freedesktop.ModemManager.Device.Control?
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
knecht
n00b
n00b


Joined: 28 Oct 2010
Posts: 13

PostPosted: Sat Nov 12, 2011 10:05 am    Post subject: Reply with quote

Ich habe hier den gleichen Fehler mit meinem Thinkpad t410. Leider kenne ich mich mit dbus (darauf bezieht sich die Meldung doch, oder) nicht gut genug aus, wie erteilt man dem User dieses Recht?
_________________
Linux, programming and image processing, thats fun!
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Sat Nov 12, 2011 10:28 am    Post subject: Reply with quote

Ich habe kürzlich festgestellt, dass die PIN akzeptiert wird, wenn ich einen Haken bei "only for this session" (sinngemäß, habe die Meldung aktuell gerade nicht im Kopf) setze. Eigentlich ziemlich sinnfrei, ich würde sie ja gerne dauerhaft speichern, aber auf dem Weg akzeptiert er sie wenigstens für den Moment.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Sat Nov 12, 2011 10:31 am    Post subject: Reply with quote

Hmm.., nur ein blinder Schuss ins Blaue,
ich frage mich ob das nicht über consolekit läuft?
Hat euer User unter X eine aktive Session?
Schaut doch mal in der
Code:
ck-list-sessions
Ausgabe.
Back to top
View user's profile Send private message
knecht
n00b
n00b


Joined: 28 Oct 2010
Posts: 13

PostPosted: Sun Nov 13, 2011 1:57 pm    Post subject: Reply with quote

Ich sollte vielleicht erwähnen, das ich Fluxbox als WM benutze, und nicht Gnome.

Ich starte mein Fluxbox und nm-applet wie folgt:
Code:

dbus-launch nm-applet --sm-disable&
exec ck-launch-session /usr/bin/fluxbox


Ich kenne die Ausgabe von ck-list-sessions nicht, aber sieht unvollständig für mich aus:
Code:
myself@lapslave ~ $ ck-list-sessions
Session1:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2011-11-13T13:41:29.268437Z'
        login-session-id = ''
Session2:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat2'
        session-type = ''
        active = FALSE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = FALSE
        on-since = '2011-11-13T13:41:34.801900Z'
        login-session-id = ''


Wie ist der Zusammenhang zwischen consolekit und dbus? Meint policy at_console="true" das consolekit die Zugriffsberechtigung regelt?

z.B.
Code:

.
.
.
        <policy at_console="true">
                <allow own="org.freedesktop.NetworkManagerUserSettings"/>

                <allow send_destination="org.freedesktop.NetworkManagerUserSettings"
                       send_interface="org.freedesktop.NetworkManagerSettings"/>

                <allow send_destination="org.freedesktop.NetworkManagerUserSettings"
                       send_interface="org.freedesktop.NetworkManagerSettings.Connection"/>
        </policy>
.
.
.


Ich habe schon versucht das Problem durch duplizieren der root Filter für meinen lokalen User myself zu lösen (ich kenne mich zugegeben nicht gut mit dbus und consolekit aus, bin für jeden Hinweis dankbar.
_________________
Linux, programming and image processing, thats fun!
Back to top
View user's profile Send private message
knecht
n00b
n00b


Joined: 28 Oct 2010
Posts: 13

PostPosted: Sun Nov 13, 2011 2:12 pm    Post subject: Reply with quote

Habe nun folgendes probiert:
https://wiki.archlinux.org/index.php/NetworkManager#Set_up_PolicyKit_permissions

Meine policykit Datei /etc/polkit-1/localauthority/50-local.d/org.freedesktop.NetworkManager.pkla
Code:
[nm-applet]
Identity=unix-group:myself
Action=org.freedesktop.NetworkManager.*
ResultAny=yes
ResultInactive=no
ResultActive=yes


Hat keine Veränderung bewirkt. Wenn ich die PIN eingebe erhalte ich folgende Fehlermeldung von nm-applet auf der Konsole:
Code:
** (nm-applet:7496): WARNING **: unlock_pin_reply: error unlocking with PIN: This request requires the 'org.freedesktop.ModemManager.Device.Control' authorization

Ich kann daraus nicht erkennen ob dbus oder policykit es mir verbietet. Als root funktioniert es. Hat jemand einen Vorschlag für eine dbus oder policykit Regel?
_________________
Linux, programming and image processing, thats fun!
Back to top
View user's profile Send private message
knecht
n00b
n00b


Joined: 28 Oct 2010
Posts: 13

PostPosted: Sun Nov 13, 2011 2:23 pm    Post subject: Reply with quote

Die PolicyKit Regel ist die Lösung für das Problem, nur muss die Action nicht org.freedesktop.NetworkManager.* sondern org.freedesktop.ModemManager.* lauten (bin ich wieder zu voreilig gewesen, und habe Details übersehen :roll: )

Ich konnte das Problem damit lösen.

Datei /etc/polkit-1/localauthority/50-local.d/org.freedesktop.NetworkManager.pkla mit folgendem Inhalt erzeugen:
Code:
[nm-applet]
Identity=unix-group:myself
Action=org.freedesktop.ModemManager.*
ResultAny=yes
ResultInactive=no
ResultActive=yes


@Josef.95
Danke, das du mich auf die richtige Spur gebracht hast, dachte das dreht sich nur um dbus
_________________
Linux, programming and image processing, thats fun!
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Sun Nov 13, 2011 2:37 pm    Post subject: Reply with quote

knecht wrote:
Ich konnte das Problem damit lösen.

Datei /etc/polkit-1/localauthority/50-local.d/org.freedesktop.NetworkManager.pkla mit folgendem Inhalt erzeugen:
Code:
[nm-applet]
Identity=unix-group:myself
Action=org.freedesktop.ModemManager.*
ResultAny=yes
ResultInactive=no
ResultActive=yes

wow, danke für die Rückmeldung. Ich werde das in Kürze mal gegentesten.

Da soll mal erstmal einer drauf kommen ...
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum