Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-light-3.0.0: only background and mouse pointer
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
patrikas
Tux's lil' helper
Tux's lil' helper


Joined: 28 Nov 2009
Posts: 106

PostPosted: Thu Jun 02, 2011 12:03 pm    Post subject: gnome-light-3.0.0: only background and mouse pointer Reply with quote

I'm currently trying to migrate to Gnome3 from Gnome overlay. I've been using simple procedure to update packages - just enabled Gnome overlay, unmasked necessary packages by using status/portage-configs and updated the system as usual. Upon starting Gnome3 through gdm I can only see mouse pointer (I'm able to move it and use keyboard) and default striped background. Gdm works perfectly.. I've searched through logs and couldn't find anything relevant. Does it have anything to do with "light" version ? Any suggestions how to trace it ?
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2229
Location: Germany

PostPosted: Sun Jun 05, 2011 3:29 pm    Post subject: Reply with quote

Quote:
Upon starting Gnome3 through gdm I can only see mouse pointer (I'm able to move it and use keyboard) and default striped background. Gdm works perfectly.. I've searched through logs and couldn't find anything relevant. Does it have anything to do with "light" version ? Any suggestions how to trace it ?


Have the same issue here, other too. I don't know. Could be related to a broken installation. On my System it is, cause i can't upgrade glib to got a clean up to date install of gnome3. So i tried to install Packages which are not so up to date like glib 2.28.7 instead of the actual (2.29.4). And so on, it seems that there is some constellation of packages that will not work well together. If you can, try to update all packages (glib-999 and x11-libs/gtk+-3.0.10).

Take a look into your ~/.xsession-errors file that will be create if you have the mouse on the background-Issue without anything. Just login on tty (ctrl + F1) and copy your .xsession-errors File to elsewhere, cause it will be overwritten when you login into another desktop-environment.
(alt + ctrl + backspace) will not work so i have to reboot every time to (read) this error out.. i am so lazy.

I tried to do an update.. from an old gnome-installation. Actually i think it would be better to remove all old gnome-2.28 and minor packages than 2.30) cause revdep-rebuild will rebuild every time the old gnome-packages.
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 516

PostPosted: Tue Jun 07, 2011 10:30 pm    Post subject: Merging gnome3--unmerge gnome2 before! Reply with quote

I had far too much troubles merging gnome3... I did it 3 times already with different kind of issues each time I did,--actually the second time it went seamlessly without any further effort than unmerging gnome-2.3* and a few closely related gnome2 software like gnome-mplayer, gnome2 themes, gtk2-engines etc., the real gtk2 world to avoid blocks as I did have the first time, trying to update gnome2 which ended up being a real mess as many gnome2 stuff remained, and an `emerge -avc' to clean up the mess,-- the second time as I said went pretty well, arround 170 binaries get pulled in and gnome3 was available in a dozen of minutes. So I advice to unmerge gnome2 and closely related softwares and `emerge -avc' before merging. It'll be less painful in this way. The other way around, updating gnome2 to will take too much time as portage will try to preserve gnome2 dependencies before updating the whole shit. It's too troublesome to bother with it.
And why the 3 times already? because the first time was a real mess updating gnome2; I did not take much attention of merging gnome3 the second time as all the necessaries binaries was already built and pulled in together; the third time I took little attention to solve the login issue see here or more info F15 -gnome3 login failure. And why trying to merge gnome3 three time already?! because I have a full backup of my system with a stage4 of 120MB with squashed directories usr:{,s}bin:lib{32,64}:opt:var/portage:var/local/portage:var/db:var/cache/edb:var/lib/layman which take as much as 2GB in this compressed format, so when restoring my stage4 backup it's only a `tar -xvzpf *`uname -r`stage4.tgz' of a 120MB stage4 tarball and copy over 2GB of squashed directories! This is far simpler to maintain and keep a small system footage which resist to any merging breakage and deletion of a system directory. I happened to have deleted the whole usr directory and restored in no time with one single image/file to restore! long lieve aufs+squashfs combination!
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 531

PostPosted: Wed Jun 08, 2011 2:00 am    Post subject: Reply with quote

I was having the same problem, and I suspect that it is related to old configuration files lying around. This is because I was having the problem in my account, but Gnome worked fine in a new account that I made. I've had success with Gnome 3 on only one of my computers, an Asus laptop with a discrete (but not illicit) NVidia G.P.U. On my desktop computer, which has a Radeon 6950, the menu bar is corrupted, and my Toughbook has only 1GB R.A.M. and not a very fast video adapter. For these reasons, I'm not incredibly interested in Gnome 3 yet. Plus it's such a pain to switch back and forth between versions (2.32 to 3 and back).
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2229
Location: Germany

PostPosted: Wed Jun 08, 2011 9:18 am    Post subject: Reply with quote

keet wrote:
I was having the same problem, and I suspect that it is related to old configuration files lying around.

Yes! I post this in the Gnome 3 How to emerge -Thread and list my .xsesson-erros i a post before.

ChrisJumper wrote:
My Issue got Solved!

I delete old settings in my .config/autostart one of them was xfconf-migration-4.6.desktop, other xfce4 related Stuff and old thnigs that used my gnome-session-properties. I have fluxbox installed to so i start gnome-session-properties from fluxbox and unchecked the (save/memories all running Applications - Sorry my English translation is not so well there, think this is the only checkbox under the Options TAB there.)

In other Forums they recommend to delete ~/.local/share/applications/ but i think that's too much. So I made a backup of this too and delete some stuff.

If the error still occur and ctrl + alt + backspace will not work just login as root and restart /etc/init.d/dbus restart and you should be back to your gdm.

Edit: Ok, just if i connect two screens, (dual mode) gnome3 would not start.


Personal i would recommend to migrate from an old gnome2 if you will not loose your evolution-Mails (my migration to gnome3 went really fine there, it just confuse me that the new evolution sort mails "by threat" as default. So all Mails seems to be unsorted in a crazy way this time.) or your nautilus bookmarks and so on, that was important for me.

Quote:
I've had success with Gnome 3 on only one of my computers, an Asus laptop with a discrete (but not illicit) NVidia G.P.U. On my desktop computer, which has a Radeon 6950, the menu bar is corrupted, and my Toughbook has only 1GB R.A.M. and not a very fast video adapter. For these reasons, I'm not incredibly interested in Gnome 3 yet. Plus it's such a pain to switch back and forth between versions (2.32 to 3 and back).


All with the ATI Cards, i would try the Gnome3 Live CD to check the hardware.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum