Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Gnome 3] Nvidia : Separate X screen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
NEOxAKIRA
Guru
Guru


Joined: 20 May 2007
Posts: 302
Location: France

PostPosted: Sat Jun 11, 2011 12:26 pm    Post subject: [Gnome 3] Nvidia : Separate X screen Reply with quote

Hello,

When I enable separate X screen on my second screen which is a TV plug in HDMI, Gnome3 crash after login in GDM ...

here my .xsession-errors :
Quote:
/etc/gdm/Xsession: Beginning session setup...
which: no keychain in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.2:/opt/blackdown-jdk-1.4.2.03/bin:/opt/blackdown-jdk-1.4.2.03/jre/bin:/opt/android-sdk-update-manager/tools:/opt/android-sdk-update-manager/platform-tools:/home/neoakira/android/eclipse:/home/neoakira/android/idea-IC-98.187/bin:/usr/games/bin:/home/neoakira/bin:/home/neoakira/android-sdk-linux_x86/tools:/home/neoakira/android-sdk-linux_x86/platform-tools)
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/dbus-launch --exit-with-session /usr/bin/ssh-agent -- gnome-session
GNOME_KEYRING_CONTROL=/tmp/keyring-5Vk8LC
GNOME_KEYRING_PID=1656
GNOME_KEYRING_CONTROL=/tmp/keyring-5Vk8LC
GPG_AGENT_INFO=/tmp/keyring-5Vk8LC/gpg:0:1
SSH_AUTH_SOCK=/tmp/keyring-5Vk8LC/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-5Vk8LC
GPG_AGENT_INFO=/tmp/keyring-5Vk8LC/gpg:0:1
GNOME_KEYRING_CONTROL=/tmp/keyring-5Vk8LC
GPG_AGENT_INFO=/tmp/keyring-5Vk8LC/gpg:0:1
SSH_AUTH_SOCK=/tmp/keyring-5Vk8LC/ssh

** (gnome-settings-daemon:1653): WARNING **: Ignoring unknown module 'org.gnome.settings-daemon.plugins.gconf'

** (gnome-settings-daemon:1653): WARNING **: Connection failed, reconnecting...
Failed to play sound: File or data not found
** Message: applet now removed from the notification area
E: main.c: Échec lors du démarrage du démon.
JS LOG: GNOME Shell started at Sat Jun 11 2011 14:17:12 GMT+0200 (CEST)

(gnome-shell:1688): Gvc-WARNING **: Connection failed, reconnecting...
Avertissement du gestionnaire de fenêtres : Log level 16: get_all_cb: couldn't retrieve system settings properties: (25) Launch helper exited with unknown return code 1.

** (nm-applet:1694): WARNING **: get_all_cb: couldn't retrieve system settings properties: (25) Launch helper exited with unknown return code 1.

** (nm-applet:1694): WARNING **: fetch_connections_done: error fetching connections: (25) Launch helper exited with unknown return code 1.

** (nm-applet:1694): WARNING **: Failed to register as an agent: (25) Launch helper exited with unknown return code 1
** Message: applet now embedded in the notification area
Avertissement du gestionnaire de fenêtres : CurrentTime used to choose focus window; focus window may not be correct.
Avertissement du gestionnaire de fenêtres : Got a request to focus the no_focus_window with a timestamp of 0. This shouldn't happen!
Avertissement du gestionnaire de fenêtres : Log level 16: fetch_connections_done: error fetching connections: (25) Launch helper exited with unknown return code 1.
Avertissement du gestionnaire de fenêtres : Log level 16: nm_client_get_devices: error getting devices: Launch helper exited with unknown return code 1

JS LOG: NetworkManager is not running, hiding...

(gnome-shell:1688): GdmUser-WARNING **: Unable to parse history: (null) 26


** (gnome-settings-daemon:1653): WARNING **: Connection failed, reconnecting...

(gnome-shell:1688): Gvc-WARNING **: Connection failed, reconnecting...

** (gnome-settings-daemon:1653): WARNING **: Connection failed, reconnecting...

(gnome-shell:1688): Gvc-WARNING **: Connection failed, reconnecting...

** (gnome-settings-daemon:1653): WARNING **: Connection failed, reconnecting...

(gnome-shell:1688): Gvc-WARNING **: Connection failed, reconnecting...
Avertissement du gestionnaire de fenêtres : Received a _NET_WM_MOVERESIZE message for 0x1000005 (neoakira@g); these messages lack timestamps and therefore suck.


and my xorg.conf generated with nvidia-settings :
Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 270.41.19  (buildmeister@swio-display-x86-rhel47-07.nvidia.com)  Mon May 16 23:52:01 PDT 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/lib64/X11/fonts/misc/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/misc/"
EndSection

Section "InputDevice"
    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "SONY TV"
    HorizSync       14.0 - 70.0
    VertRefresh     48.0 - 62.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "ViewSonic VX2245wm"
    HorizSync       30.0 - 82.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9600 GT"
    BusID          "PCI:3:0:0"
    Screen          1
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9600 GT"
    BusID          "PCI:3:0:0"
    Screen          0
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "metamodes" "DFP-1: 1920x1080 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "metamodes" "DFP-0: 1680x1050 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


With just one screen enable, It's work fine...

any ideas ?
Back to top
View user's profile Send private message
TabJones
n00b
n00b


Joined: 11 May 2011
Posts: 4
Location: Italy

PostPosted: Sat Jun 18, 2011 9:40 pm    Post subject: Reply with quote

Hi

I've the same problem, unfortunatly it seems to be an issue with nvidia-drivers and xrandr.
Right now i couldn't get it to work and i also tryied with twinview, AFAIK we have to wait for the nvidia folks to release a new driver that works on gnome3.
I could only revert to gnome 2.6 since i DO WANT dual screen, i'm too used to it to simply give it away like this...
_________________
Why do i have to think about a cool signature ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum