Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome3-netw.-manager/wpa_supplicant doesn`t connect automat.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
arkas
n00b
n00b


Joined: 08 Dec 2010
Posts: 60

PostPosted: Sat Jun 11, 2011 8:10 pm    Post subject: gnome3-netw.-manager/wpa_supplicant doesn`t connect automat. Reply with quote

hello,

I just now put on a new system with gnome3 and have the following problem.
the network manager does not save my wireless key.
I have found nothing in the internet and have no idea what to do.
Someone else maybe?

Thanks for help.


Last edited by arkas on Sun Jun 12, 2011 12:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Sun Jun 12, 2011 8:39 am    Post subject: Reply with quote

Try setting your wireless key within nm-applet running as root, preferably not in gnome-3. Then switch back to gnome-3. It must work.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
arkas
n00b
n00b


Joined: 08 Dec 2010
Posts: 60

PostPosted: Sun Jun 12, 2011 11:55 am    Post subject: Reply with quote

I have found that NetworkManager saves the key and
some aditional network-settings automatically in
/etc/wpa_supplicant/wpa_supplicant.conf:
Code:

#Generated by NetworkManager
###### Global Configuration ######

###### Security Configuration ######
network={
        auth_alg=OPEN
        priority=1
        ssid="mavo"
        mode=0
        key_mgmt=WPA-PSK
        psk="pass"
}


but it doesn`t connect automatically even though I set it in the netwok settings.

my network settings:
2,4/5GHz
SSID: mavo
encryption: WPA2
authentication: WPA2-PSK
data-encryption: AES-CCMP

and if I want to connect to the network, I have to authenticate twice as root.
Maybe it has something to do with the rights of my system-user with which I
log on gnome!?


Last edited by arkas on Sun Jun 12, 2011 2:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Sun Jun 12, 2011 1:02 pm    Post subject: Reply with quote

Try starting nm-applet from console to see the errors and messages. Also what is the output of this:
Code:

ps -ef | grep polkit

And things to try:
Edit the line in /etc/dbus-1/system.d/NetworkManager.conf like this
Code:

<deny send_destination="org.freedesktop.NetworkManager"
change into:
<allow send_destination="org.freedesktop.NetworkManager"

Maybe it is not right way but, edit the file /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy
In section "<action id="org.freedesktop.NetworkManager.settings.modify.system">" change the line:
Code:

<allow_active>auth_admin_keep</allow_active>
change into
<allow_active>yes</allow_active>

_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
arkas
n00b
n00b


Joined: 08 Dec 2010
Posts: 60

PostPosted: Sun Jun 12, 2011 2:14 pm    Post subject: Reply with quote

# nm-applet
Code:

GConf-Fehler: Der Konfigurationsserver konnte nicht kontaktiert werden. Die häufigste Ursache ist ein fehlender oder unzureichend konfigurierter D-Bus-Sitzungsdienst. Siehe http://projects.gnome.org/gconf/ für weitere Informationen. (Details -  1: Verbindung zur Sitzung konnte nicht abgerufen werden: Verbindung ist geschlossen)

** (nm-applet:2737): WARNING **: Failed to initialize D-Bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(nm-applet:2737): GConf-WARNING **: Directory `/apps/nm-applet' was not being monitored by GConfClient 0x240bcc0


# ps -ef | grep polkit
Code:

root      2107     1  0 16:07 ?        00:00:00 /usr/libexec/polkitd
root      2815  2695  0 16:18 pts/0    00:00:00 grep --colour=auto polkit


and I don't know which lines to change in
/etc/dbus-1/system.d/NetworkManager.conf:
Code:

<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
        <policy user="root">
                <allow own="org.freedesktop.NetworkManager"/>
                <allow send_destination="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.PPP"/>

                <allow send_interface="org.freedesktop.NetworkManager.SecretAgent"/>
        </policy>
        <policy at_console="true">
                <allow send_destination="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.DBus.Introspectable"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.DBus.Properties"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.AccessPoint"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Connection.Active"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Cdma"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Wired"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Gsm"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Serial"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Wireless"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.DHCP4Config"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.IP4Config"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.VPN.Connection"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.AgentManager"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="SetLogging"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="Sleep"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="sleep"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="wake"/>
        </policy>
        <policy context="default">
                <deny own="org.freedesktop.NetworkManager"/>

                <deny send_destination="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Settings"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.AgentManager"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="SetLogging"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="Sleep"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="sleep"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="wake"/>
        </policy>

        <limit name="max_replies_per_connection">512</limit>
</busconfig>


And the changes in / usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy
have the only effect that I don`t have to ahtenticate as root bevor connecting by hand.
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Sun Jun 12, 2011 4:20 pm    Post subject: Reply with quote

arkas wrote:
# nm-applet
Code:

GConf-Fehler: Der Konfigurationsserver konnte nicht kontaktiert werden. Die häufigste Ursache ist ein fehlender oder unzureichend konfigurierter D-Bus-Sitzungsdienst. Siehe http://projects.gnome.org/gconf/ für weitere Informationen. (Details -  1: Verbindung zur Sitzung konnte nicht abgerufen werden: Verbindung ist geschlossen)

** (nm-applet:2737): WARNING **: Failed to initialize D-Bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(nm-applet:2737): GConf-WARNING **: Directory `/apps/nm-applet' was not being monitored by GConfClient 0x240bcc0


Is your user in plugdev group? Do you have NetworkManager at default runlevel?
Quote:

# ps -ef | grep polkit
Code:

root      2107     1  0 16:07 ?        00:00:00 /usr/libexec/polkitd
root      2815  2695  0 16:18 pts/0    00:00:00 grep --colour=auto polkit


How do you start your gnome-3? If you use gdm-3, you should have "polkit-gnome-authentication-agent-1" running.
Quote:

and I don't know which lines to change in
/etc/dbus-1/system.d/NetworkManager.conf:

For your config, add this to NetworkManager.conf line 78:
Code:

 <policy group="plugdev">
                <allow send_destination="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                      send_interface="org.freedesktop.NetworkManager.PPP"/>
        </policy>

or use this NetworkManager.conf :
Code:

<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
        <policy user="root">
                <allow own="org.freedesktop.NetworkManager"/>
                <allow send_destination="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.PPP"/>

                <allow send_interface="org.freedesktop.NetworkManager.SecretAgent"/>
        </policy>
        <policy at_console="true">
                <allow send_destination="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.DBus.Introspectable"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.DBus.Properties"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.AccessPoint"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Connection.Active"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Cdma"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Wired"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Gsm"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Serial"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Wireless"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.DHCP4Config"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.IP4Config"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.VPN.Connection"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.AgentManager"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="SetLogging"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="Sleep"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="sleep"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="wake"/>
        </policy>
 <policy group="plugdev">
                <allow send_destination="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                      send_interface="org.freedesktop.NetworkManager.PPP"/>
        </policy>
        <policy context="default">
                <deny own="org.freedesktop.NetworkManager"/>

                <deny send_destination="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Settings"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.AgentManager"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="SetLogging"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="Sleep"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="sleep"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="wake"/>
        </policy>

        <limit name="max_replies_per_connection">512</limit>
</busconfig>



Anyway with this setup, nm-applet still does not save as a user. But saves as root. Don't forget to use the check-box giving permissions to all users., so your user can use it.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
arkas
n00b
n00b


Joined: 08 Dec 2010
Posts: 60

PostPosted: Sun Jun 12, 2011 5:31 pm    Post subject: Reply with quote

yes, my user is in the plugdev group and NetworkManager is at default runlevel.

I have done the changes as you said it.

How do I see if polkit-gnome-authentication-agent-1 is running?
Or how can I start it?
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Sun Jun 12, 2011 6:31 pm    Post subject: Reply with quote

arkas wrote:

How do I see if polkit-gnome-authentication-agent-1 is running?

This should list it:
Code:

# ps -ef | grep polkit
since I use kdm,it outputs:
/usr/lib64/kde4/libexec/polkit-kde-authentication-agent-1


Quote:

Or how can I start it?

Actually your login manager should start it. As I asked before, How do you start your gnome-3?
I mean what login manager do you use? gdm, kdm, slim? Since gdm and kdm starts it automatically, I think you use something else like slim, or startx?
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
arkas
n00b
n00b


Joined: 08 Dec 2010
Posts: 60

PostPosted: Sun Jun 12, 2011 6:43 pm    Post subject: Reply with quote

I start gnome3 with gdm 3.0.4

Code:

(20:42:32) mvlap ~ # ps -ef | grep polkit
root      2091     1  0 19:33 ?        00:00:00 /usr/libexec/polkitd
root      2993  2869  0 20:42 pts/0    00:00:00 grep --colour=auto polkit
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Sun Jun 12, 2011 7:39 pm    Post subject: Reply with quote

I read gnome-shell comes with its own implementation of a policy kit agent. So, polkit-gnome-authentication-agent-1 is not needed.
I think, gnome-3 is not ready, yet.
Anyway, since I can't start gnome-3, I am unable to help you more.
I suggest, filling a bug report for nm-aplet at b.g.o.

EDIT: Take a look at here
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
arkas
n00b
n00b


Joined: 08 Dec 2010
Posts: 60

PostPosted: Mon Jun 13, 2011 10:27 am    Post subject: Reply with quote

keenblade wrote:

EDIT: Take a look at here


unfortunately I can't do much because I use gnome and does not know how I should adjust the cmd.
Back to top
View user's profile Send private message
arkas
n00b
n00b


Joined: 08 Dec 2010
Posts: 60

PostPosted: Mon Jun 13, 2011 2:46 pm    Post subject: Reply with quote

I also have a few error messages concerning network manager with which I unfortunately can not start from
/var/log/messages:

these are coming at startup/connecting to wireless lan:

Code:

Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: Loading connections
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: guessed connection type (mavo) = 802-11-wireless
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: update_connection_setting_from_config_block: name:mavo, id:System (mavo), uuid: 0d452f28-9a00-3d40-4caa-bed3022cf681
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: Using mode: infrastructure
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: wireless_setting added for mavo
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: updating wireless security settings (mavo).
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: Found error: Ifnet plugin: can't aquire ip configuration for mavo
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: IPv6 for mavo enabled, using auto
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: Found error: Ifnet plugin: can't aquire ip configuration for mavo
Jun 13 15:59:52 mvlap NetworkManager[2033]: nm_connection_verify: assertion `*error == NULL' failed
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: Found error: Ifnet plugin: can't aquire ip configuration for mavo
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: Connection verified mavo:0
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: guessed connection type (eth0) = 802-3-ethernet
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: update_connection_setting_from_config_block: name:eth0, id:System (eth0), uuid: f3f8b0a6-0bb0-2b7b-9d30-b18634ddb983
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: Using dhcp method for eth0
Jun 13 15:59:52 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: dhcpcd hostname not defined, ignoring


Code:

Jun 13 15:59:31 mvlap polkitd(authority=local): Operator of unix-session:/org/freedesktop/ConsoleKit/Session2 successfully authenticated as unix-user:root to gain TEMPORARY authorization for action org.freedesktop.NetworkManager.settings.modify.system for system-bus-name::1.46 [nm-applet] (owned by unix-user:martin)
Jun 13 15:59:51 mvlap NetworkManager[2033]: get_secret_flags: assertion `is_secret_prop (setting, secret_name, error)' failed
Jun 13 15:59:51 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: update_connection_setting_from_config_block: name:mavo, id:System (mavo), uuid: 0d452f28-9a00-3d40-4caa-bed3022cf681


Code:

Jun 13 15:55:31 mvlap NetworkManager[2033]: <info> Loaded plugin ifnet: (C) 1999-2010 Gentoo Foundation, Inc. To report bugs please use bugs.gentoo.org with [networkmanager] or [qiaomuf] prefix.
Jun 13 15:55:31 mvlap NetworkManager[2033]: <info> Loaded plugin keyfile: (c) 2007 - 2010 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
Jun 13 15:55:31 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: getting unmanaged specs...
Jun 13 15:55:31 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: (32658432) ... get_connections.
Jun 13 15:55:31 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: (32658432) connections count: 1
Jun 13 15:55:31 mvlap NetworkManager[2033]: claim_connection: assertion `nm_connection_get_path (NM_CONNECTION (connection)) == NULL' failed
Jun 13 15:55:31 mvlap NetworkManager[2033]:    keyfile: parsing .keep_net-misc_networkmanager-0 ...
Jun 13 15:55:31 mvlap NetworkManager[2033]:    keyfile:     error: File permissions (100644) or owner (0) were insecure
Jun 13 15:55:31 mvlap NetworkManager[2033]:    SCPlugin-Ifnet: getting unmanaged specs...
Jun 13 15:55:31 mvlap NetworkManager[2033]: <info> trying to start the modem manager...
Jun 13 15:55:31 mvlap dbus[2020]: [system] Activating service name='org.freedesktop.ModemManager' (using servicehelper)
Jun 13 15:55:31 mvlap dbus[2020]: [system] Activating service name='org.freedesktop.PolicyKit1' (using servicehelper)
Jun 13 15:55:31 mvlap modem-manager[2159]: <info>  ModemManager (version 0.4.997) starting...
Jun 13 15:55:31 mvlap dbus[2020]: [system] Successfully activated service 'org.freedesktop.ModemManager'



I found a few more old messages but I could not reproduce them:

Code:

Jun 13 15:21:33 mvlap dbus[2036]: [system] Reloaded configuration
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-network: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.enable-disable-network is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.sleep-wake: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.sleep-wake is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wifi: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.enable-disable-wifi is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wwan: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.enable-disable-wwan is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wimax: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.enable-disable-wimax is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.network-control: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.network-control is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.wifi.share.protected is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.wifi.share.open is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.system: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.settings.modify.system is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.own: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.settings.modify.own is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.hostname: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.settings.modify.hostname is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-network: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.enable-disable-network is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.sleep-wake: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.sleep-wake is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wifi: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.enable-disable-wifi is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wwan: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.enable-disable-wwan is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wimax: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.enable-disable-wimax is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.network-control: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.network-control is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.wifi.share.protected is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.wifi.share.open is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.system: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.settings.modify.system is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.own: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.settings.modify.own is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.hostname: (0) GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.NetworkManager.settings.modify.hostname is not registered
Jun 13 15:21:34 mvlap NetworkManager[2049]:    SCPlugin-Ifnet: getting unmanaged specs...
Jun 13 15:21:34 mvlap NetworkManager[2049]: Error parsing file '/etc/NetworkManager/nm-system-settings.conf': No such file or directory
Jun 13 15:21:34 mvlap NetworkManager[2049]: Error parsing file '/etc/NetworkManager/nm-system-settings.conf': No such file or directory
Jun 13 15:24:18 mvlap dbus[2036]: [system] Reloaded configuration
Back to top
View user's profile Send private message
arkas
n00b
n00b


Joined: 08 Dec 2010
Posts: 60

PostPosted: Mon Jun 13, 2011 3:23 pm    Post subject: Reply with quote

a friend of mine have this problem, too!!
Back to top
View user's profile Send private message
arkas
n00b
n00b


Joined: 08 Dec 2010
Posts: 60

PostPosted: Wed Jul 06, 2011 2:59 pm    Post subject: Reply with quote

no one else can help?
_________________
Also need help with:
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Wed Jul 06, 2011 7:21 pm    Post subject: Reply with quote

arkas, you may try to downgrade nm-applet and networkmanager to v0.8.2 ones, untill they fix it.
Or use net-misc/wicd which is another great wireless network manager.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
arkas
n00b
n00b


Joined: 08 Dec 2010
Posts: 60

PostPosted: Mon Jul 25, 2011 9:09 pm    Post subject: Reply with quote

i think, networkmanager v0.8.2 doesn`t work with gnome3!
_________________
Also need help with:
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Tue Jul 26, 2011 7:39 am    Post subject: Reply with quote

Why don't you give a try to wicd?
Code:

emerge -va net-misc/wicd
rc-update del NetworkManager default
rc-update add wicd default

I always install both wicd and networkmanager. If one them is having trouble, the other one works fine.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
qdii
Tux's lil' helper
Tux's lil' helper


Joined: 19 Sep 2009
Posts: 106
Location: Madrid

PostPosted: Wed Nov 30, 2011 9:10 pm    Post subject: Reply with quote

Hey, I found out this topic. and I’m having the same problem. Anything up ?
Back to top
View user's profile Send private message
alvinwu
n00b
n00b


Joined: 15 Feb 2008
Posts: 47

PostPosted: Sat Dec 03, 2011 10:25 am    Post subject: Reply with quote

Hi,

Try this:

cd /etc/NetworkManager/system-connections

chmod 600 .keep_net-misc_networkmanager-0


That should work...
Back to top
View user's profile Send private message
mathfeel
l33t
l33t


Joined: 03 Aug 2004
Posts: 700

PostPosted: Sun Dec 18, 2011 9:33 am    Post subject: Reply with quote

alvinwu wrote:
Hi,

Try this:

cd /etc/NetworkManager/system-connections

chmod 600 .keep_net-misc_networkmanager-0


That should work...


I am having the same problem. I find .keep_net-misc-networkmanager-0 is already in mod 600:
Code:
# ls -al
total 12
drwxr-xr-x 2 root root 4096 Dec 17 23:17 .
drwxr-xr-x 5 root root 4096 Dec 17 23:17 ..
-rw------- 1 root root  158 Mar 22  2011 Auto eth0
-rw------- 1 root root    0 Dec 17 23:17 .keep_net-misc_networkmanager-0

_________________
-----------------------------------------------------------
"In heaven all the interesting people are missing"
-- Friedrich Nietzsche
Back to top
View user's profile Send private message
iamben
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 275

PostPosted: Wed Dec 28, 2011 12:47 am    Post subject: Reply with quote

see if this helps, it helped me:

https://bugs.gentoo.org/show_bug.cgi?id=364133#c12
Back to top
View user's profile Send private message
alvinwu
n00b
n00b


Joined: 15 Feb 2008
Posts: 47

PostPosted: Sun Jan 01, 2012 9:51 am    Post subject: Reply with quote

Hi,

I'm running networkmanager-0.9.xxx, maybe you can try that.

Here's my nm-system-settings.conf:

Quote:
[main]
plugins=ifnet,keyfile
plugins=keyfile

dhcp=dhcpcd

[logging]
#level=DEBUG
#domains=AGENTS,SETTINGS,SUSPEND

[ifnet]
managed=true
auto_refresh=false


You can turn on the debug key to check for more error messages.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum