Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
e17 and e_hal issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1133
Location: 127.0.0.1

PostPosted: Sun Jun 12, 2011 4:35 pm    Post subject: e17 and e_hal issues Reply with quote

never mind - using xfce now, fed up with wasting my time in trying to get it to work
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
the_mgt
Apprentice
Apprentice


Joined: 05 Aug 2005
Posts: 259
Location: Germany, near Hannover

PostPosted: Mon Jun 13, 2011 9:19 am    Post subject: Reply with quote

Since the global masking of hal useflag, you need to install eeze and e_dbus with udev useflag.

Again, ask in #gentoo-e on freenode, I am idling there 24/7 and you will get faster answers. I am not always browsing the forums.
_________________
Citadel Groupware | Avahi Howto
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1133
Location: 127.0.0.1

PostPosted: Mon Jun 13, 2011 9:21 am    Post subject: Reply with quote

the_mgt wrote:
Since the global masking of hal useflag, you need to install eeze and e_dbus with udev useflag.

Again, ask in #gentoo-e on freenode, I am idling there 24/7 and you will get faster answers. I am not always browsing the forums.


i did add udev use flag to them, and still it gave me the issue above, i have a few things to do (setting up laser printer on linux) then i may consider trying my luck with e17 again
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Mon Jun 13, 2011 9:21 am    Post subject: Reply with quote

I think I found eeze-9999 as a solution for that problem with the first google result. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1133
Location: 127.0.0.1

PostPosted: Mon Jun 13, 2011 9:23 am    Post subject: Reply with quote

genstorm wrote:
I think I found eeze-9999 as a solution for that problem with the first google result. ;)


so did i, and i installed it, with ukit,udev useflags, still it craped out, only thing i did notice was that the working version from overlay (enlightenment) was @ 699, after having to re-install whole laptop due to a complete cock up on my part the version i was pulling down yesterday was @700
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Mon Jun 13, 2011 9:38 am    Post subject: Reply with quote

Hmm, I emerged it on June 11th, 00:16. Anyway, that's it with live ebuilds, always some kind of struggling involved (perhaps >eeze-1.0.1 should be added to the enlightenment deps). Aside from that, e17 currently runs rockstable on my system, and I can't tell the same about supposedly stable KDE 4.6.4 ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
the_mgt
Apprentice
Apprentice


Joined: 05 Aug 2005
Posts: 259
Location: Germany, near Hannover

PostPosted: Mon Jun 13, 2011 4:24 pm    Post subject: Reply with quote

What was your issue? Did you try the places module? Tommy[D] should finally get rid of that one, upstream is unmaintained and it really needs hal on your system.
_________________
Citadel Groupware | Avahi Howto
Back to top
View user's profile Send private message
sera
Retired Dev
Retired Dev


Joined: 29 Feb 2008
Posts: 1017
Location: CET

PostPosted: Tue Jun 14, 2011 8:37 am    Post subject: Reply with quote

the_mgt wrote:
What was your issue? Did you try the places module? Tommy[D] should finally get rid of that one, upstream is unmaintained and it really needs hal on your system.


The latest snapshot did work just fine with in tree deps before. The masking of the hal useflag breaks the ebuild. Well, that's only half the story. Not only got e_dbus-1.0.1 added without a hal useflag but it was removed from earlier versions as well (without rev bump!).

I had to live with hal for 10 years, why should I care if it remains here just a little longer. It's hard to understand the obsession of getting rid of hal at all cost. There are certainly a lot of ebuilds out in the wild which got hurt with this pointless mask, encouraging people to mess with their profile or leaving comments like "never mind - using xfce now, fed up with wasting my time in trying to get it to work" in the forum.
Back to top
View user's profile Send private message
the_mgt
Apprentice
Apprentice


Joined: 05 Aug 2005
Posts: 259
Location: Germany, near Hannover

PostPosted: Tue Jun 14, 2011 11:16 am    Post subject: Reply with quote

I hear you! I also don't understand the obsession, as you call it. It is actually the first time I noticed that a working, stable feature is masked by removing the useflag from profile, when there is not even a security thread.

https://forums.gentoo.org/viewtopic-p-6720636.html#6720636
_________________
Citadel Groupware | Avahi Howto
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum