Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Slim]$PATH incorrect si je passe par slim(résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
elyes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2008
Posts: 121
Location: Calvados Normandie France

PostPosted: Thu Jun 16, 2011 4:48 pm    Post subject: [Slim]$PATH incorrect si je passe par slim(résolu) Reply with quote

Bonjour,

J'ai un problème étrange avec Acroread-9.4.2:
sur l'interface graphique dans un terminal, si lance acroread, bash ne trouve pas la commande:
Code:
$ acroread
bash: acroread: command not found


or si:
- je passe sur une console (Alt + F1 par exemple), il n'y a pas de problème, mon système trouve bien la commande acroread (mais bien entendu, ne se lance pas car Gtk ne peut pas ouvrir un display)
- sous l'interface graphique, si je lui donne le path complet ($ /opt/Adobe/Reader9/bin/acroread) , acroread se lance sans problème
- bien entendu, Firefox, n'ouvre pas les pages pdf, car il ne trouve pas acroread.

avez vous une piste? je suis à la rue :p

Code:
$ emerge --info
Portage 2.1.10.3 (default/linux/x86/10.0/desktop, gcc-4.5.2, glibc-2.13-r2, 3.0.0-rc1 i686)
=================================================================
System uname: Linux-3.0.0-rc1-i686-Intel-R-_Celeron-R-_CPU_2.60GHz-with-gentoo-2.0.2
Timestamp of tree: Thu, 16 Jun 2011 15:45:01 +0000
ccache version 3.1.5 [enabled]
app-shells/bash:          4.2_p10
dev-lang/python:          2.7.1-r1, 3.2
dev-util/ccache:          3.1.5
dev-util/cmake:           2.8.4-r1
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.2-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1-r1
sys-devel/binutils:       2.21
sys-devel/gcc:            4.5.2
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.13-r2
Repositories: gentoo x11 hardened-dev vdr-devel x-local-overlay
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 sun-bcla-java-vm AdobeFlash-10.1"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles fixpackages news nodoc parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://gentoo.imj.fr/pub/gentoo/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo "
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr fr_FR"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/x11 /usr/local/portage/layman/hardened-development /usr/local/portage/layman/vdr-devel /usr/local/portage/local-overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa apm bash-completion berkdb branding bzip2 cairo cdda cddb cdparanoia cdr cli consolekit cracklib crypt css cups cxx dbus dri dts dv dvb dvd dvdr emboss encode evo exif fam ffmpeg firefox flac fontconfig gdbm gdu gif gimp gnutls gpm gsl gstreamer gtk gzip hardened iconv jpeg jpeg2k lame lcms ldap libnotify lzma mad mmap mmx mng modules mp3 mp4 mpeg mplayer mudflap musepack nas ncurses nls nptl nptlonly ogg openal opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support quicktime raw readline recode scanner sdl session sound spell sse sse2 ssl startup-notification svg symlink sysfs tcpd theora threads tiff truetype udev unicode usb v4l v4l2 vcd vorbis wavpack win32codecs wmf x264 x86 xcb xcomposite xft xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="hda-intel intel8x0 intel8x0m" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau" XFCE_PLUGINS="menu trash logout" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Code:
$ emerge -pv acroread

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-text/acroread-9.4.2  USE="cups ldap -minimal -nsplugin" LINGUAS="fr -de -en -ja" 0 kB



Merci,
Elyes

--edit

un autre point qui peut etre lié a ce problème:
bien que j'ai dans mon /etc/make.conf :
LINGUAS="fr fr_FR"
toute mon interface graphique est en anglais. (sauf acroread quand il est lancé en donnant le path complet)

Merci


Last edited by elyes on Sun Jun 19, 2011 10:07 am; edited 4 times in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8132
Location: ~Brussels - Belgique

PostPosted: Thu Jun 16, 2011 5:04 pm    Post subject: Reply with quote

Salut,

As-tu VRAIMENT besoin d'un blob binaire privateur ?
As-tu essayé epdfview par exemple ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
elyes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2008
Posts: 121
Location: Calvados Normandie France

PostPosted: Thu Jun 16, 2011 6:15 pm    Post subject: Reply with quote

XavierMiller wrote:
Salut,

As-tu VRAIMENT besoin d'un blob binaire privateur ?
As-tu essayé epdfview par exemple ?

c'est pas ca le problème :)

je trouve étrange que dans un terminal sous xfce, bash ne trouve pas acroread alors si je me loge juste sur une console (Alt + F1) acroread est bien reconnu.

idem pour gcompris (soft pour les enfants)

merci
Back to top
View user's profile Send private message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 909
Location: Singapour

PostPosted: Thu Jun 16, 2011 6:30 pm    Post subject: Reply with quote

Pour une raison qui m'est totalement inconnue, ta variable d'environnement PATH est incomplète. Chez moi, avec rxvt-unicode sous XFCE j'ai ça:
Code:
$ echo $PATH
/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.2:/usr/games/bin

Donc il faut que tu cherches à savoir pourquoi /opt/bin n'est pas dans ta variable.

Sinon XavierMiller quand je compare la qualité du rendu des fontes entre acroread et epdfview sur mon ordi, acroread gagne la main levée. En fait j'ai testé acroread il y a deux jours, hé ben ça fait du bien de ne plus avoir des textes qui piquent les yeux!
Back to top
View user's profile Send private message
elyes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2008
Posts: 121
Location: Calvados Normandie France

PostPosted: Thu Jun 16, 2011 8:25 pm    Post subject: Reply with quote

Leander256 wrote:
Pour une raison qui m'est totalement inconnue, ta variable d'environnement PATH est incomplète. Chez moi, avec rxvt-unicode sous XFCE j'ai ça:
Code:
$ echo $PATH
/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.2:/usr/games/bin

Donc il faut que tu cherches à savoir pourquoi /opt/bin n'est pas dans ta variable.

Sinon XavierMiller quand je compare la qualité du rendu des fontes entre acroread et epdfview sur mon ordi, acroread gagne la main levée. En fait j'ai testé acroread il y a deux jours, hé ben ça fait du bien de ne plus avoir des textes qui piquent les yeux!


en effet, je ne sais pas pourquoi avec xfce j'ai :
Code:
  $ echo $PATH
/bin:/usr/bin:/usr/local/bin
Back to top
View user's profile Send private message
elyes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2008
Posts: 121
Location: Calvados Normandie France

PostPosted: Sat Jun 18, 2011 8:35 pm    Post subject: Reply with quote

salut,

j'ai solutionné mon problème en apportant une modification a mon /etc/slim.conf:
la ligne:
Code:
default_path        /bin:/usr/bin:/usr/local/bin


devient:
Code:
default_path        /bin:/usr/bin:/usr/local/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.5.2:/usr/games/bin


reste a trouver pourquoi:
si je lance Xfce sans slim, j'ai mon interface en francais mais si je passe par slim, mon Xfce cause english :)

merci
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sat Jun 18, 2011 8:42 pm    Post subject: Reply with quote

Ouh la c'est pas très catholique ça.
Gentoo génère un fichier avec toutes les variables d'environnement (le PATH, et la locale aussi) : /etc/profile.env

Il est sensé être chargé par tous les shells login, et devrait l'être aussi par les sessions X. Si tu n'as ni ton PATH correct ni la locale, je pense que c'est que slim ne charge pas ça... Tu ne vas pas t'amuser à dupliquer tout dans ton slim.conf !

Regardes ici http://en.gentoo-wiki.com/wiki/SLiM#Variant_A En particulier :
Code:
login_cmd  exec /bin/bash -login ~/.xinitrc %session

Le fait de lancer le shell login devrait charger l'environnement de manière correcte !
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
elyes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2008
Posts: 121
Location: Calvados Normandie France

PostPosted: Sat Jun 18, 2011 9:06 pm    Post subject: Reply with quote

oui, je partage ta vision.
sauf que:
- si je lance Xfce sans passer par slim, mes variables $PATH est correcte et j'ai également mon GUI en francais.
- si je lance Xfce en passanr par slim:
Code:
login_cmd    exec ck-launch-session xfce4-session

ou
Code:
login_cmd    exec ck-launch-session startxfce4

ma variable $PATH n'est plus correct :(
je ne trouve pas d'où vient le probleme. j'ai re-emetger slim polkit dbus dbus-glib consolekit pambase xfce4* mais rien ! :'(

je suis à sec!
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sun Jun 19, 2011 7:23 am    Post subject: Reply with quote

elyes wrote:
- si je lance Xfce en passanr par slim:
Code:
login_cmd    exec ck-launch-session xfce4-session

ou
Code:
login_cmd    exec ck-launch-session startxfce4

ma variable $PATH n'est plus correct :(

Ben justement, essaye de mettre :
Code:
login_cmd exec ck-launch-session /bin/bash -login xfce4-session

Pour lancer tout ça dans un shell login qui va charger l'environnement complet
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
elyes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2008
Posts: 121
Location: Calvados Normandie France

PostPosted: Sun Jun 19, 2011 8:10 am    Post subject: Reply with quote

Bonjour,

avec
Code:
login_cmd exec ck-launch-session /bin/bash -login xfce4-session
après la page de login de slim, l'écran reste désespérément noir .

merci
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1699
Location: 127.0.0.1

PostPosted: Sun Jun 19, 2011 8:21 am    Post subject: Reply with quote

Voici comment je fais pour lancer Xfce4 à partir de slim. Dans le slim.conf je laisse la variable login_cmd d'origine :
Code:

$ grep ^login_cmd /etc/slim.conf
login_cmd           exec /bin/bash -login /usr/share/slim/Xsession %session

Je créé un fichier pour définir la session par défaut :
Code:

$ cat /etc/env.d/90xsession
XSESSION="Xfce4"

(ne pas oublier de faire un env-update)



============ OBSOLETE ============
Puis, pour lancer consolekit :
Code:

$ cat /etc/X11/Sessions/Xfce4
ck-launch-session startxfce4

=========== FIN OBSOLETE ===========

Edit 20/10/2001 : attention, avec la dernière version stabilisée de slim (1.3.2-r6), plus besoin de lancer soi-même ck-launch-session : cela a été intégré aux scripts de démarrage de slim.
Plus besoin donc de modifier le fichier /etc/X11/Sessions/Xfce4 :
Code:

$ cat /etc/X11/Sessions/Xfce4
startxfce4




Ainsi la session par défaut est Xfce4, mais tu peux toujours changer de session avec F1 dans slim.

Edit : j'allais oublier : dans le slim.conf, ne pas se fier aux variables sessions et sessiondir pour choisir la session par défaut. Voir le bug #342523.
Dans mon slim.conf les 2 variables sont commentées :
Code:

#sessions            xfce4,icewm,wmaker,blackbox
#sessiondir           /etc/X11/Sessions


Last edited by netfab on Thu Oct 20, 2011 10:17 am; edited 1 time in total
Back to top
View user's profile Send private message
elyes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2008
Posts: 121
Location: Calvados Normandie France

PostPosted: Sun Jun 19, 2011 10:05 am    Post subject: Reply with quote

netfab wrote:
Voici comment je fais pour lancer Xfce4 à partir de slim. Dans le slim.conf je laisse la variable login_cmd d'origine :
Code:

$ grep ^login_cmd /etc/slim.conf
login_cmd           exec /bin/bash -login /usr/share/slim/Xsession %session

Je créé un fichier pour définir la session par défaut :
Code:

$ cat /etc/env.d/90xsession
XSESSION="Xfce4"

(ne pas oublier de faire un env-update)
Puis, pour lancer consolekit :
Code:

$ cat /etc/X11/Sessions/Xfce4
ck-launch-session startxfce4

Ainsi la session par défaut est Xfce4, mais tu peux toujours changer de session avec F1 dans slim.

Edit : j'allais oublier : dans le slim.conf, ne pas se fier aux variables sessions et sessiondir pour choisir la session par défaut. Voir le bug #342523.
Dans mon slim.conf les 2 variables sont commentées :
Code:

#sessions            xfce4,icewm,wmaker,blackbox
#sessiondir           /etc/X11/Sessions


Yes, solved :D

merci a vous tous
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum